summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-12-01 17:30:05 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-06 13:08:30 +0100
commit4ae0bea8d39f6dab75b99dcc19410ee086fcdae7 (patch)
tree334c259e7c7c4d8beb081c7e38ef5c114a6dc0c2 /meta-efl/recipes-efl/efl
parentc2660eb5c61aaa044d5acad35067e48f3d11ceda (diff)
downloadmeta-openembedded-4ae0bea8d39f6dab75b99dcc19410ee086fcdae7.tar.gz
libeflvala: try to fix build
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/efl')
-rw-r--r--meta-efl/recipes-efl/efl/libeflvala/0001-BINDINS-vala-update-genlist-gengrid-callbacks-s-labe.patch97
-rw-r--r--meta-efl/recipes-efl/efl/libeflvala_svn.bb4
2 files changed, 100 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/efl/libeflvala/0001-BINDINS-vala-update-genlist-gengrid-callbacks-s-labe.patch b/meta-efl/recipes-efl/efl/libeflvala/0001-BINDINS-vala-update-genlist-gengrid-callbacks-s-labe.patch
new file mode 100644
index 000000000..90c0de6e2
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/libeflvala/0001-BINDINS-vala-update-genlist-gengrid-callbacks-s-labe.patch
@@ -0,0 +1,97 @@
1From 3e51778fdba36c81204b9eca81e67624c6401972 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 1 Dec 2011 17:28:38 +0100
4Subject: [PATCH] BINDINS/vala: update genlist/gengrid callbacks
5 s/label_get/text_get/g
6
7Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
8---
9 BINDINGS/vala/examples/elementary/genlist.vala | 2 +-
10 BINDINGS/vala/vapi/elementary.vapi | 16 ++++++++--------
11 2 files changed, 9 insertions(+), 9 deletions(-)
12
13diff --git a/examples/elementary/genlist.vala b/examples/elementary/genlist.vala
14index b9fb42b..3a4a3b1 100644
15--- a/examples/elementary/genlist.vala
16+++ b/examples/elementary/genlist.vala
17@@ -53,7 +53,7 @@ public class T.Genlist : T.Abstract
18 public static string getText( Elm.Object obj, string part )
19 {
20 int number = (int)obj;
21- debug( "label_get: %p", obj );
22+ debug( "text_get: %p", obj );
23 return "This is list item #%d".printf( number );
24 }
25 public static Elm.Object? getContent( Elm.Object obj, string part )
26diff --git a/vapi/elementary.vapi b/vapi/elementary.vapi
27index 8a6cc17..90b50f5c7 100644
28--- a/vapi/elementary.vapi
29+++ b/vapi/elementary.vapi
30@@ -842,7 +842,7 @@ public class MenuItem
31 public Elm.Object object_get();
32 public void label_set( string label );
33 //public void del_cb_set( ... );
34- public unowned string label_get();
35+ public unowned string text_get();
36 public void icon_set( Elm.Object icon );
37 public void disabled_set( bool disabled );
38 public void* item_data_get();
39@@ -908,7 +908,7 @@ public class Slider : Elm.Object
40 public Slider( Elm.Object? parent );
41
42 public void label_set( string label );
43- public unowned string label_get();
44+ public unowned string text_get();
45 public void icon_set( Elm.Object icon );
46 public Elm.Object icon_get();
47 public void span_size_set( Evas.Coord size );
48@@ -931,8 +931,8 @@ public enum GenlistItemFlags
49 SUBITEMS,
50 }
51
52-[CCode (cname = "Elm_Gen_Item_Label_Get_Cb", has_target = false)]
53-public delegate string GenlistItemLabelGetFunc( Elm.Object obj, string part );
54+[CCode (cname = "Elm_Gen_Item_Text_Get_Cb", has_target = false)]
55+public delegate string GenlistItemTextGetFunc( Elm.Object obj, string part );
56 [CCode (cname = "Elm_Gen_Item_Content_Get_Cb", has_target = false)]
57 public delegate Elm.Object? GenlistItemContentGetFunc( Elm.Object obj, string part );
58 [CCode (cname = "Elm_Gen_Item_State_Get_Cb", has_target = false)]
59@@ -944,7 +944,7 @@ public delegate void GenlistItemDelFunc( Elm.Object obj );
60 [CCode (cname = "Elm_Gen_Item_Class_Func", destroy_function = "")]
61 public struct GenlistItemClassFunc
62 {
63- public GenlistItemLabelGetFunc text_get;
64+ public GenlistItemTextGetFunc text_get;
65 public GenlistItemContentGetFunc content_get;
66 public GenlistItemStateGetFunc state_get;
67 public GenlistItemDelFunc del;
68@@ -1027,7 +1027,7 @@ public class Check : Elm.Object
69 public Check( Elm.Object? parent );
70
71 public void label_set( string label );
72- public unowned string label_get();
73+ public unowned string text_get();
74 public void icon_set( Elm.Object icon );
75 public Elm.Object icon_get();
76 public void state_set( bool state );
77@@ -1044,7 +1044,7 @@ public class Radio : Elm.Object
78 public Radio( Elm.Object? parent );
79
80 public void label_set( string label );
81- public unowned string label_get();
82+ public unowned string text_get();
83 public void icon_set( Elm.Object icon );
84 public Elm.Object icon_get();
85 public void group_add( Elm.Object group );
86@@ -1256,7 +1256,7 @@ public class ListItem
87 public void selected_set( bool selected );
88 public void show();
89 public void* data_get();
90- public unowned string label_get();
91+ public unowned string text_get();
92 public void label_set( string label );
93 public Elm.Object icon_get();
94 public void icon_set( Elm.Object icon );
95--
961.7.8.rc4
97
diff --git a/meta-efl/recipes-efl/efl/libeflvala_svn.bb b/meta-efl/recipes-efl/efl/libeflvala_svn.bb
index f70f9530b..e2450aa89 100644
--- a/meta-efl/recipes-efl/efl/libeflvala_svn.bb
+++ b/meta-efl/recipes-efl/efl/libeflvala_svn.bb
@@ -12,7 +12,9 @@ SRCNAME = "vala"
12 12
13inherit e-base autotools pkgconfig vala 13inherit e-base autotools pkgconfig vala
14 14
15SRC_URI = "${E_SVN}/trunk/BINDINGS;module=${SRCNAME};proto=http" 15SRC_URI = "${E_SVN}/trunk/BINDINGS;module=${SRCNAME};proto=http \
16 file://0001-BINDINS-vala-update-genlist-gengrid-callbacks-s-labe.patch \
17"
16S = "${WORKDIR}/${SRCNAME}" 18S = "${WORKDIR}/${SRCNAME}"
17 19
18PACKAGES =+ "${PN}-examples" 20PACKAGES =+ "${PN}-examples"