summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/exquisite_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
commit7d995c58b1f3c34874110f6040021fd83d618732 (patch)
tree21db911783f88a232b3bc5a0f669b73833f63f1c /meta-efl/recipes-efl/e17/exquisite_svn.bb
parent1c2cf0868bcf72847a3150416f5b48e94ba512d4 (diff)
downloadmeta-openembedded-7d995c58b1f3c34874110f6040021fd83d618732.tar.gz
meta-efl: import from meta-shr.
Not all dependencies are in yet e.g. eve is missing webkit-efl, but e-wm should build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl/recipes-efl/e17/exquisite_svn.bb')
-rw-r--r--meta-efl/recipes-efl/e17/exquisite_svn.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/exquisite_svn.bb b/meta-efl/recipes-efl/e17/exquisite_svn.bb
new file mode 100644
index 000000000..fcfb65cf8
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/exquisite_svn.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "A psplash replacement for display"
2LICENSE = "MIT BSD"
3DEPENDS = "eet evas ecore embryo edje"
4PV = "0.0.1+svnr${SRCPV}"
5PR = "r11"
6SRCREV = "${EFL_SRCREV}"
7RRECOMMENDS_${PN} = "exquisite-themes"
8RCONFLICTS_${PN} = "psplash virtual-psplash"
9
10SRCNAME = "exquisite"
11
12inherit e
13SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
14S = "${WORKDIR}/${SRCNAME}"
15
16EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
17
18SRC_URI += "file://exquisite-init"
19SRC_URI += "file://splashfuncs"
20
21inherit update-rc.d
22
23do_install_prepend() {
24 install -d ${D}/mnt/.splash/
25 install -d ${D}${sysconfdir}/init.d
26 install -m 0755 ${WORKDIR}/exquisite-init ${D}${sysconfdir}/init.d/exquisite
27 install -d ${D}${sysconfdir}/default
28 install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
29 install -d ${D}${bindir}
30 ln -s exquisite-write ${D}${bindir}/splash-write
31}
32
33
34do_install_append() {
35 rm -rf ${D}${datadir}/exquisite/data/fonts/*
36}
37
38INITSCRIPT_NAME = "exquisite"
39INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
40
41FILES_${PN} += "/mnt/.splash/"