summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-devtools
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-efl/recipes-devtools
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-efl/recipes-devtools')
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc50
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc75
-rw-r--r--meta-efl/recipes-devtools/python/python-efl_1.11.0.bb4
-rw-r--r--meta-efl/recipes-devtools/python/python-efl_git.bb8
5 files changed, 143 insertions, 0 deletions
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
new file mode 100644
index 000000000..1d8098f60
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -0,0 +1,50 @@
1DESCRIPTION = "${PN} bindings"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
5# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
6# we need to build pyrex otherwise cython doesn't get called to build
7# the extension modules.
8DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus"
9RDEPENDS_${PN} += "python-lang python-dbus"
10
11# necessary to let the call for python-config succeed
12export BUILD_SYS
13export HOST_SYS
14
15inherit e-base autotools pkgconfig distutils-base
16
17SRCNAME = "python-e_dbus"
18SRCVER = "${PV}"
19
20SRC_URI = "\
21 ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
22"
23S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
24
25
26do_configure_prepend() {
27 # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
28 sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
29}
30
31do_install_append() {
32 if [ -e examples ]; then
33 for i in `find examples -name "*.edc"`; do
34 cd ${S}/`dirname $i`
35 echo "Generating .edj file for $i..."
36 edje_cc `basename $i`
37 echo "Removing sources in this directory..."
38 rm -f *.edc *.png *.ttf *.jpeg
39 done
40 cd ${S}
41 install -d ${D}${datadir}/${PN}/
42 cp -a examples ${D}${datadir}/${PN}/
43 find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
44 fi
45}
46
47FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
48
49PACKAGES += "${PN}-examples"
50FILES_${PN}-examples = "${datadir}/${PN}/examples"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb b/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
new file mode 100644
index 000000000..9e5ff0a02
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
@@ -0,0 +1,6 @@
1require ${BPN}.inc
2
3PR = "r1"
4
5SRC_URI[md5sum] = "40b479444bb06147429a276127981890"
6SRC_URI[sha256sum] = "78e5ca334ee25185748660b4e612f984f4d3bced018f062278701429868f117b"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
new file mode 100644
index 000000000..978051889
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -0,0 +1,75 @@
1DESCRIPTION = "${PN} bindings"
2
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
5# there is also GPLv3.0 in COPYING;md5=d32239bcb673463ab874e80d47fae504 but no file seems to use that
6
7AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
8# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
9# we need to build pyrex otherwise cython doesn't get called to build
10# the extension modules.
11DEPENDS = "python-cython-native python-pyrex-native python-numeric python-dbus lua efl elementary"
12RDEPENDS_${PN} += "python-lang"
13
14PROVIDES = "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas"
15
16# necessary to let the call for python-config succeed
17export BUILD_SYS
18export HOST_SYS
19
20inherit e-base distutils pkgconfig
21
22SRCVER = "${PV}"
23
24SRC_URI = "\
25 ${E_RELEASES}/bindings/python/${SRCNAME}-${SRCVER}.tar.gz \
26"
27S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
28
29do_install_append() {
30 # drop all .pyo, pyc files
31 find ${D}${libdir}/${PYTHON_DIR}/site-packages -name \*.pyo -o -name \*.pyc | xargs rm -f
32}
33
34PACKAGES += "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas python-ethumb ${PN}-examples"
35
36FILES_${PN} = " \
37 ${libdir}/${PYTHON_DIR}/site-packages/python_efl*egg-info \
38 ${libdir}/${PYTHON_DIR}/site-packages/efl/eo.so \
39 ${libdir}/${PYTHON_DIR}/site-packages/efl/utils \
40 ${libdir}/${PYTHON_DIR}/site-packages/efl/__init__.py \
41"
42FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
43FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/*/*.la"
44
45FILES_${PN}-examples = "${datadir}/${PN}/examples"
46
47FILES_python-ecore = " \
48 ${libdir}/${PYTHON_DIR}/site-packages/ecore/ \
49 ${libdir}/${PYTHON_DIR}/site-packages/efl/ecore.so \
50 ${libdir}/${PYTHON_DIR}/site-packages/efl/ecore \
51"
52FILES_python-eldbus = " \
53 ${libdir}/${PYTHON_DIR}/site-packages/e_dbus/ \
54 ${libdir}/${PYTHON_DIR}/site-packages/efl/dbus_mainloop.so \
55"
56FILES_python-edje = " \
57 ${libdir}/${PYTHON_DIR}/site-packages/edje/ \
58 ${libdir}/${PYTHON_DIR}/site-packages/efl/edje*so \
59"
60FILES_python-elementary = " \
61 ${libdir}/${PYTHON_DIR}/site-packages/elementary/ \
62 ${libdir}/${PYTHON_DIR}/site-packages/efl/elementary/ \
63"
64FILES_python-emotion = " \
65 ${libdir}/${PYTHON_DIR}/site-packages/emotion/ \
66 ${libdir}/${PYTHON_DIR}/site-packages/efl/emotion.so \
67"
68FILES_python-evas = " \
69 ${libdir}/${PYTHON_DIR}/site-packages/evas/ \
70 ${libdir}/${PYTHON_DIR}/site-packages/efl/evas.so \
71"
72FILES_python-ethumb = " \
73 ${libdir}/${PYTHON_DIR}/site-packages/ethumb/ \
74 ${libdir}/${PYTHON_DIR}/site-packages/efl/ethumb*so \
75"
diff --git a/meta-efl/recipes-devtools/python/python-efl_1.11.0.bb b/meta-efl/recipes-devtools/python/python-efl_1.11.0.bb
new file mode 100644
index 000000000..379b1becd
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-efl_1.11.0.bb
@@ -0,0 +1,4 @@
1require ${BPN}.inc
2
3SRC_URI[md5sum] = "b378f48ae4defbcb7c3e82479d106cfc"
4SRC_URI[sha256sum] = "e147b5c8995afbae691b90385ec3b008f9675207c7aa3c3bb724c57d9bcf8ed5"
diff --git a/meta-efl/recipes-devtools/python/python-efl_git.bb b/meta-efl/recipes-devtools/python/python-efl_git.bb
new file mode 100644
index 000000000..b776f7da3
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-efl_git.bb
@@ -0,0 +1,8 @@
1require ${BPN}.inc
2
3SRCREV = "c1497e10288589ff9834f3d4da17461b8a3a1c15"
4PV = "1.10.0+git${SRCPV}"
5
6SRC_URI = "git://git.enlightenment.org/bindings/python/${BPN}.git;branch=python-efl-1.10"
7
8S = "${WORKDIR}/git"