diff options
author | Jeremy Kerr <jk@codeconstruct.com.au> | 2021-12-17 10:59:10 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-12-21 18:49:37 -0800 |
commit | 022317805b09942790e664cef68e9a1d17838caf (patch) | |
tree | 0b0ba197afbd3f1d04897e933f51c51a53909915 /contrib | |
parent | b6eb9036eb4e007c8e1b622da72af468b58fe3ef (diff) | |
download | meta-openembedded-022317805b09942790e664cef68e9a1d17838caf.tar.gz |
contrib: allow override-style syntax for vars & routines
Currently, the variable and routine regexes don't support the
override-style syntax. This means we may break routine blocks, as we
don't recognise overridden routines with an :append/:prepend/etc.
This change adds the ":" char to the var & routine regexes.
Signed-off-by: Jeremy Kerr <jk@codeconstruct.com.au>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'contrib')
-rwxr-xr-x | contrib/oe-stylize.py | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/oe-stylize.py b/contrib/oe-stylize.py index e1ba1b3218..67c06b1bb5 100755 --- a/contrib/oe-stylize.py +++ b/contrib/oe-stylize.py | |||
@@ -210,8 +210,8 @@ OE_vars = [ | |||
210 | 'others' | 210 | 'others' |
211 | ] | 211 | ] |
212 | 212 | ||
213 | varRegexp = r'^([a-zA-Z_0-9${}-]*)([ \t]*)([+.:]?=[+.]?)([ \t]*)([^\t]+)' | 213 | varRegexp = r'^([a-zA-Z_0-9${}:-]*)([ \t]*)([+.:]?=[+.]?)([ \t]*)([^\t]+)' |
214 | routineRegexp = r'^([a-zA-Z0-9_ ${}-]+?)\(' | 214 | routineRegexp = r'^([a-zA-Z0-9_ ${}:-]+?)\(' |
215 | 215 | ||
216 | # Variables seen in the processed .bb | 216 | # Variables seen in the processed .bb |
217 | seen_vars = {} | 217 | seen_vars = {} |