summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-08 18:21:07 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-09 10:55:23 -0800
commitfdfd5109923c4fb1d8da685642637901507269dc (patch)
tree0221af396e10ac99c3bd9f83065c53adff55ac55
parent2da0ae3cb2c17fc10c23153fa79dd60898818922 (diff)
downloadmeta-openembedded-fdfd5109923c4fb1d8da685642637901507269dc.tar.gz
remove obsolete PIP_INSTALL_PACKAGE and PIP_INSTALL_DIST_PATH
All downloaded files and sstates for the recipes were cleaned, build was got from stratch and no errors were encoutered. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb2
-rw-r--r--meta-oe/recipes-support/libiio/libiio_0.25.bb1
-rw-r--r--meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb2
-rw-r--r--meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-astor_0.8.1.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-dbussy_1.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-gcovr_7.2.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-inotify_git.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-monotonic_1.6.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb2
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb2
-rw-r--r--meta-python/recipes-extended/python-cson/python3-cson_git.bb2
-rw-r--r--meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb2
26 files changed, 0 insertions, 47 deletions
diff --git a/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
index e129c18d6..a98dfab6d 100644
--- a/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
+++ b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae
10 10
11inherit setuptools3 11inherit setuptools3
12 12
13PIP_INSTALL_PACKAGE = "python_distutils_extra"
14
15S = "${WORKDIR}/python-distutils-extra-${PV}" 13S = "${WORKDIR}/python-distutils-extra-${PV}"
16 14
17BBCLASSEXTEND = "native" 15BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/libiio/libiio_0.25.bb b/meta-oe/recipes-support/libiio/libiio_0.25.bb
index 9f3fcc008..2c6d2b514 100644
--- a/meta-oe/recipes-support/libiio/libiio_0.25.bb
+++ b/meta-oe/recipes-support/libiio/libiio_0.25.bb
@@ -73,7 +73,6 @@ do_compile() {
73 cmake_do_compile 73 cmake_do_compile
74} 74}
75 75
76PIP_INSTALL_PACKAGE = "pylibiio"
77do_install() { 76do_install() {
78 if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then 77 if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then
79 setuptools3_do_install 78 setuptools3_do_install
diff --git a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
index ef1b6e537..c5dfff225 100644
--- a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
+++ b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f489
10 10
11inherit setuptools3 11inherit setuptools3
12 12
13PIP_INSTALL_DIST_PATH = "${B}/python/python3/dist"
14
15SETUPTOOLS_SETUP_PATH = "${S}/python" 13SETUPTOOLS_SETUP_PATH = "${S}/python"
16 14
17do_install:append() { 15do_install:append() {
diff --git a/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
index ef6375546..ab39606bd 100644
--- a/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
+++ b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
@@ -17,5 +17,3 @@ SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit setuptools3 19inherit setuptools3
20
21PIP_INSTALL_PACKAGE = "txWS"
diff --git a/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb b/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
index 54e43e375..bc3315f75 100644
--- a/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
@@ -10,7 +10,6 @@ SRC_URI = "git://github.com/berkerpeksag/astor.git;branch=master;protocol=https
10SRCREV ?= "c7553c79f9222e20783fe9bd8a553f932e918072" 10SRCREV ?= "c7553c79f9222e20783fe9bd8a553f932e918072"
11 11
12inherit setuptools3 12inherit setuptools3
13PIP_INSTALL_PACKAGE = "astor"
14 13
15S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
16 15
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
index bcb68d771..ac76ccc96 100644
--- a/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
@@ -7,7 +7,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996"
7SRC_URI[sha256sum] = "78e73e19c63f5b20ffa567001531680d939dc042bf7850431877645523c66709" 7SRC_URI[sha256sum] = "78e73e19c63f5b20ffa567001531680d939dc042bf7850431877645523c66709"
8 8
9PYPI_PACKAGE = "python-dateutil" 9PYPI_PACKAGE = "python-dateutil"
10PIP_INSTALL_PACKAGE = "python_dateutil"
11inherit pypi python_setuptools_build_meta 10inherit pypi python_setuptools_build_meta
12 11
13PACKAGES =+ "${PN}-zoneinfo" 12PACKAGES =+ "${PN}-zoneinfo"
diff --git a/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb b/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
index b1ba95392..59da4545a 100644
--- a/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
@@ -12,8 +12,6 @@ S = "${WORKDIR}/git"
12 12
13inherit setuptools3 13inherit setuptools3
14 14
15PIP_INSTALL_PACKAGE = "DBussy"
16
17RDEPENDS:${PN} += "\ 15RDEPENDS:${PN} += "\
18 python3-asyncio \ 16 python3-asyncio \
19 python3-core \ 17 python3-core \
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb b/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
index 2965e2f09..8a61a2de0 100644
--- a/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
@@ -10,7 +10,6 @@ SRCREV = "c4b74b0859611283be646d590c7915e787911b6f"
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12inherit setuptools3 12inherit setuptools3
13PIP_INSTALL_PACKAGE = "gcovr"
14 13
15RDEPENDS:${PN} += "python3-jinja2 python3-lxml python3-setuptools python3-pygments python3-multiprocessing" 14RDEPENDS:${PN} += "python3-jinja2 python3-lxml python3-setuptools python3-pygments python3-multiprocessing"
16 15
diff --git a/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb b/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb
index bdf4fc538..ceba10b65 100644
--- a/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb
@@ -13,7 +13,6 @@ SRC_URI = "git://github.com/geomet/geomet.git;protocol=https;branch=master"
13SRCREV = "6ac73c312b52aca328db2e61d90c5e363b62639f" 13SRCREV = "6ac73c312b52aca328db2e61d90c5e363b62639f"
14 14
15inherit setuptools3 15inherit setuptools3
16PIP_INSTALL_PACKAGE = "geomet"
17 16
18RDEPENDS:${PN} += "\ 17RDEPENDS:${PN} += "\
19 python3-click \ 18 python3-click \
diff --git a/meta-python/recipes-devtools/python/python3-inotify_git.bb b/meta-python/recipes-devtools/python/python3-inotify_git.bb
index 657f610bd..582599bca 100644
--- a/meta-python/recipes-devtools/python/python3-inotify_git.bb
+++ b/meta-python/recipes-devtools/python/python3-inotify_git.bb
@@ -16,9 +16,6 @@ SRCREV = "9be6a51d1660991562eefaaddefa757ca0e0e00f"
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18inherit setuptools3 ptest 18inherit setuptools3 ptest
19PIP_INSTALL_PACKAGE = "inotify"
20PIP_INSTALL_DIST_PATH = "${S}/dist"
21
22 19
23RDEPENDS:${PN} += " \ 20RDEPENDS:${PN} += " \
24 python3-ctypes \ 21 python3-ctypes \
diff --git a/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb b/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb
index 6c2af0d4e..ba1819979 100644
--- a/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb
+++ b/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb
@@ -7,11 +7,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=366e2fd3c9714f162d3663b6f97cfe41"
7SRC_URI = "git://github.com/keras-team/keras-applications.git;branch=master;protocol=https" 7SRC_URI = "git://github.com/keras-team/keras-applications.git;branch=master;protocol=https"
8SRCREV ?= "3b180cb10eda683dda7913ecee2e6487288d292d" 8SRCREV ?= "3b180cb10eda683dda7913ecee2e6487288d292d"
9 9
10
11inherit setuptools3 10inherit setuptools3
12 11
13PIP_INSTALL_PACKAGE = "Keras_Applications"
14
15S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
16 13
17BBCLASSEXTEND = "native" 14BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
index 9e791c6e7..991aa0f7d 100644
--- a/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
@@ -5,7 +5,6 @@ LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09"
6 6
7inherit setuptools3 pkgconfig features_check 7inherit setuptools3 pkgconfig features_check
8PIP_INSTALL_PACKAGE = "Kivy"
9 8
10# Kivy's setup files only look for GLES libraries for Android, iOS, RPi, 9# Kivy's setup files only look for GLES libraries for Android, iOS, RPi,
11# and mali-based OS's. We need to patch the setup file to tell Kivy setup 10# and mali-based OS's. We need to patch the setup file to tell Kivy setup
diff --git a/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb b/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb
index 673d32c2d..8cd60d3a0 100644
--- a/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb
+++ b/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb
@@ -17,7 +17,6 @@ RDEPENDS:${PN} = " \
17" 17"
18 18
19inherit setuptools3 19inherit setuptools3
20PIP_INSTALL_PACKAGE = "lrparsing"
21 20
22S = "${WORKDIR}/lrparsing-${PV}" 21S = "${WORKDIR}/lrparsing-${PV}"
23 22
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb
index 5a0a79a54..bf1d8dd29 100644
--- a/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "4e65e9e0d80fc9e609574b9983cf32579f305c718afb30d7233ab81857
10 10
11inherit python_flit_core pypi ptest 11inherit python_flit_core pypi ptest
12 12
13PIP_INSTALL_PACKAGE = "marshmallow"
14
15SRC_URI += " \ 13SRC_URI += " \
16 file://run-ptest \ 14 file://run-ptest \
17" 15"
diff --git a/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb b/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb
index 2af7b5792..aacc32a6d 100644
--- a/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb
+++ b/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb
@@ -11,5 +11,3 @@ SRC_URI = "git://github.com/atdt/monotonic.git;branch=master;protocol=https"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13inherit setuptools3 13inherit setuptools3
14
15PIP_INSTALL_PACKAGE = "monotonic"
diff --git a/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
index f3e071108..50dae7b40 100644
--- a/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
+++ b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
@@ -7,9 +7,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=38066667888b01d8118ff9cc23da1873"
7inherit setuptools3 pypi ptest 7inherit setuptools3 pypi ptest
8SRC_URI[sha256sum] = "82e6114004b3d6911c77c3953e3838654b04511b8b66e8583db70c65998017dc" 8SRC_URI[sha256sum] = "82e6114004b3d6911c77c3953e3838654b04511b8b66e8583db70c65998017dc"
9 9
10PIP_INSTALL_PACKAGE = "pefile"
11PIP_INSTALL_DIST_PATH = "${S}/dist"
12
13BBCLASSEXTEND = "native nativesdk" 10BBCLASSEXTEND = "native nativesdk"
14 11
15RDEPENDS:${PN} += " \ 12RDEPENDS:${PN} += " \
diff --git a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb b/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
index 91b02ea01..e795bd491 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
@@ -14,9 +14,6 @@ SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c"
14 14
15inherit setuptools3 ptest 15inherit setuptools3 ptest
16 16
17PIP_INSTALL_PACKAGE = "Pillow"
18PIP_INSTALL_DIST_PATH = "${S}/dist"
19
20DEPENDS += " \ 17DEPENDS += " \
21 zlib \ 18 zlib \
22 jpeg \ 19 jpeg \
diff --git a/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
index a45ef45f3..a4732993f 100644
--- a/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
@@ -15,7 +15,6 @@ SRC_URI = "git://github.com/seveas/python-prctl;protocol=https;branch=main \
15 file://0001-support-cross-complication.patch \ 15 file://0001-support-cross-complication.patch \
16" 16"
17inherit setuptools3 python3native 17inherit setuptools3 python3native
18PIP_INSTALL_PACKAGE = "python_prctl"
19 18
20DEPENDS += "libcap" 19DEPENDS += "libcap"
21 20
diff --git a/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb b/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb
index 97985a8a1..5be6e6319 100644
--- a/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb
@@ -9,8 +9,6 @@ S = "${WORKDIR}/git"
9 9
10inherit setuptools3 10inherit setuptools3
11 11
12PIP_INSTALL_PACKAGE = "PyMetno"
13
14RDEPENDS:${PN} = "\ 12RDEPENDS:${PN} = "\
15 python3-aiohttp (>=3.6.1) \ 13 python3-aiohttp (>=3.6.1) \
16 python3-async-timeout (>=3.0.1) \ 14 python3-async-timeout (>=3.0.1) \
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
index dcde77db0..e9000dd47 100644
--- a/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
@@ -7,8 +7,6 @@ SRC_URI[sha256sum] = "bdf2d54b297ad890418179b044dd4ea79821fccef723823919d12262e9
7 7
8inherit python_poetry_core pypi 8inherit python_poetry_core pypi
9 9
10PIP_INSTALL_PACKAGE = "pymisp"
11
12RDEPENDS:${PN} += " \ 10RDEPENDS:${PN} += " \
13 python3-dateutil \ 11 python3-dateutil \
14 python3-json \ 12 python3-json \
diff --git a/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb b/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb
index 7a9663514..2807c054d 100644
--- a/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb
@@ -24,8 +24,6 @@ S = "${WORKDIR}/git"
24 24
25inherit python_setuptools3_rust cargo-update-recipe-crates 25inherit python_setuptools3_rust cargo-update-recipe-crates
26 26
27PIP_INSTALL_DIST_PATH = "${S}/dist"
28
29# crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64 27# crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64
30# not supported on mips/powerpc with 32-bit pointers 28# not supported on mips/powerpc with 32-bit pointers
31# https://doc.rust-lang.org/std/sync/atomic/#portability 29# https://doc.rust-lang.org/std/sync/atomic/#portability
diff --git a/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb b/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
index 7373b02f5..b6680568b 100644
--- a/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
+++ b/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
@@ -34,4 +34,3 @@ RDEPENDS:${PN} += "\
34CLEANBROKEN = "1" 34CLEANBROKEN = "1"
35 35
36inherit setuptools3 36inherit setuptools3
37PIP_INSTALL_PACKAGE = "slip"
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
index 8a9af14d3..aedf483be 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
@@ -17,8 +17,6 @@ SRCREV = "b8d573e11ec149da695d695c81a156232b89a949"
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit ptest setuptools3 19inherit ptest setuptools3
20PIP_INSTALL_PACKAGE = "xlrd"
21PIP_INSTALL_DIST_PATH = "${S}/dist"
22 20
23RDEPENDS:${PN} += " \ 21RDEPENDS:${PN} += " \
24 python3-compression \ 22 python3-compression \
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
index b6e04e081..7c30f5630 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
@@ -13,8 +13,6 @@ S = "${WORKDIR}/git"
13inherit features_check setuptools3 13inherit features_check setuptools3
14REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data" 14REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data"
15 15
16PIP_INSTALL_PACKAGE = "blivet_gui"
17
18RDEPENDS:${PN} = "python3-pygobject python3 \ 16RDEPENDS:${PN} = "python3-pygobject python3 \
19 python3-blivet gtk+3 \ 17 python3-blivet gtk+3 \
20 python3-pid libreport \ 18 python3-pid libreport \
diff --git a/meta-python/recipes-extended/python-cson/python3-cson_git.bb b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
index aba1d8fff..489733c76 100644
--- a/meta-python/recipes-extended/python-cson/python3-cson_git.bb
+++ b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
@@ -18,8 +18,6 @@ RDEPENDS:${PN} = "python3-json"
18 18
19inherit setuptools3 19inherit setuptools3
20 20
21PIP_INSTALL_PACKAGE = "python_cson"
22
23do_configure:prepend() { 21do_configure:prepend() {
24 echo "__version__=${PV}" > ${S}/version.py 22 echo "__version__=${PV}" > ${S}/version.py
25} 23}
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
index 3c6c47832..953068f7c 100644
--- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
+++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
@@ -23,5 +23,3 @@ SRCREV = "fa6c80c0e5c6bee29d089899a10d26e6f7f8afd8"
23UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)" 23UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
24 24
25inherit setuptools3 25inherit setuptools3
26PIP_INSTALL_PACKAGE = "pykickstart"
27PIP_INSTALL_DIST_PATH = "${S}/dist"