summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-06 17:11:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-12 12:06:01 +0200
commitfc7eda558f058317789680d13149af63d86e372d (patch)
tree8e3743b766620a548f1d2dd3725684d3008cbfe1
parent1295dedccd2744970cea8dba7157432323936f3b (diff)
downloadmeta-openembedded-fc7eda558f058317789680d13149af63d86e372d.tar.gz
llvm: use newer class-native overrides instead of virtclass
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/llvm/llvm-common.bb2
-rw-r--r--meta-oe/recipes-core/llvm/llvm2.inc10
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm-common.bb b/meta-oe/recipes-core/llvm/llvm-common.bb
index 192919ee9..395ab0151 100644
--- a/meta-oe/recipes-core/llvm/llvm-common.bb
+++ b/meta-oe/recipes-core/llvm/llvm-common.bb
@@ -14,7 +14,7 @@ llvm_common_sysroot_preprocess() {
14 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 14 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
15} 15}
16 16
17do_install_virtclass-native() { 17do_install_class-native() {
18 install -d ${D}${bindir} 18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir} 19 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
20} 20}
diff --git a/meta-oe/recipes-core/llvm/llvm2.inc b/meta-oe/recipes-core/llvm/llvm2.inc
index 5ae993afd..b239d30f4 100644
--- a/meta-oe/recipes-core/llvm/llvm2.inc
+++ b/meta-oe/recipes-core/llvm/llvm2.inc
@@ -1,5 +1,5 @@
1DEPENDS = "llvm${LLVM_RELEASE}-native llvm-common" 1DEPENDS = "llvm${LLVM_RELEASE}-native llvm-common"
2DEPENDS_virtclass-native = "llvm-common-native cmake-native" 2DEPENDS_class-native = "llvm-common-native cmake-native"
3 3
4SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.tgz" 4SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.tgz"
5S = "${WORKDIR}/llvm-${PV}" 5S = "${WORKDIR}/llvm-${PV}"
@@ -57,7 +57,7 @@ PACKAGES_DYNAMIC = "llvm-*"
57 57
58# the difference to the non-native build is that we do not need 58# the difference to the non-native build is that we do not need
59# to declare the location of the tblgen executable. 59# to declare the location of the tblgen executable.
60EXTRA_OECMAKE_virtclass-native = "\ 60EXTRA_OECMAKE_class-native = "\
61 -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \ 61 -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
62 -DCMAKE_LINKER:FILEPATH=${LD} \ 62 -DCMAKE_LINKER:FILEPATH=${LD} \
63 -DCMAKE_AR:FILEPATH=${AR} \ 63 -DCMAKE_AR:FILEPATH=${AR} \
@@ -68,9 +68,9 @@ EXTRA_OECMAKE_virtclass-native = "\
68 -DNM_PATH:FILEPATH=${NM} \ 68 -DNM_PATH:FILEPATH=${NM} \
69" 69"
70 70
71PACKAGES_virtclass-native = "" 71PACKAGES_class-native = ""
72 72
73PACKAGES_DYNAMIC_virtclass-native = "" 73PACKAGES_DYNAMIC_class-native = ""
74 74
75python populate_packages_prepend () { 75python populate_packages_prepend () {
76 libllvm_libdir = bb.data.expand('${libdir}/${LLVM_DIR}', d) 76 libllvm_libdir = bb.data.expand('${libdir}/${LLVM_DIR}', d)
@@ -130,7 +130,7 @@ llvm_sysroot_preprocess() {
130 install -m 0755 bin/llvm-config${LLVM_RELEASE} ${SYSROOT_DESTDIR}${bindir_crossscripts} 130 install -m 0755 bin/llvm-config${LLVM_RELEASE} ${SYSROOT_DESTDIR}${bindir_crossscripts}
131} 131}
132 132
133do_install_virtclass-native() { 133do_install_class-native() {
134 # Install into a private directory to be able to reorganize the files. 134 # Install into a private directory to be able to reorganize the files.
135 cd ${LLVM_BUILD_DIR} 135 cd ${LLVM_BUILD_DIR}
136 oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install 136 oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install