summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarko Lindqvist <cazfi74@gmail.com>2012-12-01 09:38:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-16 21:11:43 +0100
commitfaa67b1e9d3e713338321cdd2c4b5c10ce2599e9 (patch)
treec1f71592efc6b0f9e619638ff24e34c98c36d2bb
parent86c8f4503c7d2965322b442686e0c1a43ed15e7c (diff)
downloadmeta-openembedded-faa67b1e9d3e713338321cdd2c4b5c10ce2599e9.tar.gz
fakeroot: update to upstream version 1.18.4
License is now GPLv3 Signed-off-by: Marko Lindqvist <cazfi74@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb (renamed from meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb)4
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot/configure-libtool.patch20
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot/fix-prefix.patch15
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb27
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb28
5 files changed, 28 insertions, 66 deletions
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
index 1e9f15a67..a27a60b48 100644
--- a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb
+++ b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
@@ -1,6 +1,5 @@
1require fakeroot_${PV}.bb 1require fakeroot_${PV}.bb
2 2
3SRC_URI += "file://fix-prefix.patch"
4S = "${WORKDIR}/fakeroot-${PV}" 3S = "${WORKDIR}/fakeroot-${PV}"
5 4
6inherit native 5inherit native
@@ -14,6 +13,3 @@ python () {
14} 13}
15 14
16RDEPENDS_${PN} = "util-linux-native" 15RDEPENDS_${PN} = "util-linux-native"
17
18SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
19SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot/configure-libtool.patch b/meta-oe/recipes-core/fakeroot/fakeroot/configure-libtool.patch
deleted file mode 100644
index 46f7df702..000000000
--- a/meta-oe/recipes-core/fakeroot/fakeroot/configure-libtool.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1Index: fakeroot-1.12.1/configure.ac
2===================================================================
3--- fakeroot-1.12.1.orig/configure.ac
4+++ fakeroot-1.12.1/configure.ac
5@@ -2,14 +2,12 @@
6 AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
7 AC_PREREQ(2.61)
8 AC_CONFIG_MACRO_DIR([build-aux])
9-LT_PREREQ(2.1a)
10 AC_CANONICAL_TARGET
11 AM_INIT_AUTOMAKE
12 AM_MAINTAINER_MODE
13 AC_CONFIG_HEADERS([config.h])
14 AC_PROG_MAKE_SET
15-LT_INIT
16-LT_LANG(C)
17+AC_PROG_LIBTOOL
18
19 AH_BOTTOM([#if ! HAVE_BUILTIN_EXPECT
20 #define __builtin_expect(x, expected_value) (x)
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot/fix-prefix.patch b/meta-oe/recipes-core/fakeroot/fakeroot/fix-prefix.patch
deleted file mode 100644
index 3c47bd765..000000000
--- a/meta-oe/recipes-core/fakeroot/fakeroot/fix-prefix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1Index: fakeroot-1.12.1/scripts/fakeroot.in
2===================================================================
3--- fakeroot-1.12.1.orig/scripts/fakeroot.in
4+++ fakeroot-1.12.1/scripts/fakeroot.in
5@@ -30,8 +30,8 @@
6 }
7
8 # strip /bin/fakeroot to find install prefix
9-PREFIX=@prefix@
10-BINDIR=@bindir@
11+BINDIR=`dirname $0`
12+PREFIX=`dirname ${BINDIR}`
13
14 USEABSLIBPATH=@LDPRELOADABS@
15 LIB=lib@fakeroot_transformed@@DLSUFFIX@
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb
deleted file mode 100644
index 1cc56025e..000000000
--- a/meta-oe/recipes-core/fakeroot/fakeroot_1.12.4.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1DESCRIPTION = "Gives a fake root environment"
2HOMEPAGE = "http://fakeroot.alioth.debian.org"
3SECTION = "base"
4LICENSE = "GPL"
5LIC_FILES_CHKSUM = "file://COPYING;md5=7686b00e9859a1a04043d33452bae823"
6PR = "r2"
7
8SRC_URI = "\
9 ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
10 file://configure-libtool.patch \
11"
12
13inherit autotools
14
15do_install_append() {
16 install -d ${D}${includedir}/fakeroot
17 install -m 644 *.h ${D}${includedir}/fakeroot
18 install -d ${D}${libdir}/libfakeroot/
19 oe_libinstall -so libfakeroot ${D}${libdir}/libfakeroot/
20}
21
22# fakeroot needs getopt which is provided by the util-linux package
23RDEPENDS_${PN} = "util-linux"
24
25
26SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
27SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb
new file mode 100644
index 000000000..a277a69bf
--- /dev/null
+++ b/meta-oe/recipes-core/fakeroot/fakeroot_1.18.4.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Gives a fake root environment"
2HOMEPAGE = "http://fakeroot.alioth.debian.org"
3SECTION = "base"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
6PR = "r0"
7
8SRC_URI = "\
9 ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
10"
11
12inherit autotools
13
14do_configure_prepend() {
15 mkdir -p ${S}/build-aux
16}
17
18do_install_append() {
19 install -d ${D}${includedir}/fakeroot
20 install -m 644 *.h ${D}${includedir}/fakeroot
21}
22
23# fakeroot needs getopt which is provided by the util-linux package
24RDEPENDS_${PN} = "util-linux"
25
26
27SRC_URI[md5sum] = "706171d8d520b1ca1576ac73f2ceb4f3"
28SRC_URI[sha256sum] = "0a359efa3e9496c33234b3e9c89306a09bb4da9d33de43c261f1d8447e6ebea2"