summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:56:54 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:25 +0200
commitf9ce43cdf6639acaa59d6144aabee798970ca3b6 (patch)
tree4cd53cb95eb5e514d834a65cdbdfa1d8739532c8
parente5f01cae3885030f8b3c585e62e7dd7f84a278d9 (diff)
downloadmeta-openembedded-f9ce43cdf6639acaa59d6144aabee798970ca3b6.tar.gz
Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipes
They are no longer required to build python software. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc4
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc4
-rw-r--r--meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb2
-rw-r--r--meta-networking/classes/waf-samba.bbclass2
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb2
-rw-r--r--meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb2
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.12.6.bb2
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb2
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb2
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb6
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.4.bb2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb2
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb3
-rw-r--r--meta-python/recipes-devtools/python/python-six.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb1
16 files changed, 2 insertions, 37 deletions
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
index 3e72261e2..cc6008387 100644
--- a/meta-efl/recipes-devtools/python/python-edbus.inc
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -8,10 +8,6 @@ AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
8DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus" 8DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus"
9RDEPENDS_${PN} += "python-lang python-dbus" 9RDEPENDS_${PN} += "python-lang python-dbus"
10 10
11# necessary to let the call for python-config succeed
12export BUILD_SYS
13export HOST_SYS
14
15inherit e-base autotools pkgconfig distutils-base 11inherit e-base autotools pkgconfig distutils-base
16 12
17SRCNAME = "python-e_dbus" 13SRCNAME = "python-e_dbus"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
index 92a26eddb..6837dab9f 100644
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -13,10 +13,6 @@ RDEPENDS_${PN} += "python-lang"
13 13
14PROVIDES = "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas" 14PROVIDES = "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas"
15 15
16# necessary to let the call for python-config succeed
17export BUILD_SYS
18export HOST_SYS
19
20inherit e-base distutils pkgconfig 16inherit e-base distutils pkgconfig
21 17
22SRCVER = "${PV}" 18SRCVER = "${PV}"
diff --git a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
index f14d4e1cf..0d8dd5cb3 100644
--- a/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
+++ b/meta-multimedia/recipes-mediacentre/xbmc/xbmc_git.bb
@@ -52,8 +52,6 @@ BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
52EXTRA_OECONF_append_armv7a = "--cpu=cortex-a8" 52EXTRA_OECONF_append_armv7a = "--cpu=cortex-a8"
53 53
54# for python modules 54# for python modules
55export HOST_SYS
56export BUILD_SYS
57export STAGING_LIBDIR 55export STAGING_LIBDIR
58export STAGING_INCDIR 56export STAGING_INCDIR
59export PYTHON_DIR 57export PYTHON_DIR
diff --git a/meta-networking/classes/waf-samba.bbclass b/meta-networking/classes/waf-samba.bbclass
index 45fbcc342..772bc7504 100644
--- a/meta-networking/classes/waf-samba.bbclass
+++ b/meta-networking/classes/waf-samba.bbclass
@@ -65,8 +65,6 @@ do_configure() {
65 -L ${STAGING_DIR_HOST} \ 65 -L ${STAGING_DIR_HOST} \
66 -E LD_LIBRARY_PATH=${libdir_qemu}:${base_libdir_qemu}" 66 -E LD_LIBRARY_PATH=${libdir_qemu}:${base_libdir_qemu}"
67 67
68 export BUILD_SYS=${BUILD_SYS}
69 export HOST_SYS=${HOST_SYS}
70 export BUILD_ARCH=${BUILD_ARCH} 68 export BUILD_ARCH=${BUILD_ARCH}
71 export HOST_ARCH=${HOST_ARCH} 69 export HOST_ARCH=${HOST_ARCH}
72 export STAGING_LIBDIR=${STAGING_LIBDIR} 70 export STAGING_LIBDIR=${STAGING_LIBDIR}
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
index 303a032fb..aeec195fa 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/mercurial-${PV}"
14inherit native 14inherit native
15 15
16EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \ 16EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
17 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} PREFIX=${prefix}" 17 PREFIX=${prefix}"
18 18
19do_configure_append () { 19do_configure_append () {
20 sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile 20 sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
index a2747c350..e203198af 100644
--- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
+++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
@@ -24,8 +24,6 @@ EXTRA_OECMAKE = "-DLIB='${baselib}' \
24 -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}" 24 -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}"
25 25
26do_configure_prepend() { 26do_configure_prepend() {
27 export HOST_SYS=${HOST_SYS}
28 export BUILD_SYS=${BUILD_SYS}
29 export STAGING_LIBDIR=${STAGING_LIBDIR} 27 export STAGING_LIBDIR=${STAGING_LIBDIR}
30 export STAGING_INCDIR=${STAGING_INCDIR} 28 export STAGING_INCDIR=${STAGING_INCDIR}
31 export ENV_INSTALL_PATH=${PYTHON_SITEPACKAGES_DIR} 29 export ENV_INSTALL_PATH=${PYTHON_SITEPACKAGES_DIR}
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
index 86628b14b..9848e5ac1 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
@@ -15,8 +15,6 @@ DEPENDS += "cups python libusb"
15 15
16inherit autotools-brokensep python-dir pythonnative pkgconfig 16inherit autotools-brokensep python-dir pythonnative pkgconfig
17 17
18export BUILD_SYS
19export HOST_SYS
20export STAGING_INCDIR 18export STAGING_INCDIR
21export STAGING_LIBDIR 19export STAGING_LIBDIR
22 20
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
index 52b271c11..af9633d40 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
@@ -39,8 +39,6 @@ EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
39 " 39 "
40 40
41do_configure_prepend() { 41do_configure_prepend() {
42 export HOST_SYS=${HOST_SYS}
43 export BUILD_SYS=${BUILD_SYS}
44 export STAGING_INCDIR=${STAGING_INCDIR} 42 export STAGING_INCDIR=${STAGING_INCDIR}
45 export STAGING_LIBDIR=${STAGING_LIBDIR} 43 export STAGING_LIBDIR=${STAGING_LIBDIR}
46} 44}
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 73a5d0e5b..a43e77029 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -50,8 +50,6 @@ EXTRA_OECONF = " \
50 --disable-rpath \ 50 --disable-rpath \
51" 51"
52 52
53export BUILD_SYS
54export HOST_SYS
55export STAGING_LIBDIR 53export STAGING_LIBDIR
56export STAGING_INCDIR 54export STAGING_INCDIR
57 55
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index aef9b138a..6b883a87e 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -55,9 +55,6 @@ do_compile_prepend() {
55 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}" 55 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
56 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config" 56 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
57 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}" 57 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
58
59 export BUILD_SYS="${BUILD_SYS}"
60 export HOST_SYS="${HOST_SYS}"
61} 58}
62 59
63do_install() { 60do_install() {
@@ -65,9 +62,6 @@ do_install() {
65 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config" 62 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
66 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}" 63 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
67 64
68 export BUILD_SYS="${BUILD_SYS}"
69 export HOST_SYS="${HOST_SYS}"
70
71 export DESTDIR="${D}" 65 export DESTDIR="${D}"
72 # prefix is used for RPATH and DESTDIR/prefix for instalation 66 # prefix is used for RPATH and DESTDIR/prefix for instalation
73 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \ 67 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb
index eb38a5a6a..83e7de8c0 100644
--- a/meta-oe/recipes-support/opencv/opencv_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb
@@ -50,8 +50,6 @@ PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
50 50
51inherit distutils-base pkgconfig cmake 51inherit distutils-base pkgconfig cmake
52 52
53export BUILD_SYS
54export HOST_SYS
55export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}" 53export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
56export PYTHON="${STAGING_BINDIR_NATIVE}/python" 54export PYTHON="${STAGING_BINDIR_NATIVE}/python"
57 55
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index 789512f9e..961b9cba0 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -70,8 +70,6 @@ PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
70 70
71inherit distutils-base pkgconfig cmake 71inherit distutils-base pkgconfig cmake
72 72
73export BUILD_SYS
74export HOST_SYS
75export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}" 73export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
76export PYTHON="${STAGING_BINDIR_NATIVE}/python" 74export PYTHON="${STAGING_BINDIR_NATIVE}/python"
77export JAVA_HOME="${STAGING_DIR_NATIVE}/usr/bin/java" 75export JAVA_HOME="${STAGING_DIR_NATIVE}/usr/bin/java"
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
index 288a2d183..32ffe190b 100644
--- a/meta-oe/recipes-support/postgresql/postgresql.inc
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -113,7 +113,7 @@ python populate_packages_prepend() {
113do_configure() { 113do_configure() {
114 # do_configure_prepend 114 # do_configure_prepend
115 # make sure configure finds python includdirs with these envs 115 # make sure configure finds python includdirs with these envs
116 export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ 116 export \
117 STAGING_INCDIR=${STAGING_INCDIR} \ 117 STAGING_INCDIR=${STAGING_INCDIR} \
118 STAGING_LIBDIR=${STAGING_LIBDIR} 118 STAGING_LIBDIR=${STAGING_LIBDIR}
119 119
diff --git a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
index 69f71c711..133e66da4 100644
--- a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
@@ -19,15 +19,12 @@ EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
19inherit distutils 19inherit distutils
20 20
21do_compile_prepend() { 21do_compile_prepend() {
22 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
23 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ 22 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
24 true 23 true
25} 24}
26 25
27# need to export these variables for python-config to work 26# need to export these variables for python-config to work
28export PYTHONPATH 27export PYTHONPATH
29export BUILD_SYS
30export HOST_SYS
31export STAGING_INCDIR 28export STAGING_INCDIR
32export STAGING_LIBDIR 29export STAGING_LIBDIR
33 30
diff --git a/meta-python/recipes-devtools/python/python-six.inc b/meta-python/recipes-devtools/python/python-six.inc
index 408c60e88..625cbad17 100644
--- a/meta-python/recipes-devtools/python/python-six.inc
+++ b/meta-python/recipes-devtools/python/python-six.inc
@@ -6,7 +6,6 @@ SRC_URI[md5sum] = "34eed507548117b2ab523ab14b2f8b55"
6SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a" 6SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a"
7 7
8do_compile_append() { 8do_compile_append() {
9 export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
10 ${PYTHON} setup.py -q bdist_egg --dist-dir ./ 9 ${PYTHON} setup.py -q bdist_egg --dist-dir ./
11} 10}
12do_install_append() { 11do_install_append() {
diff --git a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
index e87e50f9b..0df18f5df 100644
--- a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "acd43686e92e6c8bbeb4f2eef54408567a7adea9692fa72d591eec5357
10inherit pypi setuptools 10inherit pypi setuptools
11 11
12do_compile_append() { 12do_compile_append() {
13 export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
14 ${PYTHON} setup.py -q bdist_egg --dist-dir ./ 13 ${PYTHON} setup.py -q bdist_egg --dist-dir ./
15} 14}
16 15