summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 12:22:48 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-25 12:50:39 -0700
commitf952769a3724ad95ac0059575afc82f0205a005c (patch)
tree8702b860eddd9e69ce8f836a5ef9f7adb95a4e83
parent7bc6403b7334deb499d3b4dbc76ea8f3ea45e185 (diff)
downloadmeta-openembedded-f952769a3724ad95ac0059575afc82f0205a005c.tar.gz
autofs: Fix build with musl >= 1.2.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/0001-include-libgen.h-for-basename.patch58
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb1
2 files changed, 59 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs/0001-include-libgen.h-for-basename.patch b/meta-networking/recipes-daemons/autofs/autofs/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 000000000..4c8b4ef77
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,58 @@
1From 1651e7a35be8b3e2fa90ca57b073f6944664fa62 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 Mar 2024 12:04:03 -0700
4Subject: [PATCH] include libgen.h for basename
5
6basename prototype has been removed from string.h from latest musl [1]
7compilers e.g. clang-18 flags the absense of prototype as error. therefore
8include libgen.h for providing it.
9
10[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
11
12Upstream-Status: Pending
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 daemon/automount.c | 1 +
16 daemon/master.c | 1 +
17 modules/lookup_file.c | 1 +
18 3 files changed, 3 insertions(+)
19
20diff --git a/daemon/automount.c b/daemon/automount.c
21index 3d9461d..61b3478 100644
22--- a/daemon/automount.c
23+++ b/daemon/automount.c
24@@ -21,6 +21,7 @@
25
26 #include <dirent.h>
27 #include <getopt.h>
28+#include <libgen.h>
29 #include <signal.h>
30 #include <stdio.h>
31 #include <stdlib.h>
32diff --git a/daemon/master.c b/daemon/master.c
33index f99359c..3f56499 100644
34--- a/daemon/master.c
35+++ b/daemon/master.c
36@@ -21,6 +21,7 @@
37 #include <string.h>
38 #include <memory.h>
39 #include <limits.h>
40+#include <libgen.h>
41 #include <signal.h>
42 #include <sys/types.h>
43 #include <sys/stat.h>
44diff --git a/modules/lookup_file.c b/modules/lookup_file.c
45index 6afc558..82b1f28 100644
46--- a/modules/lookup_file.c
47+++ b/modules/lookup_file.c
48@@ -15,6 +15,7 @@
49
50 #include <stdio.h>
51 #include <malloc.h>
52+#include <libgen.h>
53 #include <stdlib.h>
54 #include <string.h>
55 #include <time.h>
56--
572.44.0
58
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb
index ca11f1a17..e3f977738 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.8.bb
@@ -29,6 +29,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
29 file://mount_conflict.patch \ 29 file://mount_conflict.patch \
30 file://0001-autofs-5.1.8-add-autofs_strerror_r-helper-for-musl.patch \ 30 file://0001-autofs-5.1.8-add-autofs_strerror_r-helper-for-musl.patch \
31 file://0002-autofs-5.1.8-handle-innetgr-not-present-in-musl.patch \ 31 file://0002-autofs-5.1.8-handle-innetgr-not-present-in-musl.patch \
32 file://0001-include-libgen.h-for-basename.patch \
32 " 33 "
33SRC_URI[sha256sum] = "0bd401c56f0eb1ca6251344c3a3d70bface3eccf9c67117cd184422c4cace30c" 34SRC_URI[sha256sum] = "0bd401c56f0eb1ca6251344c3a3d70bface3eccf9c67117cd184422c4cace30c"
34 35