summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2024-03-05 14:34:43 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-05 11:02:03 -0800
commitf88e5b146e0fd4f6d79423d6718e4875643c4ba8 (patch)
tree49c2dd4bfe126d09ee26f2866931075e04ec3da6
parent0d9351e9290f6750e44ab52536bbe9268d5afac3 (diff)
downloadmeta-openembedded-f88e5b146e0fd4f6d79423d6718e4875643c4ba8.tar.gz
postgresql: upgrade 15.5 -> 16.2
License-Update: Update lincense year to 2024 In version 16.2, ICU support is enabled by default, add PACKAGECONFIG icu to align with upstream, enable icu by default. And fix buildpaths QA warning. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0001-Add-support-for-RISC-V.patch31
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0002-Improve-reproducibility.patch (renamed from meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch)8
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch (renamed from meta-oe/recipes-dbs/postgresql/files/0001-configure.ac-bypass-autoconf-2.69-version-check.patch)10
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0004-config_info.c-not-expose-build-info.patch (renamed from meta-oe/recipes-dbs/postgresql/files/0001-config_info.c-not-expose-build-info.patch)20
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0005-postgresql-fix-ptest-failure-of-sysviews.patch (renamed from meta-oe/recipes-dbs/postgresql/files/0001-postgresql-fix-ptest-failure-of-sysviews.patch)15
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql.inc13
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql_15.5.bb16
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql_16.2.bb16
8 files changed, 72 insertions, 57 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-Add-support-for-RISC-V.patch b/meta-oe/recipes-dbs/postgresql/files/0001-Add-support-for-RISC-V.patch
index 7a4ba9897..34d34ecad 100644
--- a/meta-oe/recipes-dbs/postgresql/files/0001-Add-support-for-RISC-V.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/0001-Add-support-for-RISC-V.patch
@@ -1,21 +1,19 @@
1From 780fd27ea6f7f2c446c46a7a5e26d94106c67efd Mon Sep 17 00:00:00 2001 1From ba079b8d6a50796db41bb0ddf4c22bfe022ef898 Mon Sep 17 00:00:00 2001
2From: "Richard W.M. Jones" <rjones@redhat.com> 2From: "Richard W.M. Jones" <rjones@redhat.com>
3Date: Sun, 20 Nov 2016 15:04:52 +0000 3Date: Sun, 20 Nov 2016 15:04:52 +0000
4Subject: [PATCH] Add support for RISC-V. 4Subject: [PATCH 1/5] Add support for RISC-V.
5 5
6The architecture is sufficiently similar to aarch64 that simply 6The architecture is sufficiently similar to aarch64 that simply
7extending the existing aarch64 macro works. 7extending the existing aarch64 macro works.
8--- 8---
9Upstream-Status: Pending 9 src/include/storage/s_lock.h | 5 +++--
10 10 1 file changed, 3 insertions(+), 2 deletions(-)
11 src/include/storage/s_lock.h | 6 +++---
12 1 file changed, 3 insertions(+), 3 deletions(-)
13 11
14diff --git a/src/include/storage/s_lock.h b/src/include/storage/s_lock.h 12diff --git a/src/include/storage/s_lock.h b/src/include/storage/s_lock.h
15index 4d3ffc7..22e27bf 100644 13index c9fa84c..9b491e8 100644
16--- a/src/include/storage/s_lock.h 14--- a/src/include/storage/s_lock.h
17+++ b/src/include/storage/s_lock.h 15+++ b/src/include/storage/s_lock.h
18@@ -317,11 +317,12 @@ tas(volatile slock_t *lock) 16@@ -252,11 +252,12 @@ spin_delay(void)
19 17
20 /* 18 /*
21 * On ARM and ARM64, we use __sync_lock_test_and_set(int *, int) if available. 19 * On ARM and ARM64, we use __sync_lock_test_and_set(int *, int) if available.
@@ -24,21 +22,20 @@ index 4d3ffc7..22e27bf 100644
24 * We use the int-width variant of the builtin because it works on more chips 22 * We use the int-width variant of the builtin because it works on more chips
25 * than other widths. 23 * than other widths.
26 */ 24 */
27-#if defined(__arm__) || defined(__arm) || defined(__aarch64__) || defined(__aarch64) 25-#if defined(__arm__) || defined(__arm) || defined(__aarch64__)
28+#if defined(__arm__) || defined(__arm) || defined(__aarch64__) || defined(__aarch64) || defined(__riscv) 26+#if defined(__arm__) || defined(__arm) || defined(__aarch64__) || defined(__riscv)
29 #ifdef HAVE_GCC__SYNC_INT32_TAS 27 #ifdef HAVE_GCC__SYNC_INT32_TAS
30 #define HAS_TEST_AND_SET 28 #define HAS_TEST_AND_SET
31 29
32@@ -355,8 +356,7 @@ spin_delay(void) 30@@ -290,7 +291,7 @@ spin_delay(void)
33 31
34 #endif /* __aarch64__ || __aarch64 */ 32 #endif /* __aarch64__ */
35 #endif /* HAVE_GCC__SYNC_INT32_TAS */ 33 #endif /* HAVE_GCC__SYNC_INT32_TAS */
36-#endif /* __arm__ || __arm || __aarch64__ || __aarch64 */ 34-#endif /* __arm__ || __arm || __aarch64__ */
37- 35+#endif /* __arm__ || __arm || __aarch64__ || __riscv */
38+#endif /* __arm__ || __arm || __aarch64__ || __aarch64 || __riscv */ 36
39 37
40 /* S/390 and S/390x Linux (32- and 64-bit zSeries) */ 38 /* S/390 and S/390x Linux (32- and 64-bit zSeries) */
41 #if defined(__s390__) || defined(__s390x__)
42-- 39--
432.34.1 402.25.1
44 41
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch b/meta-oe/recipes-dbs/postgresql/files/0002-Improve-reproducibility.patch
index 02f4c9e51..b3e87cbc4 100644
--- a/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/0002-Improve-reproducibility.patch
@@ -1,7 +1,7 @@
1From bbba8a5261a99e79c9cd4693ef56021014a9856b Mon Sep 17 00:00:00 2001 1From 084cc44215c1d5e6d33bc3d2e1d24da4fc98bdcd Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com> 2From: Changqing Li <changqing.li@windriver.com>
3Date: Mon, 28 Dec 2020 16:38:21 +0800 3Date: Mon, 28 Dec 2020 16:38:21 +0800
4Subject: [PATCH] Improve reproducibility, 4Subject: [PATCH 2/5] Improve reproducibility,
5 5
6Remove build patch from binaries which pg_config do 6Remove build patch from binaries which pg_config do
7not record var-CC, var-CFLAGS, and configure 7not record var-CC, var-CFLAGS, and configure
@@ -23,7 +23,7 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
23 1 file changed, 3 deletions(-) 23 1 file changed, 3 deletions(-)
24 24
25diff --git a/src/common/Makefile b/src/common/Makefile 25diff --git a/src/common/Makefile b/src/common/Makefile
26index 880722f..7a9b9d4 100644 26index 113029b..58842a6 100644
27--- a/src/common/Makefile 27--- a/src/common/Makefile
28+++ b/src/common/Makefile 28+++ b/src/common/Makefile
29@@ -31,9 +31,6 @@ include $(top_builddir)/src/Makefile.global 29@@ -31,9 +31,6 @@ include $(top_builddir)/src/Makefile.global
@@ -37,5 +37,5 @@ index 880722f..7a9b9d4 100644
37 override CPPFLAGS += -DVAL_LDFLAGS="\"$(STD_LDFLAGS)\"" 37 override CPPFLAGS += -DVAL_LDFLAGS="\"$(STD_LDFLAGS)\""
38 override CPPFLAGS += -DVAL_LDFLAGS_EX="\"$(LDFLAGS_EX)\"" 38 override CPPFLAGS += -DVAL_LDFLAGS_EX="\"$(LDFLAGS_EX)\""
39-- 39--
402.34.1 402.25.1
41 41
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-configure.ac-bypass-autoconf-2.69-version-check.patch b/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
index ab578056f..d76d1991b 100644
--- a/meta-oe/recipes-dbs/postgresql/files/0001-configure.ac-bypass-autoconf-2.69-version-check.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
@@ -1,7 +1,7 @@
1From d44c83ed0f30462a31930d6d925762b3f8412ce2 Mon Sep 17 00:00:00 2001 1From 30b1b37d309f67ba6d58f2197bd917107bc7d56c Mon Sep 17 00:00:00 2001
2From: Yi Fan Yu <yifan.yu@windriver.com> 2From: Yi Fan Yu <yifan.yu@windriver.com>
3Date: Fri, 5 Feb 2021 17:15:42 -0500 3Date: Fri, 5 Feb 2021 17:15:42 -0500
4Subject: [PATCH] configure.ac: bypass autoconf 2.69 version check 4Subject: [PATCH 3/5] configure.ac: bypass autoconf 2.69 version check
5 5
6for upgrade to autoconf 2.71 6for upgrade to autoconf 2.71
7 7
@@ -13,18 +13,18 @@ Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
13 1 file changed, 4 deletions(-) 13 1 file changed, 4 deletions(-)
14 14
15diff --git a/configure.ac b/configure.ac 15diff --git a/configure.ac b/configure.ac
16index e988503..d1b2cfd 100644 16index 401ce30..27f382d 100644
17--- a/configure.ac 17--- a/configure.ac
18+++ b/configure.ac 18+++ b/configure.ac
19@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros 19@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros
20 20
21 AC_INIT([PostgreSQL], [15.5], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/]) 21 AC_INIT([PostgreSQL], [16.2], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/])
22 22
23-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required. 23-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required.
24-Untested combinations of 'autoconf' and PostgreSQL versions are not 24-Untested combinations of 'autoconf' and PostgreSQL versions are not
25-recommended. You can remove the check from 'configure.ac' but it is then 25-recommended. You can remove the check from 'configure.ac' but it is then
26-your responsibility whether the result works or not.])]) 26-your responsibility whether the result works or not.])])
27 AC_COPYRIGHT([Copyright (c) 1996-2022, PostgreSQL Global Development Group]) 27 AC_COPYRIGHT([Copyright (c) 1996-2023, PostgreSQL Global Development Group])
28 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c]) 28 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
29 AC_CONFIG_AUX_DIR(config) 29 AC_CONFIG_AUX_DIR(config)
30-- 30--
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-config_info.c-not-expose-build-info.patch b/meta-oe/recipes-dbs/postgresql/files/0004-config_info.c-not-expose-build-info.patch
index 52ca276da..ff0582ab8 100644
--- a/meta-oe/recipes-dbs/postgresql/files/0001-config_info.c-not-expose-build-info.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/0004-config_info.c-not-expose-build-info.patch
@@ -1,7 +1,7 @@
1From b92eebe8b0760fee7bd55c6c22318620c2c07579 Mon Sep 17 00:00:00 2001 1From 5be3ffdf767c1efcbfd2d1be87aa83f2e37e348e Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Mon, 1 Aug 2022 15:44:38 +0800 3Date: Mon, 1 Aug 2022 15:44:38 +0800
4Subject: [PATCH] config_info.c: not expose build info 4Subject: [PATCH 4/5] config_info.c: not expose build info
5 5
6Don't collect the build information to fix the buildpaths issue. 6Don't collect the build information to fix the buildpaths issue.
7 7
@@ -10,14 +10,14 @@ Upstream-Status: Inappropriate [oe specific]
10Signed-off-by: Mingli Yu <mingli.yu@windriver.com> 10Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
11--- 11---
12 configure.ac | 2 +- 12 configure.ac | 2 +-
13 src/common/config_info.c | 68 ---------------------------------------- 13 src/common/config_info.c | 70 +---------------------------------------
14 2 files changed, 1 insertion(+), 69 deletions(-) 14 2 files changed, 2 insertions(+), 70 deletions(-)
15 15
16diff --git a/configure.ac b/configure.ac 16diff --git a/configure.ac b/configure.ac
17index 0eb595b..508487b 100644 17index 27f382d..3dd6bb1 100644
18--- a/configure.ac 18--- a/configure.ac
19+++ b/configure.ac 19+++ b/configure.ac
20@@ -23,7 +23,7 @@ AC_COPYRIGHT([Copyright (c) 1996-2021, PostgreSQL Global Development Group]) 20@@ -23,7 +23,7 @@ AC_COPYRIGHT([Copyright (c) 1996-2023, PostgreSQL Global Development Group])
21 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c]) 21 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
22 AC_CONFIG_AUX_DIR(config) 22 AC_CONFIG_AUX_DIR(config)
23 AC_PREFIX_DEFAULT(/usr/local/pgsql) 23 AC_PREFIX_DEFAULT(/usr/local/pgsql)
@@ -27,19 +27,19 @@ index 0eb595b..508487b 100644
27 [PG_MAJORVERSION=`expr "$PACKAGE_VERSION" : '\([0-9][0-9]*\)'`] 27 [PG_MAJORVERSION=`expr "$PACKAGE_VERSION" : '\([0-9][0-9]*\)'`]
28 [PG_MINORVERSION=`expr "$PACKAGE_VERSION" : '.*\.\([0-9][0-9]*\)'`] 28 [PG_MINORVERSION=`expr "$PACKAGE_VERSION" : '.*\.\([0-9][0-9]*\)'`]
29diff --git a/src/common/config_info.c b/src/common/config_info.c 29diff --git a/src/common/config_info.c b/src/common/config_info.c
30index e72e729..b482c20 100644 30index 09e78a6..86e4230 100644
31--- a/src/common/config_info.c 31--- a/src/common/config_info.c
32+++ b/src/common/config_info.c 32+++ b/src/common/config_info.c
33@@ -38,7 +38,7 @@ 33@@ -38,7 +38,7 @@ get_configdata(const char *my_exec_path, size_t *configdata_len)
34 int i = 0; 34 int i = 0;
35 35
36 /* Adjust this to match the number of items filled below */ 36 /* Adjust this to match the number of items filled below */
37- *configdata_len = 23; 37- *configdata_len = 23;
38+ *configdata_len = 14; 38+ *configdata_len = 14;
39 configdata = (ConfigData *) palloc(*configdata_len * sizeof(ConfigData)); 39 configdata = palloc_array(ConfigData, *configdata_len);
40 40
41 configdata[i].name = pstrdup("BINDIR"); 41 configdata[i].name = pstrdup("BINDIR");
42@@ -123,74 +123,6 @@ 42@@ -123,74 +123,6 @@ get_configdata(const char *my_exec_path, size_t *configdata_len)
43 configdata[i].setting = pstrdup(path); 43 configdata[i].setting = pstrdup(path);
44 i++; 44 i++;
45 45
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-postgresql-fix-ptest-failure-of-sysviews.patch b/meta-oe/recipes-dbs/postgresql/files/0005-postgresql-fix-ptest-failure-of-sysviews.patch
index 4db36d26f..af36da492 100644
--- a/meta-oe/recipes-dbs/postgresql/files/0001-postgresql-fix-ptest-failure-of-sysviews.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/0005-postgresql-fix-ptest-failure-of-sysviews.patch
@@ -1,7 +1,7 @@
1From 9f81377dddfe32d950844d7053020a36b40fce08 Mon Sep 17 00:00:00 2001 1From 1a8b94140988d2ee5ff987b0bb3e7c3e936b8c01 Mon Sep 17 00:00:00 2001
2From: Manoj Saun <manojsingh.saun@windriver.com> 2From: Manoj Saun <manojsingh.saun@windriver.com>
3Date: Wed, 22 Mar 2023 08:07:26 +0000 3Date: Wed, 22 Mar 2023 08:07:26 +0000
4Subject: [PATCH] postgresql: fix ptest failure of sysviews 4Subject: [PATCH 5/5] postgresql: fix ptest failure of sysviews
5 5
6The patch "0001-config_info.c-not-expose-build-info.patch" hides the debug info 6The patch "0001-config_info.c-not-expose-build-info.patch" hides the debug info
7in pg_config table which reduces the count of rows from pg_config and leads to 7in pg_config table which reduces the count of rows from pg_config and leads to
@@ -18,9 +18,11 @@ Signed-off-by: Manoj Saun <manojsingh.saun@windriver.com>
18 src/test/regress/sql/sysviews.sql | 2 +- 18 src/test/regress/sql/sysviews.sql | 2 +-
19 2 files changed, 2 insertions(+), 2 deletions(-) 19 2 files changed, 2 insertions(+), 2 deletions(-)
20 20
21diff --git a/src/test/regress/expected/sysviews.out b/src/test/regress/expected/sysviews.out
22index 001c6e7..8256898 100644
21--- a/src/test/regress/expected/sysviews.out 23--- a/src/test/regress/expected/sysviews.out
22+++ b/src/test/regress/expected/sysviews.out 24+++ b/src/test/regress/expected/sysviews.out
23@@ -29,7 +29,7 @@ select name, ident, parent, level, total 25@@ -29,7 +29,7 @@ select name, ident, parent, level, total_bytes >= free_bytes
24 (1 row) 26 (1 row)
25 27
26 -- At introduction, pg_config had 23 entries; it may grow 28 -- At introduction, pg_config had 23 entries; it may grow
@@ -29,9 +31,11 @@ Signed-off-by: Manoj Saun <manojsingh.saun@windriver.com>
29 ok 31 ok
30 ---- 32 ----
31 t 33 t
34diff --git a/src/test/regress/sql/sysviews.sql b/src/test/regress/sql/sysviews.sql
35index 351e469..84c113e 100644
32--- a/src/test/regress/sql/sysviews.sql 36--- a/src/test/regress/sql/sysviews.sql
33+++ b/src/test/regress/sql/sysviews.sql 37+++ b/src/test/regress/sql/sysviews.sql
34@@ -18,7 +18,7 @@ select name, ident, parent, level, total 38@@ -18,7 +18,7 @@ select name, ident, parent, level, total_bytes >= free_bytes
35 from pg_backend_memory_contexts where level = 0; 39 from pg_backend_memory_contexts where level = 0;
36 40
37 -- At introduction, pg_config had 23 entries; it may grow 41 -- At introduction, pg_config had 23 entries; it may grow
@@ -40,3 +44,6 @@ Signed-off-by: Manoj Saun <manojsingh.saun@windriver.com>
40 44
41 -- We expect no cursors in this test; see also portals.sql 45 -- We expect no cursors in this test; see also portals.sql
42 select count(*) = 0 as ok from pg_cursors; 46 select count(*) = 0 as ok from pg_cursors;
47--
482.25.1
49
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc
index 15ecdeeb2..868a2e443 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql.inc
+++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc
@@ -54,7 +54,7 @@ pkg_postinst:${PN} () {
54 54
55PACKAGECONFIG ??= " \ 55PACKAGECONFIG ??= " \
56 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \ 56 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \
57 openssl python uuid libxml tcl perl zlib \ 57 openssl python uuid libxml tcl perl zlib icu \
58" 58"
59PACKAGECONFIG[tcl] = "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl tcl-native," 59PACKAGECONFIG[tcl] = "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl tcl-native,"
60PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl" 60PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl"
@@ -69,6 +69,7 @@ PACKAGECONFIG[libxslt] = "--with-libxslt,--without-libxslt,libxslt"
69PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib" 69PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
70PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4" 70PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4"
71PACKAGECONFIG[openssl] = "--with-ssl=openssl,ac_cv_file__dev_urandom=yes,openssl" 71PACKAGECONFIG[openssl] = "--with-ssl=openssl,ac_cv_file__dev_urandom=yes,openssl"
72PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu,icu"
72 73
73EXTRA_OECONF += "--enable-thread-safety --disable-rpath \ 74EXTRA_OECONF += "--enable-thread-safety --disable-rpath \
74 --datadir=${datadir}/${BPN} \ 75 --datadir=${datadir}/${BPN} \
@@ -229,6 +230,16 @@ do_install:append() {
229SSTATE_SCAN_FILES += "Makefile.global" 230SSTATE_SCAN_FILES += "Makefile.global"
230SSTATE_SCAN_FILES:remove = "*_config" 231SSTATE_SCAN_FILES:remove = "*_config"
231 232
233postgresql_fix_sources () {
234 for f in ${PKGD}${TARGET_DBGSRC_DIR}/src/pl/plperl/Util.c \
235 ${PKGD}${TARGET_DBGSRC_DIR}/src/pl/plperl/SPI.c; do
236 if [ -e $f ]; then
237 sed -i -e 's#${B}/../${P}#${TARGET_DBGSRC_DIR}#g' $f
238 fi
239 done
240}
241PACKAGESPLITFUNCS =+ "postgresql_fix_sources"
242
232PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \ 243PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \
233 libecpg-compat libecpg-compat-dev \ 244 libecpg-compat libecpg-compat-dev \
234 libecpg libecpg-dev libecpg-staticdev libecpg-doc \ 245 libecpg libecpg-dev libecpg-staticdev libecpg-doc \
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_15.5.bb b/meta-oe/recipes-dbs/postgresql/postgresql_15.5.bb
deleted file mode 100644
index cb90ff930..000000000
--- a/meta-oe/recipes-dbs/postgresql/postgresql_15.5.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1require postgresql.inc
2
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=c31f662bb2bfb3b4187fe9a53e0ffe7c"
4
5SRC_URI += "\
6 file://not-check-libperl.patch \
7 file://0001-Add-support-for-RISC-V.patch \
8 file://0001-Improve-reproducibility.patch \
9 file://0001-configure.ac-bypass-autoconf-2.69-version-check.patch \
10 file://0001-config_info.c-not-expose-build-info.patch \
11 file://0001-postgresql-fix-ptest-failure-of-sysviews.patch \
12"
13
14SRC_URI[sha256sum] = "8f53aa95d78eb8e82536ea46b68187793b42bba3b4f65aa342f540b23c9b10a6"
15
16CVE_STATUS[CVE-2017-8806] = "not-applicable-config: Ddoesn't apply to out configuration of postgresql so we can safely ignore it."
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_16.2.bb b/meta-oe/recipes-dbs/postgresql/postgresql_16.2.bb
new file mode 100644
index 000000000..31f83a564
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/postgresql_16.2.bb
@@ -0,0 +1,16 @@
1require postgresql.inc
2
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=89afbb2d7716371015101c2b2cb4297a"
4
5SRC_URI += "\
6 file://not-check-libperl.patch \
7 file://0001-Add-support-for-RISC-V.patch \
8 file://0002-Improve-reproducibility.patch \
9 file://0003-configure.ac-bypass-autoconf-2.69-version-check.patch \
10 file://0004-config_info.c-not-expose-build-info.patch \
11 file://0005-postgresql-fix-ptest-failure-of-sysviews.patch \
12"
13
14SRC_URI[sha256sum] = "446e88294dbc2c9085ab4b7061a646fa604b4bec03521d5ea671c2e5ad9b2952"
15
16CVE_STATUS[CVE-2017-8806] = "not-applicable-config: Ddoesn't apply to out configuration of postgresql so we can safely ignore it."