summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-03-31 14:31:53 +0200
committerKhem Raj <raj.khem@gmail.com>2023-04-01 06:09:47 -0700
commitf6b3a82e1eb0cd140353dbc1b7e49432a82fd51d (patch)
tree74fe797b4c93b8a10cee43507d85543bf89ecde5
parent55489e5d10ed735ad96bb86db47c8e1fda3c5850 (diff)
downloadmeta-openembedded-f6b3a82e1eb0cd140353dbc1b7e49432a82fd51d.tar.gz
reboot-mode: put the build artifacts in ${B}
We should output the compiled executables into ${B} and install them from it as well. Currently we put the build objects in the source directory. While at it: don't assume we're already in the source directory and instead prepend the source file with ${S}. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
index 20e77c63d..4c3436823 100644
--- a/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
+++ b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
@@ -10,9 +10,9 @@ SRCREV = "84831b20512abd9033414ca5f5a023f333525335"
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12do_compile() { 12do_compile() {
13 ${CC} ${CFLAGS} ${LDFLAGS} reboot-mode.c -o reboot-mode 13 ${CC} ${CFLAGS} ${LDFLAGS} ${S}/reboot-mode.c -o ${B}/reboot-mode
14} 14}
15 15
16do_install() { 16do_install() {
17 install -D -m 0755 ${S}/reboot-mode ${D}${bindir}/reboot-mode 17 install -D -m 0755 ${B}/reboot-mode ${D}${bindir}/reboot-mode
18} 18}