diff options
author | Patrick Wicki <patrick.wicki@siemens.com> | 2024-11-29 22:38:37 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-11-29 15:25:42 -0800 |
commit | f57840b83bb61832893074cf1642108a261f1c7a (patch) | |
tree | f2e0647244c07a9950faf690147ef7d01f7c55e3 | |
parent | 0fdf559877b4444d716824cc6eca367d590ed9dd (diff) | |
download | meta-openembedded-f57840b83bb61832893074cf1642108a261f1c7a.tar.gz |
fluentbit: use system libs instead of vendored ones
Make use of the new build option to unbundle some vendored dependencies.
Currently supported are libbacktrace, c-ares, jemalloc, luajit and
nghttp, all of which have Yocto recipes. librdkafka is currently below
the required version (>=2.3.0) so for that it will fall back to the
vendored version.
Signed-off-by: Patrick Wicki <patrick.wicki@siemens.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit_3.2.1.bb | 11 |
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_3.2.1.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_3.2.1.bb index 54fa9b277..b895c7da0 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit_3.2.1.bb +++ b/meta-oe/recipes-extended/fluentbit/fluentbit_3.2.1.bb | |||
@@ -43,6 +43,7 @@ PACKAGECONFIG ??= "\ | |||
43 | ipo \ | 43 | ipo \ |
44 | metrics \ | 44 | metrics \ |
45 | parser \ | 45 | parser \ |
46 | prefer-system-libs \ | ||
46 | proxy-go \ | 47 | proxy-go \ |
47 | record-accessor \ | 48 | record-accessor \ |
48 | regex \ | 49 | regex \ |
@@ -56,6 +57,12 @@ PACKAGECONFIG ??= "\ | |||
56 | # See https://github.com/fluent/fluent-bit/issues/7248#issuecomment-1631280496 | 57 | # See https://github.com/fluent/fluent-bit/issues/7248#issuecomment-1631280496 |
57 | PACKAGECONFIG:remove:toolchain-clang = "ipo" | 58 | PACKAGECONFIG:remove:toolchain-clang = "ipo" |
58 | 59 | ||
60 | # Use system libs | ||
61 | PACKAGECONFIG[prefer-system-libs] = "-DFLB_PREFER_SYSTEM_LIBS=Yes,-DFLB_PREFER_SYSTEM_LIBS=No, nghttp2 c-ares" | ||
62 | DEPENDS += " ${@bb.utils.contains('PACKAGECONFIG', 'prefer-system-libs backtrace', 'libbacktrace', '', d)}" | ||
63 | DEPENDS += " ${@bb.utils.contains('PACKAGECONFIG', 'prefer-system-libs jemalloc', 'jemalloc', '', d)}" | ||
64 | DEPENDS += " ${@bb.utils.contains('PACKAGECONFIG', 'prefer-system-libs luajit', 'luajit', '', d)}" | ||
65 | |||
59 | PACKAGECONFIG[all] = "-DFLB_ALL=Yes,-DFLB_ALL=No" | 66 | PACKAGECONFIG[all] = "-DFLB_ALL=Yes,-DFLB_ALL=No" |
60 | PACKAGECONFIG[arrow] = "-DFLB_ARROW=Yes,-DFLB_ARROW=No" | 67 | PACKAGECONFIG[arrow] = "-DFLB_ARROW=Yes,-DFLB_ARROW=No" |
61 | PACKAGECONFIG[avro-encoder] = "-DFLB_AVRO_ENCODER=Yes,-DFLB_AVRO_ENCODER=No" | 68 | PACKAGECONFIG[avro-encoder] = "-DFLB_AVRO_ENCODER=Yes,-DFLB_AVRO_ENCODER=No" |
@@ -105,8 +112,8 @@ PACKAGECONFIG[windows-defaults] = "-DFLB_WINDOWS_DEFAULTS=Yes,-DFLB_WINDOWS_DEFA | |||
105 | PACKAGECONFIG[minimal] = "-DFLB_MINIMAL=Yes,-DFLB_MINIMAL=No" | 112 | PACKAGECONFIG[minimal] = "-DFLB_MINIMAL=Yes,-DFLB_MINIMAL=No" |
106 | 113 | ||
107 | # Without zstd dependency, kafka plugin build fails at link attempt against native libzstd.so | 114 | # Without zstd dependency, kafka plugin build fails at link attempt against native libzstd.so |
108 | PACKAGECONFIG[in-kafka] = "-DFLB_IN_KAFKA=ON,-DFLB_IN_KAFKA=OFF,librdkafka zstd" | 115 | PACKAGECONFIG[in-kafka] = "-DFLB_IN_KAFKA=ON,-DFLB_IN_KAFKA=OFF,librdkafka zstd curl" |
109 | PACKAGECONFIG[out-kafka] = "-DFLB_OUT_KAFKA=ON,-DFLB_OUT_KAFKA=OFF,librdkafka zstd" | 116 | PACKAGECONFIG[out-kafka] = "-DFLB_OUT_KAFKA=ON,-DFLB_OUT_KAFKA=OFF,librdkafka zstd curl" |
110 | 117 | ||
111 | SYSTEMD_SERVICE:${PN} = "fluent-bit.service" | 118 | SYSTEMD_SERVICE:${PN} = "fluent-bit.service" |
112 | 119 | ||