summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPotin Lai <potin.lai@quantatw.com>2022-03-31 23:49:10 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-31 11:54:44 -0700
commitf42c97376693fe2f828f9315001f43089a8f21ae (patch)
tree1c0b1081a29f2613db492274960cb8e2c4d13412
parent69c9070f9e918ecc847c893691f430578db69ad0 (diff)
downloadmeta-openembedded-f42c97376693fe2f828f9315001f43089a8f21ae.tar.gz
libimobiledevice-glue: fix undefined bswap error
Add patch for fixing undefiened bswap32 & bswap64 error on MIPS machine Signed-off-by: Potin Lai <potin.lai@quantatw.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch32
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb5
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch b/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch
new file mode 100644
index 000000000..cff37fb5d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch
@@ -0,0 +1,32 @@
1From 73fcf0b54f4c1fc07a2aa003dddaeb5a97177cce Mon Sep 17 00:00:00 2001
2From: Potin Lai <potin.lai@quantatw.com>
3Date: Thu, 31 Mar 2022 08:44:31 +0800
4Subject: [PATCH 1/1] fix undefined bswap32 and bswap64 errors for MIPS machine
5
6Replace bswap32 and bswap64 with internal defined version (__bswap_X)
7
8Upstream Status: Submitted [libimobiledevice-devel@libimobiledevice.org]
9
10Signed-off-by: Potin Lai <potin.lai@quantatw.com>
11---
12 include/endianness.h | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/include/endianness.h b/include/endianness.h
16index 099877a..88b63db 100644
17--- a/include/endianness.h
18+++ b/include/endianness.h
19@@ -113,8 +113,8 @@
20 && !defined(__FLOAT_WORD_ORDER__)) \
21 || (defined(__FLOAT_WORD_ORDER__) \
22 && __FLOAT_WORD_ORDER__ == __ORDER_BIG_ENDIAN__)
23-#define float_bswap64(x) bswap64(x)
24-#define float_bswap32(x) bswap32(x)
25+#define float_bswap64(x) __bswap_64(x)
26+#define float_bswap32(x) __bswap_32(x)
27 #else
28 #define float_bswap64(x) (x)
29 #define float_bswap32(x) (x)
30--
312.17.1
32
diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
index 831d32cdb..d5d90ea13 100644
--- a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
+++ b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
@@ -11,7 +11,10 @@ DEPENDS = "libplist"
11PV = "1.0.0+git${SRCPV}" 11PV = "1.0.0+git${SRCPV}"
12 12
13SRCREV = "ecb0996fd2a3b0539153dd3ef901d137bf498ffe" 13SRCREV = "ecb0996fd2a3b0539153dd3ef901d137bf498ffe"
14SRC_URI = "git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master" 14SRC_URI = "\
15 git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master \
16 file://0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch \
17"
15 18
16S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
17inherit autotools pkgconfig 20inherit autotools pkgconfig