summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Le Foll <brendan.le.foll@intel.com>2018-02-21 14:50:41 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:12:55 -0800
commitefc2e0837ea101bf86b4b7b162a459cbf19a9cfb (patch)
treef61df990bbdd05e98326b83d68a1f020f33d86e1
parent3e0ec54b8cfe994a0c5a23780fa036d851cd90a4 (diff)
downloadmeta-openembedded-efc2e0837ea101bf86b4b7b162a459cbf19a9cfb.tar.gz
mraa: Update recipe to use v1.9.0
The musl endian patch has been merged upstream so is no longer needed Signed-off-by: Brendan Le Foll <brendan.le.foll@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch29
-rw-r--r--meta-oe/recipes-extended/mraa/mraa_git.bb8
2 files changed, 3 insertions, 34 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch b/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch
deleted file mode 100644
index 401949e2e..000000000
--- a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 6c2649718fc9818da0d602a0b4767ea21a367e9e Mon Sep 17 00:00:00 2001
2From: Tim Orling <timothy.t.orling@linux.intel.com>
3Date: Sat, 27 Jan 2018 02:06:36 -0800
4Subject: [PATCH] examples/iio_driver.c: include endian.h to fix musl build
5
6* be16toh and le16toh are defined in endian.h
7
8Upstream-Status: Pending
9
10Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
11---
12 examples/iio_driver.c | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/examples/iio_driver.c b/examples/iio_driver.c
16index c5a0181..e3dc438 100644
17--- a/examples/iio_driver.c
18+++ b/examples/iio_driver.c
19@@ -23,6 +23,7 @@
20 */
21
22 #include <unistd.h>
23+#include <endian.h>
24 #include "mraa/iio.h"
25
26 static void
27--
282.13.6
29
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb
index e1d593cbe..16883be3a 100644
--- a/meta-oe/recipes-extended/mraa/mraa_git.bb
+++ b/meta-oe/recipes-extended/mraa/mraa_git.bb
@@ -3,15 +3,13 @@ HOMEPAGE = "https://github.com/intel-iot-devkit/mraa"
3SECTION = "libs" 3SECTION = "libs"
4 4
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=66493d54e65bfc12c7983ff2e884f37f" 6LIC_FILES_CHKSUM = "file://COPYING;md5=4b92a3b497d7943042a6db40c088c3f2"
7 7
8SRCREV = "8ddbcde84e2d146bc0f9e38504d6c89c14291480" 8SRCREV = "fbb7d9232067eac3f4508a37a8f7ea0c4fcebacb"
9PV = "1.7.0-git${SRCPV}" 9PV = "1.9.0-git${SRCPV}"
10 10
11SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http" 11SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http"
12 12
13SRC_URI_append_libc-musl = " file://0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch"
14
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14
17# CMakeLists.txt checks the architecture, only x86 and ARM supported for now 15# CMakeLists.txt checks the architecture, only x86 and ARM supported for now