summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-12 23:43:15 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-15 08:20:06 -0700
commiteedd174a26b712a44a9ba9bb0c69094bc70d8bd2 (patch)
tree28503313c28b2a481811f474a4139c207b9438eb
parentada136e89fe54eb1474bd2b85e846108fb447794 (diff)
downloadmeta-openembedded-eedd174a26b712a44a9ba9bb0c69094bc70d8bd2.tar.gz
stress-ng: Upgrade to 0.09.37
Carries fixes needed for building with glibc 2.28+ Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch28
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch2
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng/0002-stress-fcntl-fix-build-for-musl.patch25
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb (renamed from meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb)8
4 files changed, 33 insertions, 30 deletions
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch
new file mode 100644
index 000000000..fd2199e53
--- /dev/null
+++ b/meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch
@@ -0,0 +1,28 @@
1From 7c97710bfc44d895b7111bef9c55866f00a3589c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Aug 2018 11:54:27 -0700
4Subject: [PATCH] Revert "Makefile: force sync after build in case reboot loses
5 executable"
6
7This reverts commit ae6322b1baea56a589207c96e358daae8edd0a8f.
8
9Not needed for cross-builds
10
11Upstream-Status: Inappropriate [Cross compile specific]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 Makefile | 1 -
15 1 file changed, 1 deletion(-)
16
17Index: stress-ng-0.09.37/Makefile
18===================================================================
19--- stress-ng-0.09.37.orig/Makefile
20+++ stress-ng-0.09.37/Makefile
21@@ -344,7 +344,6 @@ OBJS += $(CONFIG_OBJS)
22 stress-ng: info $(OBJS)
23 @echo "LD $@"
24 @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
25- @sync
26
27 .PHONY: info
28 info:
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch
index d604f860a..93d9b544d 100644
--- a/meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch
+++ b/meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch
@@ -1,4 +1,4 @@
1From 784dcd09d3f266e271d007f4fd257e85036872ca Mon Sep 17 00:00:00 2001 1From d499375fe267be8819ecb985123d89a21edc0e59 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?An=C3=ADbal=20Lim=C3=B3n?= <anibal.limon@linaro.org> 2From: =?UTF-8?q?An=C3=ADbal=20Lim=C3=B3n?= <anibal.limon@linaro.org>
3Date: Tue, 17 Oct 2017 10:13:20 -0500 3Date: Tue, 17 Oct 2017 10:13:20 -0500
4Subject: [PATCH] Several changes to fix musl build 4Subject: [PATCH] Several changes to fix musl build
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0002-stress-fcntl-fix-build-for-musl.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0002-stress-fcntl-fix-build-for-musl.patch
deleted file mode 100644
index ed3287e32..000000000
--- a/meta-oe/recipes-test/stress-ng/stress-ng/0002-stress-fcntl-fix-build-for-musl.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From faadbc147394cea9278bc2494f33e3521d88e742 Mon Sep 17 00:00:00 2001
2From: Tim Orling <timothy.t.orling@linux.intel.com>
3Date: Tue, 9 Jan 2018 18:38:45 -0800
4Subject: [PATCH] stress-fcntl: fix build for musl
5
6Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
7
8Upstream-status: Pending
9
10---
11 stress-fcntl.c | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/stress-fcntl.c b/stress-fcntl.c
15index 2ea867b..e91b345 100644
16--- a/stress-fcntl.c
17+++ b/stress-fcntl.c
18@@ -415,6 +415,7 @@ ofd_lock_abort: { /* Nowt */ }
19 #if (defined(F_GET_FILE_RW_HINT) && defined(F_SET_FILE_RW_HINT)) | \
20 (defined(F_GET_RW_HINT) && defined(F_SET_RW_HINT))
21 {
22+ int ret;
23 size_t i;
24 unsigned long hint;
25 static const unsigned long hints[] = {
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb
index 7fab43025..19ce64192 100644
--- a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb
+++ b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb
@@ -6,13 +6,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6DEPENDS = "zlib libaio" 6DEPENDS = "zlib libaio"
7 7
8SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \ 8SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0002-stress-fcntl-fix-build-for-musl.patch \ 9 file://0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch \
10 " 10 "
11SRC_URI_append_libc-musl = " \ 11SRC_URI_append_libc-musl = " \
12 file://0001-Several-changes-to-fix-musl-build.patch \ 12 file://0001-Several-changes-to-fix-musl-build.patch \
13 " 13 "
14SRC_URI[md5sum] = "1f8b6c2c2830704d2a2814c16082d48e" 14SRC_URI[md5sum] = "81d73313ea7778f749470b6f950553af"
15SRC_URI[sha256sum] = "02cac34a5cb041197af60c1867844c6cbb089a6d10a38cdcf7b8f27bfaa6ef8f" 15SRC_URI[sha256sum] = "8494afb2f2e2cf7e79ec9c6c3129308b098e530141ba2b07d6547708fd63af3d"
16 16
17UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/" 17UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/"
18UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar" 18UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar"