diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-05-27 17:15:01 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-28 16:35:00 -0700 |
commit | ecc683bbd810e5a44cb1199fa749ae093de26413 (patch) | |
tree | cea9946d964087e9d93ab1d64a0b1fab46cfe196 | |
parent | ceb4c4019b0e6d2d15bded3976723646316c156a (diff) | |
download | meta-openembedded-ecc683bbd810e5a44cb1199fa749ae093de26413.tar.gz |
gnome-online-accounts: Replace filename with basename
Fixes
WARNING: gnome-online-accounts-3.48.0-r0 do_package_qa: QA Issue: File /usr/src/debug/gnome-online-accounts/3.48.0-r0/src/goaidentity/goaidentityenumtypes.h in package gnome-online-accounts-src contains reference to TMPDIR [buildpaths]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
2 files changed, 105 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-Replace-filename-with-basename.patch b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-Replace-filename-with-basename.patch new file mode 100644 index 0000000000..9bb1d6bb59 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-Replace-filename-with-basename.patch | |||
@@ -0,0 +1,104 @@ | |||
1 | From c4a2951f8a75c4151f009e42b26639e4f456d5a2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 27 May 2023 14:41:28 -0700 | ||
4 | Subject: [PATCH] Replace filename with basename | ||
5 | |||
6 | This avoids emitting absolute paths into generated sourcecode, it | ||
7 | improves reproducibility. See [1] | ||
8 | |||
9 | [1] https://developer-old.gnome.org/gobject/stable/glib-mkenums.html | ||
10 | |||
11 | Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/merge_requests/125] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | src/goa/goaenumtypes.c.template | 2 +- | ||
15 | src/goa/goaenumtypes.h.template | 2 +- | ||
16 | src/goabackend/goabackendenumtypes.c.template | 2 +- | ||
17 | src/goabackend/goabackendenumtypes.h.template | 2 +- | ||
18 | src/goaidentity/goaidentityenumtypes.c.in | 4 ++-- | ||
19 | src/goaidentity/goaidentityenumtypes.h.in | 2 +- | ||
20 | 6 files changed, 7 insertions(+), 7 deletions(-) | ||
21 | |||
22 | diff --git a/src/goa/goaenumtypes.c.template b/src/goa/goaenumtypes.c.template | ||
23 | index 3150fa71..c2bc4b0a 100644 | ||
24 | --- a/src/goa/goaenumtypes.c.template | ||
25 | +++ b/src/goa/goaenumtypes.c.template | ||
26 | @@ -5,7 +5,7 @@ | ||
27 | /*** END file-header ***/ | ||
28 | |||
29 | /*** BEGIN file-production ***/ | ||
30 | -/* enumerations from "@filename@" */ | ||
31 | +/* enumerations from "@basename@" */ | ||
32 | /*** END file-production ***/ | ||
33 | |||
34 | /*** BEGIN value-header ***/ | ||
35 | diff --git a/src/goa/goaenumtypes.h.template b/src/goa/goaenumtypes.h.template | ||
36 | index 040428c3..14548cb4 100644 | ||
37 | --- a/src/goa/goaenumtypes.h.template | ||
38 | +++ b/src/goa/goaenumtypes.h.template | ||
39 | @@ -9,7 +9,7 @@ G_BEGIN_DECLS | ||
40 | |||
41 | /*** BEGIN file-production ***/ | ||
42 | |||
43 | -/* enumerations from "@filename@" */ | ||
44 | +/* enumerations from "@basename@" */ | ||
45 | /*** END file-production ***/ | ||
46 | |||
47 | /*** BEGIN value-header ***/ | ||
48 | diff --git a/src/goabackend/goabackendenumtypes.c.template b/src/goabackend/goabackendenumtypes.c.template | ||
49 | index 6d2651da..05156bdd 100644 | ||
50 | --- a/src/goabackend/goabackendenumtypes.c.template | ||
51 | +++ b/src/goabackend/goabackendenumtypes.c.template | ||
52 | @@ -5,7 +5,7 @@ | ||
53 | /*** END file-header ***/ | ||
54 | |||
55 | /*** BEGIN file-production ***/ | ||
56 | -/* enumerations from "@filename@" */ | ||
57 | +/* enumerations from "@basename@" */ | ||
58 | /*** END file-production ***/ | ||
59 | |||
60 | /*** BEGIN value-header ***/ | ||
61 | diff --git a/src/goabackend/goabackendenumtypes.h.template b/src/goabackend/goabackendenumtypes.h.template | ||
62 | index 7321076e..51ce84bd 100644 | ||
63 | --- a/src/goabackend/goabackendenumtypes.h.template | ||
64 | +++ b/src/goabackend/goabackendenumtypes.h.template | ||
65 | @@ -9,7 +9,7 @@ G_BEGIN_DECLS | ||
66 | |||
67 | /*** BEGIN file-production ***/ | ||
68 | |||
69 | -/* enumerations from "@filename@" */ | ||
70 | +/* enumerations from "@basename@" */ | ||
71 | /*** END file-production ***/ | ||
72 | |||
73 | /*** BEGIN value-header ***/ | ||
74 | diff --git a/src/goaidentity/goaidentityenumtypes.c.in b/src/goaidentity/goaidentityenumtypes.c.in | ||
75 | index c0286907..8aad7ae4 100644 | ||
76 | --- a/src/goaidentity/goaidentityenumtypes.c.in | ||
77 | +++ b/src/goaidentity/goaidentityenumtypes.c.in | ||
78 | @@ -5,8 +5,8 @@ | ||
79 | /*** END file-header ***/ | ||
80 | |||
81 | /*** BEGIN file-production ***/ | ||
82 | -#include "@filename@" | ||
83 | -/* enumerations from "@filename@" */ | ||
84 | +#include "@basename@" | ||
85 | +/* enumerations from "@basename@" */ | ||
86 | /*** END file-production ***/ | ||
87 | |||
88 | /*** BEGIN value-header ***/ | ||
89 | diff --git a/src/goaidentity/goaidentityenumtypes.h.in b/src/goaidentity/goaidentityenumtypes.h.in | ||
90 | index 35d4d5c5..8719282a 100644 | ||
91 | --- a/src/goaidentity/goaidentityenumtypes.h.in | ||
92 | +++ b/src/goaidentity/goaidentityenumtypes.h.in | ||
93 | @@ -9,7 +9,7 @@ G_BEGIN_DECLS | ||
94 | |||
95 | /*** BEGIN file-production ***/ | ||
96 | |||
97 | -/* enumerations from "@filename@" */ | ||
98 | +/* enumerations from "@basename@" */ | ||
99 | /*** END file-production ***/ | ||
100 | |||
101 | /*** BEGIN value-header ***/ | ||
102 | -- | ||
103 | 2.40.1 | ||
104 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb index 948a738881..ca78fa0119 100644 --- a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb +++ b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb | |||
@@ -8,6 +8,7 @@ inherit gnomebase gsettings gobject-introspection gtk-icon-cache vala features_c | |||
8 | 8 | ||
9 | DEPENDS = "gdk-pixbuf dbus glib-2.0" | 9 | DEPENDS = "gdk-pixbuf dbus glib-2.0" |
10 | 10 | ||
11 | SRC_URI += "file://0001-Replace-filename-with-basename.patch" | ||
11 | SRC_URI[archive.sha256sum] = "418bb9fcffdbd72a98205ad365137617fc1e3551a54de74f6a98d45d266175bf" | 12 | SRC_URI[archive.sha256sum] = "418bb9fcffdbd72a98205ad365137617fc1e3551a54de74f6a98d45d266175bf" |
12 | 13 | ||
13 | PACKAGECONFIG ?= "goabackend kerberos owncloud lastfm google windows_live" | 14 | PACKAGECONFIG ?= "goabackend kerberos owncloud lastfm google windows_live" |