summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-12-05 14:37:46 +0000
committerKhem Raj <raj.khem@gmail.com>2018-12-05 10:18:59 -0800
commitebcd20dc7d11e020bbc3c9c84211e03f0f3f70d9 (patch)
tree0c7b0cf4d792caf8801b624c9268ba00f0bf7b49
parent030e8d445ad3601e6b4f59f951f6f9fe1d9341a2 (diff)
downloadmeta-openembedded-ebcd20dc7d11e020bbc3c9c84211e03f0f3f70d9.tar.gz
open-vm-tools: fix indentation and drop FILES_${PN}-dbg
* don't mix tabs and spaces for indentation, removes new warning: meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb: python should use 4 spaces indentation, but found tabs in open-vm-tools_10.3.0.bb, line 107 * remove FILES_${PN}-dbg variable, all .debug directories are packaged automatically in ${PN}-dbg for long time (at least since 2.1 Krogoth) since this oe-core commit: commit da5ec06814e105451cca11cce76b5c5231110524 Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Tue Dec 15 15:38:54 2015 +0000 package: Add auto package splitting of .debug files Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb47
1 files changed, 21 insertions, 26 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
index 478d762cf..2d7486da3 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.3.0.bb
@@ -22,22 +22,22 @@ LICENSE_modules/linux = "GPL-2.0"
22LICENSE_modules/solaris = "CDDL-1.0" 22LICENSE_modules/solaris = "CDDL-1.0"
23 23
24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \ 24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
25 file://tools.conf \ 25 file://tools.conf \
26 file://vmtoolsd.service \ 26 file://vmtoolsd.service \
27 file://vmtoolsd.init \ 27 file://vmtoolsd.init \
28 file://0001-configure.ac-don-t-use-dnet-config.patch \ 28 file://0001-configure.ac-don-t-use-dnet-config.patch \
29 file://0002-add-include-sys-sysmacros.h.patch \ 29 file://0002-add-include-sys-sysmacros.h.patch \
30 file://0005-Use-configure-test-for-struct-timespec.patch \ 30 file://0005-Use-configure-test-for-struct-timespec.patch \
31 file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \ 31 file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \
32 file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \ 32 file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \
33 file://0011-Use-configure-test-for-sys-stat.h-include.patch \ 33 file://0011-Use-configure-test-for-sys-stat.h-include.patch \
34 file://fix-subdir-objects-configure-error.patch \ 34 file://fix-subdir-objects-configure-error.patch \
35 file://0001-include-poll.h-instead-of-sys-poll.h.patch \ 35 file://0001-include-poll.h-instead-of-sys-poll.h.patch \
36 file://0002-Rename-poll.h-to-vm_poll.h.patch \ 36 file://0002-Rename-poll.h-to-vm_poll.h.patch \
37 file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \ 37 file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \
38 file://0004-Use-uintmax_t-for-handling-rlim_t.patch \ 38 file://0004-Use-uintmax_t-for-handling-rlim_t.patch \
39 file://0001-Use-off64_t-instead-of-__off64_t.patch \ 39 file://0001-Use-off64_t-instead-of-__off64_t.patch \
40 " 40"
41SRCREV = "2147df6aabe639fc5ff423ed791a8e7f02bf8d0a" 41SRCREV = "2147df6aabe639fc5ff423ed791a8e7f02bf8d0a"
42 42
43S = "${WORKDIR}/git/open-vm-tools" 43S = "${WORKDIR}/git/open-vm-tools"
@@ -52,9 +52,9 @@ inherit autotools pkgconfig systemd update-rc.d
52SYSTEMD_SERVICE_${PN} = "vmtoolsd.service" 52SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
53 53
54EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \ 54EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
55 --disable-tests --without-gtkmm --without-xerces --without-pam \ 55 --disable-tests --without-gtkmm --without-xerces --without-pam \
56 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \ 56 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
57 --without-root-privileges --without-kernel-modules" 57 --without-root-privileges --without-kernel-modules"
58 58
59NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3" 59NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
60X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf" 60X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
@@ -68,13 +68,9 @@ FILES_${PN} += "\
68 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \ 68 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
69 ${libdir}/open-vm-tools/plugins/common/lib*.so \ 69 ${libdir}/open-vm-tools/plugins/common/lib*.so \
70 ${sysconfdir}/vmware-tools/tools.conf \ 70 ${sysconfdir}/vmware-tools/tools.conf \
71 " 71"
72FILES_${PN}-locale += "${datadir}/open-vm-tools/messages" 72FILES_${PN}-locale += "${datadir}/open-vm-tools/messages"
73FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la" 73FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
74FILES_${PN}-dbg += "\
75 ${libdir}/open-vm-tools/plugins/common/.debug \
76 ${libdir}/open-vm-tools/plugins/vmsvc/.debug \
77 "
78 74
79CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf" 75CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
80 76
@@ -104,7 +100,6 @@ INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
104 100
105python() { 101python() {
106 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \ 102 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
107 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split(): 103 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
108 raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.') 104 raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
109} 105}
110