summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2024-10-23 15:36:44 +0300
committerKhem Raj <raj.khem@gmail.com>2024-10-24 05:52:19 -0700
commite96604395ded9a620ec4995d3619b96dd2448cde (patch)
treee69ef6c222ebf3a2de1c3115b655bcba746531a1
parent94b51dc5761b03fa66d6f56295c7cad55e154c15 (diff)
downloadmeta-openembedded-e96604395ded9a620ec4995d3619b96dd2448cde.tar.gz
python3-trustme: Upgrade 1.1.0 -> 1.2.0
Upgrade to release 1.2.0: - Add support for Python 3.13 - Allow setting of cert's notBefore attribute - Add the Authority Key Identifier extension to child CA certificates - Remove support for Python 3.8 and PyPy 3.9 The project has a proper pyproject.toml which declares the setuptools.build.meta PEP-517 backend. Fixes: WARNING: python3-trustme-1.2.0-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with hatchling.build, use the correct class [pep517-backend] Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-trustme_1.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb)5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb b/meta-python/recipes-devtools/python/python3-trustme_1.2.0.bb
index dab18f28b6..69db7e6189 100644
--- a/meta-python/recipes-devtools/python/python3-trustme_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-trustme_1.2.0.bb
@@ -4,9 +4,9 @@ HOMEPAGE = "https://pypi.org/project/trustme"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d5a7af1a4b73e57431e25d15a2da745a" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=d5a7af1a4b73e57431e25d15a2da745a"
6 6
7SRC_URI[sha256sum] = "5375ad7fb427074bec956592e0d4ee2a4cf4da68934e1ba4bcf4217126bc45e6" 7SRC_URI[sha256sum] = "ed2264fb46c35459e6de9e454ed4bab73be44b6a2a26ad417f9b6854aebb644a"
8 8
9inherit pypi setuptools3 ptest 9inherit pypi python_hatchling python_setuptools_build_meta ptest
10 10
11SRC_URI += " \ 11SRC_URI += " \
12 file://run-ptest \ 12 file://run-ptest \
@@ -32,5 +32,4 @@ RDEPENDS:${PN}-ptest += " \
32do_install_ptest() { 32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/tests 33 install -d ${D}${PTEST_PATH}/tests
34 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ 34 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
35 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
36} 35}