summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Wagenknecht <dwagenknecht@emlix.com>2021-03-08 14:53:18 +0100
committerKhem Raj <raj.khem@gmail.com>2021-03-08 12:51:44 -0800
commite8dd3c02519ec38344b8b9962b833eeb5668f01a (patch)
treef6914b9937354810f1ac34b86c457d8c924d199a
parent61e3bc3907250cebdc78ae37dc9349cbb78ee85a (diff)
downloadmeta-openembedded-e8dd3c02519ec38344b8b9962b833eeb5668f01a.tar.gz
gnome-keyring: set file capabilities in pkg_postinst
file capabilities need to be set on gnome-keyring-daemon. This is now possible using pkg_postinst function on the build host. Previous workarounds are not needed anymore. Signed-off-by: Daniel Wagenknecht <dwagenknecht@emlix.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.36.0.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.36.0.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.36.0.bb
index 8f318bb15..3fc16bb0a 100644
--- a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.36.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.36.0.bb
@@ -43,10 +43,8 @@ FILES_${PN} += " \
43 ${base_libdir}/security/*${SOLIBSDEV} \ 43 ${base_libdir}/security/*${SOLIBSDEV} \
44 ${libdir}/pkcs11/gnome-keyring-pkcs11.so \ 44 ${libdir}/pkcs11/gnome-keyring-pkcs11.so \
45" 45"
46
47# fix | gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used 46# fix | gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
48# This does not make it through pseudo so perform on-target - sigh 47pkg_postinst_${PN} () {
49pkg_postinst_ontarget_${PN} () { 48 setcap cap_ipc_lock+ep $D/${bindir}/gnome-keyring-daemon
50 setcap cap_ipc_lock+ep `which gnome-keyring-daemon`
51} 49}
52RDEPENDS_${PN} += "libcap-bin" 50PACKAGE_WRITE_DEPS += "libcap-native"