diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-02-04 23:44:47 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-05 10:59:44 -0800 |
commit | e81cc160019e3ccea527d079620961db3def83e9 (patch) | |
tree | 71b616581b1478f67e8c7b1d6134459a9b91e3b9 | |
parent | 326d19c39389f977d22a745ca3fcf6ab58c235ea (diff) | |
download | meta-openembedded-e81cc160019e3ccea527d079620961db3def83e9.tar.gz |
geany,geany-plugins: Upgrade to 1.37.x
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/geany/geany-plugins/0002-Make-libgit2-version-preprocessor-conditionals-compatible.patch | 55 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/geany/geany-plugins_1.37.bb (renamed from meta-oe/recipes-devtools/geany/geany-plugins_1.36.bb) | 4 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/geany/geany_1.37.1.bb (renamed from meta-oe/recipes-devtools/geany/geany_1.36.bb) | 8 |
3 files changed, 7 insertions, 60 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany-plugins/0002-Make-libgit2-version-preprocessor-conditionals-compatible.patch b/meta-oe/recipes-devtools/geany/geany-plugins/0002-Make-libgit2-version-preprocessor-conditionals-compatible.patch deleted file mode 100644 index 25e5ac4ea..000000000 --- a/meta-oe/recipes-devtools/geany/geany-plugins/0002-Make-libgit2-version-preprocessor-conditionals-compatible.patch +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | From 9497d829e1b207eb83575dc6f617feecfb89bc16 Mon Sep 17 00:00:00 2001 | ||
2 | From: Dominik Schmidt <dominik@schm1dt.ch> | ||
3 | Date: Sun, 23 Feb 2020 19:15:30 +0100 | ||
4 | Subject: [PATCH] Make libgit2 version preprocessor conditionals compatible | ||
5 | with libgit2-0.99 | ||
6 | |||
7 | LIBGIT2_SOVERSION is defined as string literal, e.g. "0.99", | ||
8 | from libgit2-0.99 and beyond. Arithmetic checks against this | ||
9 | variable whill hence fail. This patch switches the checks to | ||
10 | compare against the LIBGIT2_VER_* family, which should be more stable. | ||
11 | --- | ||
12 | git-changebar/src/gcb-plugin.c | 6 +++--- | ||
13 | workbench/src/plugin_main.c | 2 +- | ||
14 | 2 files changed, 4 insertions(+), 4 deletions(-) | ||
15 | |||
16 | diff --git a/git-changebar/src/gcb-plugin.c b/git-changebar/src/gcb-plugin.c | ||
17 | index b7083199..a911815f 100644 | ||
18 | --- a/git-changebar/src/gcb-plugin.c | ||
19 | +++ b/git-changebar/src/gcb-plugin.c | ||
20 | @@ -32,11 +32,11 @@ | ||
21 | #include <geany.h> | ||
22 | #include <document.h> | ||
23 | |||
24 | -#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 22 | ||
25 | +#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 22) ) | ||
26 | # define git_libgit2_init git_threads_init | ||
27 | # define git_libgit2_shutdown git_threads_shutdown | ||
28 | #endif | ||
29 | -#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 23 | ||
30 | +#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 23) ) | ||
31 | /* 0.23 added @p binary_cb */ | ||
32 | # define git_diff_buffers(old_buffer, old_len, old_as_path, \ | ||
33 | new_buffer, new_len, new_as_path, options, \ | ||
34 | @@ -45,7 +45,7 @@ | ||
35 | new_buffer, new_len, new_as_path, options, \ | ||
36 | file_cb, hunk_cb, line_cb, payload) | ||
37 | #endif | ||
38 | -#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 28 | ||
39 | +#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 28) ) | ||
40 | # define git_buf_dispose git_buf_free | ||
41 | # define git_error_last giterr_last | ||
42 | #endif | ||
43 | diff --git a/workbench/src/plugin_main.c b/workbench/src/plugin_main.c | ||
44 | index 6fa6fc84..25ecdf6d 100644 | ||
45 | --- a/workbench/src/plugin_main.c | ||
46 | +++ b/workbench/src/plugin_main.c | ||
47 | @@ -36,7 +36,7 @@ | ||
48 | #include "tm_control.h" | ||
49 | |||
50 | |||
51 | -#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 22 | ||
52 | +#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 22)) | ||
53 | # define git_libgit2_init git_threads_init | ||
54 | # define git_libgit2_shutdown git_threads_shutdown | ||
55 | #endif | ||
diff --git a/meta-oe/recipes-devtools/geany/geany-plugins_1.36.bb b/meta-oe/recipes-devtools/geany/geany-plugins_1.37.bb index 3cf260573..890bbdb44 100644 --- a/meta-oe/recipes-devtools/geany/geany-plugins_1.36.bb +++ b/meta-oe/recipes-devtools/geany/geany-plugins_1.37.bb | |||
@@ -31,10 +31,8 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
31 | SRC_URI = " \ | 31 | SRC_URI = " \ |
32 | https://plugins.geany.org/${BPN}/${BP}.tar.bz2 \ | 32 | https://plugins.geany.org/${BPN}/${BP}.tar.bz2 \ |
33 | file://0001-Use-pkg-config-to-find-gpgme.patch \ | 33 | file://0001-Use-pkg-config-to-find-gpgme.patch \ |
34 | file://0002-Make-libgit2-version-preprocessor-conditionals-compatible.patch \ | ||
35 | " | 34 | " |
36 | SRC_URI[md5sum] = "91fb4634953702f914d9105da7048a33" | 35 | SRC_URI[sha256sum] = "c98f9b1303f4ab9bed7587e749cd0b5594d9136a1bf8ba110900d46a17fa9cd8" |
37 | SRC_URI[sha256sum] = "ebe18dd699292174622e8cb8745b020ada8a5be3b604ab980af36e8518df7ce6" | ||
38 | 36 | ||
39 | do_configure_prepend() { | 37 | do_configure_prepend() { |
40 | rm -f ${S}/build/cache/glib-gettext.m4 | 38 | rm -f ${S}/build/cache/glib-gettext.m4 |
diff --git a/meta-oe/recipes-devtools/geany/geany_1.36.bb b/meta-oe/recipes-devtools/geany/geany_1.37.1.bb index 039999f6b..330daaace 100644 --- a/meta-oe/recipes-devtools/geany/geany_1.36.bb +++ b/meta-oe/recipes-devtools/geany/geany_1.37.1.bb | |||
@@ -10,11 +10,15 @@ inherit features_check autotools pkgconfig perlnative gettext mime-xdg | |||
10 | REQUIRED_DISTRO_FEATURES = "x11" | 10 | REQUIRED_DISTRO_FEATURES = "x11" |
11 | 11 | ||
12 | SRC_URI = "https://download.geany.org/${BP}.tar.bz2" | 12 | SRC_URI = "https://download.geany.org/${BP}.tar.bz2" |
13 | SRC_URI[md5sum] = "53216a43345e2b6dbefa02ac24885753" | 13 | SRC_URI[sha256sum] = "18c5756444c1d8bcd737c8ecfd4ef0b3607c924fc02560d4e8b78f6121531a18" |
14 | SRC_URI[sha256sum] = "9184dd3dd40b7b84fca70083284bb9dbf2ee8022bf2be066bdc36592d909d53e" | ||
15 | 14 | ||
16 | FILES_${PN} += "${datadir}/icons" | 15 | FILES_${PN} += "${datadir}/icons" |
17 | 16 | ||
18 | EXTRA_OECONF = "--disable-html-docs" | 17 | EXTRA_OECONF = "--disable-html-docs" |
19 | 18 | ||
19 | do_configure_prepend() { | ||
20 | cd ${S} | ||
21 | intltoolize --copy --force --automake | ||
22 | } | ||
23 | |||
20 | RRECOMMENDS_${PN} += "source-code-pro-fonts" | 24 | RRECOMMENDS_${PN} += "source-code-pro-fonts" |