summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-09-18 23:10:02 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:54 +0200
commite335110e1e051411207a3f4ce55a1a9388e35daa (patch)
tree485ab58d772826360de54eb4219ce7b8c3afaa9e
parentf25843b7fa9acdfac980a581118190ca6bb7fbf3 (diff)
downloadmeta-openembedded-e335110e1e051411207a3f4ce55a1a9388e35daa.tar.gz
imagemagick: do not install magick-baseconfig.h repeatedly
Both targets install-data-local & install-includeHEADERS will install header file magick-baseconfig.h to the same location, and they might be run in the same time while enabling parallel build: * target dependencies: + install-data-am: ... install-data-local ... install-includeHEADERS * make install error: /usr/bin/install: cannot create regular file \ `.../usr/include/ImageMagick-6/magick/magick-baseconfig.h': \ File exists \ make[3]: *** [install-magickincarchHEADERS] Error 1 * reproduce the error: $ /usr/bin/install test /tmp & /usr/bin/install test /tmp [1] 4052 /usr/bin/install: cannot create regular file `/tmp/test': File exists [1]+ Exit 1 /usr/bin/install test /tmp Just disable the one from install-data-local to remove this race issue. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch49
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch b/meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch
new file mode 100644
index 000000000..114fb5ed4
--- /dev/null
+++ b/meta-oe/recipes-support/imagemagick/imagemagick/do-not-install-magick-baseconfig.h-repeatedly.patch
@@ -0,0 +1,49 @@
1From bbdd42384d0b5f3ccb11465f63d90097579a1897 Mon Sep 17 00:00:00 2001
2From: Konrad Scherer <konrad.scherer@windriver.com>
3Date: Tue, 10 Jun 2014 15:43:16 +0800
4Subject: [PATCH] imagemagick: do not install magick-baseconfig.h repeatedly
5
6Both targets install-data-local & install-includeHEADERS will install
7header file magick-baseconfig.h to the same location, and they might
8be run in the same time while enabling parallel build:
9
10* target dependencies:
11 + install-data-am: ... install-data-local ... install-includeHEADERS
12
13* make install error:
14 /usr/bin/install: cannot create regular file \
15 `.../usr/include/ImageMagick-6/magick/magick-baseconfig.h': \
16 File exists \
17 make[3]: *** [install-magickincarchHEADERS] Error 1
18
19* reproduce the error:
20 $ /usr/bin/install test /tmp & /usr/bin/install test /tmp
21 [1] 4052
22 /usr/bin/install: cannot create regular file `/tmp/test': File exists
23 [1]+ Exit 1 /usr/bin/install test /tmp
24
25Just disable the one from install-data-local to remove this race issue.
26
27Upstream-Status: pending
28
29Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
30---
31 magick/Makefile.am | 2 +-
32 1 file changed, 1 insertion(+), 1 deletion(-)
33
34diff --git a/magick/Makefile.am b/magick/Makefile.am
35index 2f72461..e45466c 100644
36--- a/magick/Makefile.am
37+++ b/magick/Makefile.am
38@@ -468,7 +468,7 @@ MAGICK_EXTRA_DIST = \
39 magick/xwdfile.h_vms
40
41 # Install magick-baseconfig.h
42-MAGICK_INSTALL_DATA_LOCAL_TARGETS = magick-install-data-local
43+MAGICK_INSTALL_DATA_LOCAL_TARGETS =
44 magick-install-data-local:
45 $(mkinstalldirs) $(DESTDIR)$(magickincarchdir)
46 $(INSTALL_HEADER) magick/magick-baseconfig.h $(DESTDIR)$(magickincarchdir)/magick-baseconfig.h
47--
481.8.2.1
49
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
index 31207daa6..847ab3493 100644
--- a/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.8.8.bb
@@ -8,6 +8,7 @@ DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
8PATCHSET = "10" 8PATCHSET = "10"
9SRC_URI = "http://www.imagemagick.org/download/legacy/ImageMagick-${PV}-${PATCHSET}.tar.bz2 \ 9SRC_URI = "http://www.imagemagick.org/download/legacy/ImageMagick-${PV}-${PATCHSET}.tar.bz2 \
10 file://remove.dist-lzip.patch \ 10 file://remove.dist-lzip.patch \
11 file://do-not-install-magick-baseconfig.h-repeatedly.patch \
11" 12"
12SRC_URI[md5sum] = "a3a0fa301965d6fde68fccd066f62b0b" 13SRC_URI[md5sum] = "a3a0fa301965d6fde68fccd066f62b0b"
13SRC_URI[sha256sum] = "8c0982b2bc0c1cea8ac9627b4e1e5d37f8171ef8282ee09aef32529cf68e1820" 14SRC_URI[sha256sum] = "8c0982b2bc0c1cea8ac9627b4e1e5d37f8171ef8282ee09aef32529cf68e1820"