summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-09-16 14:19:17 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-26 08:29:10 +0200
commitdf0c384b38ab220098c84267933e71d5f8c9d528 (patch)
tree13648854c1dbbaed0234701f8153670567797b5c
parentfe249f8c5dcce33666447d74d886d6474c676a8d (diff)
downloadmeta-openembedded-df0c384b38ab220098c84267933e71d5f8c9d528.tar.gz
tslib: move recipe from oe-core
Move tslib recipe from oe-core layer. Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib/ts.conf25
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib/tslib.sh8
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib_1.1.bb53
3 files changed, 86 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/tslib/tslib/ts.conf b/meta-oe/recipes-graphics/tslib/tslib/ts.conf
new file mode 100644
index 000000000..1b0da937e
--- /dev/null
+++ b/meta-oe/recipes-graphics/tslib/tslib/ts.conf
@@ -0,0 +1,25 @@
1# Uncomment if you wish to use the linux input layer event interface
2module_raw input
3
4# Uncomment if you're using a Sharp Zaurus SL-5500/SL-5000d
5# module_raw collie
6
7# Uncomment if you're using a Sharp Zaurus SL-C700/C750/C760/C860
8# module_raw corgi
9
10# Uncomment if you're using a device with a UCB1200/1300/1400 TS interface
11# module_raw ucb1x00
12
13# Uncomment if you're using an HP iPaq h3600 or similar
14# module_raw h3600
15
16# Uncomment if you're using a Hitachi Webpad
17# module_raw mk712
18
19# Uncomment if you're using an IBM Arctic II
20# module_raw arctic2
21
22module pthres pmin=1
23module variance delta=30
24module dejitter delta=100
25module linear
diff --git a/meta-oe/recipes-graphics/tslib/tslib/tslib.sh b/meta-oe/recipes-graphics/tslib/tslib/tslib.sh
new file mode 100644
index 000000000..7068e8d92
--- /dev/null
+++ b/meta-oe/recipes-graphics/tslib/tslib/tslib.sh
@@ -0,0 +1,8 @@
1#!/bin/sh
2
3if [ -e /dev/input/touchscreen0 ]; then
4 TSLIB_TSDEVICE=/dev/input/touchscreen0
5
6 export TSLIB_TSDEVICE
7fi
8
diff --git a/meta-oe/recipes-graphics/tslib/tslib_1.1.bb b/meta-oe/recipes-graphics/tslib/tslib_1.1.bb
new file mode 100644
index 000000000..502034a9c
--- /dev/null
+++ b/meta-oe/recipes-graphics/tslib/tslib_1.1.bb
@@ -0,0 +1,53 @@
1SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.berlios.de/"
7
8AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
9SECTION = "base"
10LICENSE = "LGPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
12
13SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
14 file://ts.conf \
15 file://tslib.sh \
16"
17
18SRC_URI[md5sum] = "14771f8607b341bb4b297819d37e837d"
19SRC_URI[sha256sum] = "fe35e5f710ea933b118f710e2ce4403ac076fe69926b570333867d4de082a51c"
20
21UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
22
23inherit autotools pkgconfig
24
25EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
26
27do_install_prepend() {
28 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
29}
30
31do_install_append() {
32 install -d ${D}${sysconfdir}/profile.d/
33 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
34}
35
36# People should consider using udev's /dev/input/touchscreen0 symlink
37# instead of detect-stylus
38#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
39RPROVIDES_tslib-conf = "libts-0.0-conf"
40
41PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate"
42DEBIAN_NOAUTONAME_tslib-conf = "1"
43DEBIAN_NOAUTONAME_tslib-tests = "1"
44DEBIAN_NOAUTONAME_tslib-calibrate = "1"
45
46RDEPENDS_${PN} = "tslib-conf"
47RRECOMMENDS_${PN} = "pointercal"
48
49FILES_${PN}-dev += "${libdir}/ts/*.la"
50FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
51FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
52FILES_tslib-calibrate += "${bindir}/ts_calibrate"
53FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"