summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-06-18 19:55:14 +0300
committerKhem Raj <raj.khem@gmail.com>2019-06-18 15:58:26 -0700
commitde09894f395d5d7b456d482cf60c05a9a3dc3f08 (patch)
treefd2992582a9682541af26810ba8dc10b39516562
parent4257adeeb5038fec4f7cd0499f878719461ec77a (diff)
downloadmeta-openembedded-de09894f395d5d7b456d482cf60c05a9a3dc3f08.tar.gz
xl2tpd: Remove the old 1.3.6 version
It started as one recipe for the latest stable release and one for the latest git, but after these became ancient release and latest release it no longer made sense to have two recipees. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc39
-rw-r--r--meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.14.bb41
-rw-r--r--meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.6.bb7
3 files changed, 38 insertions, 49 deletions
diff --git a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc b/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
deleted file mode 100644
index 43942bcae..000000000
--- a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "Xelerance version of the Layer 2 Tunneling Protocol (L2TP) daemon"
2HOMEPAGE = "http://www.xelerance.com/software/xl2tpd/"
3SECTION = "net"
4DEPENDS = "ppp virtual/kernel"
5
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "git://github.com/xelerance/xl2tpd.git"
12
13S = "${WORKDIR}/git"
14
15inherit update-rc.d
16
17do_compile () {
18 oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all
19}
20
21do_install () {
22 oe_runmake PREFIX="${D}${prefix}" install
23
24 install -d ${D}${sysconfdir}/init.d
25 touch ${D}${sysconfdir}/xl2tpd.conf
26 install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd
27 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
28 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
29 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
30 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd
31
32 install -d ${D}${sysconfdir}/default
33 install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd
34}
35
36CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd"
37
38INITSCRIPT_PACKAGES = "${PN}"
39INITSCRIPT_NAME_${PN} = "xl2tpd"
diff --git a/meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.14.bb b/meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.14.bb
index f03b537d9..b02e183db 100644
--- a/meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.14.bb
+++ b/meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.14.bb
@@ -1,5 +1,40 @@
1require xl2tpd.inc 1SUMMARY = "Xelerance version of the Layer 2 Tunneling Protocol (L2TP) daemon"
2HOMEPAGE = "http://www.xelerance.com/software/xl2tpd/"
3SECTION = "net"
4DEPENDS = "ppp virtual/kernel"
2 5
3# This is v1.3.6 plus some commits. There is no tag for this commit. 6PACKAGE_ARCH = "${MACHINE_ARCH}"
4# 7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "git://github.com/xelerance/xl2tpd.git"
5SRCREV = "ba619c79c4790c78c033df0abde4a9a5de744a08" 12SRCREV = "ba619c79c4790c78c033df0abde4a9a5de744a08"
13
14S = "${WORKDIR}/git"
15
16inherit update-rc.d
17
18do_compile () {
19 oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all
20}
21
22do_install () {
23 oe_runmake PREFIX="${D}${prefix}" install
24
25 install -d ${D}${sysconfdir}/init.d
26 touch ${D}${sysconfdir}/xl2tpd.conf
27 install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd
28 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
29 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
30 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
31 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd
32
33 install -d ${D}${sysconfdir}/default
34 install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd
35}
36
37CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd"
38
39INITSCRIPT_PACKAGES = "${PN}"
40INITSCRIPT_NAME_${PN} = "xl2tpd"
diff --git a/meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.6.bb b/meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.6.bb
deleted file mode 100644
index df2ec52c6..000000000
--- a/meta-networking/recipes-protocols/xl2tpd/xl2tpd_1.3.6.bb
+++ /dev/null
@@ -1,7 +0,0 @@
1require xl2tpd.inc
2
3# The SRCREV corresponds to v1.3.6.
4# Adding tag=v1.3.6 to the SRC_URI will force access to the upstream repo.
5#
6SRCREV = "5619e1771048e74b729804e8602f409af0f3faea"
7