summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-20 21:05:39 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-23 08:44:43 -0700
commitddc8a6557fd0dfd8ea42019970f84006b640a806 (patch)
treebf9b6535fdf9e60d21c24bc023ac05c863698a21
parent35cf63e5f3953c5ab398bc2f806aea806cbe90bb (diff)
downloadmeta-openembedded-ddc8a6557fd0dfd8ea42019970f84006b640a806.tar.gz
etcd-cpp-apiv3: Fix build on musl + GCC14
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/etcd/etcd-cpp-apiv3/0001-include-stdint.h-for-int64_t-types.patch27
-rw-r--r--meta-oe/recipes-extended/etcd/etcd-cpp-apiv3_0.15.3.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/etcd/etcd-cpp-apiv3/0001-include-stdint.h-for-int64_t-types.patch b/meta-oe/recipes-extended/etcd/etcd-cpp-apiv3/0001-include-stdint.h-for-int64_t-types.patch
new file mode 100644
index 000000000..373e146b9
--- /dev/null
+++ b/meta-oe/recipes-extended/etcd/etcd-cpp-apiv3/0001-include-stdint.h-for-int64_t-types.patch
@@ -0,0 +1,27 @@
1From 44f4254fe96c43437400f94a8a2800175ddf3279 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 20 May 2024 21:00:48 -0700
4Subject: [PATCH] include stdint.h for int64_t types
5
6This is exposed when compiling for musl platforms where this
7header is not included indirectly.
8
9Upstream-Status: Submitted [https://github.com/etcd-cpp-apiv3/etcd-cpp-apiv3/pull/270]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 src/Value.cpp | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/src/Value.cpp b/src/Value.cpp
16index cbda697..d6f2c9c 100644
17--- a/src/Value.cpp
18+++ b/src/Value.cpp
19@@ -1,4 +1,5 @@
20 #include <iomanip>
21+#include <cstdint>
22
23 #include "etcd/Value.hpp"
24 #include "etcd/v3/KeyValue.hpp"
25--
262.45.1
27
diff --git a/meta-oe/recipes-extended/etcd/etcd-cpp-apiv3_0.15.3.bb b/meta-oe/recipes-extended/etcd/etcd-cpp-apiv3_0.15.3.bb
index 401d53c79..2e149577d 100644
--- a/meta-oe/recipes-extended/etcd/etcd-cpp-apiv3_0.15.3.bb
+++ b/meta-oe/recipes-extended/etcd/etcd-cpp-apiv3_0.15.3.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eae7da6a2cd1788a5cf8a9f838cf6450"
7SRC_URI = " \ 7SRC_URI = " \
8 git://github.com/etcd-cpp-apiv3/etcd-cpp-apiv3.git;branch=master;protocol=https \ 8 git://github.com/etcd-cpp-apiv3/etcd-cpp-apiv3.git;branch=master;protocol=https \
9 file://0001-cmake-fix-when-cross-compiling.patch \ 9 file://0001-cmake-fix-when-cross-compiling.patch \
10 file://0001-include-stdint.h-for-int64_t-types.patch \
10" 11"
11 12
12SRCREV = "e31ac4d4caa55fa662e207150ba40f8151b7ad96" 13SRCREV = "e31ac4d4caa55fa662e207150ba40f8151b7ad96"