diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2022-11-01 19:03:26 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-11-02 07:58:18 -0700 |
commit | dd6ab68c21a5bf496938dad869064d35cd166e10 (patch) | |
tree | 526bbff0aedc13c153066a662bab6d359eb87cc2 | |
parent | 6ebff843cce0a66a7749e048f280bb9cfdca5946 (diff) | |
download | meta-openembedded-dd6ab68c21a5bf496938dad869064d35cd166e10.tar.gz |
python3-automat: Upgrade 20.2.0 -> 22.10.0
Upgrade to release 22.10.0:
- Added double-spaces after embedded youtube links
- Add explanation for how to use assert to pacify mypy
- Allow enter to have a default
- CI improvements
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-automat/0001-setup.py-remove-the-dependency-on-m2r.patch | 53 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-automat_22.10.0.bb (renamed from meta-python/recipes-devtools/python/python3-automat_20.2.0.bb) | 7 |
2 files changed, 1 insertions, 59 deletions
diff --git a/meta-python/recipes-devtools/python/python3-automat/0001-setup.py-remove-the-dependency-on-m2r.patch b/meta-python/recipes-devtools/python/python3-automat/0001-setup.py-remove-the-dependency-on-m2r.patch deleted file mode 100644 index b83b7f380..000000000 --- a/meta-python/recipes-devtools/python/python3-automat/0001-setup.py-remove-the-dependency-on-m2r.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | From 4fb6bbfbc53428fe5d38ec3e04bb4fd187b2fd45 Mon Sep 17 00:00:00 2001 | ||
2 | From: Derek Straka <derek@asterius.io> | ||
3 | Date: Fri, 22 Dec 2017 09:07:00 -0500 | ||
4 | Subject: [PATCH] setup.py: remove the dependency on m2r | ||
5 | |||
6 | The dependency on m2r is removed here as it only provides the | ||
7 | long_description value that is optional. This item is just the | ||
8 | text that would be present on PyPi, so it doesn't provide much | ||
9 | value in this case | ||
10 | |||
11 | Upstream-Status: Inappropriate (OE specific) | ||
12 | |||
13 | Signed-off-by: Derek Straka <derek@asterius.io> | ||
14 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
15 | --- | ||
16 | setup.py | 10 ---------- | ||
17 | 1 file changed, 10 deletions(-) | ||
18 | |||
19 | diff --git a/setup.py b/setup.py | ||
20 | index 3fb7fdb..245d69a 100644 | ||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -4,14 +4,6 @@ Setup file for automat | ||
24 | |||
25 | from setuptools import setup, find_packages | ||
26 | |||
27 | -try: | ||
28 | - from m2r import parse_from_file | ||
29 | - long_description = parse_from_file('README.md') | ||
30 | -except(IOError, ImportError): | ||
31 | - print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n") | ||
32 | - import io | ||
33 | - long_description = io.open('README.md', encoding="utf-8").read() | ||
34 | - | ||
35 | setup( | ||
36 | name='Automat', | ||
37 | use_scm_version=True, | ||
38 | @@ -19,12 +11,10 @@ setup( | ||
39 | description=""" | ||
40 | Self-service finite-state machines for the programmer on the go. | ||
41 | """.strip(), | ||
42 | - long_description=long_description, | ||
43 | packages=find_packages(exclude=[]), | ||
44 | package_dir={'automat': 'automat'}, | ||
45 | setup_requires=[ | ||
46 | 'setuptools-scm', | ||
47 | - 'm2r', | ||
48 | ], | ||
49 | install_requires=[ | ||
50 | "attrs>=19.2.0", | ||
51 | -- | ||
52 | 2.17.1 | ||
53 | |||
diff --git a/meta-python/recipes-devtools/python/python3-automat_20.2.0.bb b/meta-python/recipes-devtools/python/python3-automat_22.10.0.bb index dbba97e76..bb29fbd4a 100644 --- a/meta-python/recipes-devtools/python/python3-automat_20.2.0.bb +++ b/meta-python/recipes-devtools/python/python3-automat_22.10.0.bb | |||
@@ -3,15 +3,10 @@ HOMEPAGE = "https://github.com/glyph/Automat" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "d6cef9886b037b8857bfbc686f3ae30a" | 6 | SRC_URI[sha256sum] = "e56beb84edad19dcc11d30e8d9b895f75deeb5ef5e96b84a467066b3b84bb04e" |
7 | SRC_URI[sha256sum] = "7979803c74610e11ef0c0d68a2942b152df52da55336e0c9d58daf1831cbdf33" | ||
8 | 7 | ||
9 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | 8 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" |
10 | 9 | ||
11 | SRC_URI:append = " \ | ||
12 | file://0001-setup.py-remove-the-dependency-on-m2r.patch \ | ||
13 | " | ||
14 | |||
15 | PYPI_PACKAGE = "Automat" | 10 | PYPI_PACKAGE = "Automat" |
16 | inherit pypi setuptools3 | 11 | inherit pypi setuptools3 |
17 | 12 | ||