summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWindel Bouwman <windel.bouwman@gmail.com>2022-05-06 08:55:12 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-06 09:21:39 -0700
commitda8a50684ad87a7937bf9242c0bc831ad5b2f544 (patch)
treefa34e55e0d07a62d2cd68285fea2e9b1f351b6a5
parent0716b34c88e47458ef2d068474ddabfdca7fc779 (diff)
downloadmeta-openembedded-da8a50684ad87a7937bf9242c0bc831ad5b2f544.tar.gz
Add zfs recipe
Signed-off-by: Windel Bouwman <windel@windel.nl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb
new file mode 100644
index 000000000..072af7901
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb
@@ -0,0 +1,54 @@
1
2SUMMARY = "OpenZFS on Linux and FreeBSD"
3DESCRIPTION = "OpenZFS on Linux and FreeBSD"
4LICENSE = "CDDL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7087caaf1dc8a2856585619f4a787faa"
6HOMEPAGE ="https://github.com/openzfs/zfs"
7
8SRC_URI = "https://github.com/openzfs/zfs/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz"
9SRC_URI[sha256sum] = "3b52c0d493f806f638dca87dde809f53861cd318c1ebb0e60daeaa061cf1acf6"
10
11# Using both 'module' and 'autotools' classes seems a bit odd, they both
12# define a do_compile function.
13# That's why we opt for module-base, also this prevents module splitting.
14inherit module-base pkgconfig autotools
15
16DEPENDS = "virtual/kernel zlib util-linux libtirpc openssl curl"
17
18PACKAGECONFIG[pam] = "--enable-pam --with-pamconfigsdir=${datadir}/pam-configs --with-pammoduledir=${libdir}/security, --disable-pam"
19
20EXTRA_OECONF:append = " \
21 --disable-pyzfs \
22 --with-linux=${STAGING_KERNEL_DIR} --with-linux-obj=${STAGING_KERNEL_BUILDDIR} \
23 --with-mounthelperdir=${base_sbin} \
24 --with-udevdir=${base_libdir}/udev \
25 --enable-systemd \
26 --disable-sysvinit \
27 --without-dracutdir \
28 "
29
30EXTRA_OEMAKE:append = " \
31 INSTALL_MOD_PATH=${D}${root_prefix} \
32 "
33
34do_install:append() {
35 # /usr/share/zfs contains the zfs-tests folder which we do not need:
36 rm -rf ${D}${datadir}/zfs
37
38 rm -rf ${D}${datadir}/initramfs-tools
39}
40
41FILES:${PN} += "\
42 ${base_sbindir}/* \
43 ${base_libdir}/* \
44 ${sysconfdir}/* \
45 ${sbindir}/* \
46 ${bindir}/* \
47 ${libexecdir}/${BPN}/* \
48 ${libdir}/* \
49 "
50
51FILES:${PN}-dev += "\
52 ${prefix}/src/zfs-${PV}/* \
53 ${prefix}/src/spl-${PV}/* \
54 "