summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-06-23 15:48:32 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:24 +0200
commitd8e895ef7339cc94df2a57ee7f048efa9884e9cf (patch)
tree1f4dba46bf35ddb73797b7d28e293fdaaf017a22
parentb460ac6bcb1cf4ab59df56cd0f5c2c91111199b6 (diff)
downloadmeta-openembedded-d8e895ef7339cc94df2a57ee7f048efa9884e9cf.tar.gz
open-vm-tools: add new recipe
This recipe is modified from the recipe originally found in the Open-Switch repository: https://github.com/open-switch/ops-build yocto/openswitch/meta-foss-openswitch/recipes-extended/open-vm-tools/open-vm-tools_10.0.5.bb Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9 Although the original recipe packaging was Apache-licensed, I received permission from the author (Diego Dompe) to relicense it under the MIT license for inclusion in meta-openembedded: https://lists.openswitch.net/pipermail/ops-dev/2017-April/014715.html https://lists.openswitch.net/pipermail/ops-dev/2017-April/014716.html Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/open-vm-tools/files/tools.conf2
-rw-r--r--meta-oe/recipes-support/open-vm-tools/files/vmtoolsd.service11
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch35
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb75
4 files changed, 123 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/files/tools.conf b/meta-oe/recipes-support/open-vm-tools/files/tools.conf
new file mode 100644
index 000000000..f6cae70cc
--- /dev/null
+++ b/meta-oe/recipes-support/open-vm-tools/files/tools.conf
@@ -0,0 +1,2 @@
1[guestinfo]
2disable-perf-mon=1
diff --git a/meta-oe/recipes-support/open-vm-tools/files/vmtoolsd.service b/meta-oe/recipes-support/open-vm-tools/files/vmtoolsd.service
new file mode 100644
index 000000000..d30e38055
--- /dev/null
+++ b/meta-oe/recipes-support/open-vm-tools/files/vmtoolsd.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Open Virtual Machine Tools (VMware Tools)
3ConditionVirtualization=vmware
4
5[Service]
6ExecStart=/usr/bin/vmtoolsd
7Restart=on-failure
8KillSignal=SIGKILL
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch
new file mode 100644
index 000000000..63ea45324
--- /dev/null
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-kernel-detection.patch
@@ -0,0 +1,35 @@
1From 5d8814f4b4f016a633984822a6dfbc9426fef333 Mon Sep 17 00:00:00 2001
2From: Diego Dompe <dompe@hpe.com>
3Date: Thu, 7 Jan 2016 15:06:16 -0600
4Subject: [PATCH] Fix-kernel-detection
5
6Signed-off-by: Diego Dompe <dompe@hpe.com>
7---
8 configure.ac | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/configure.ac b/configure.ac
12index 04e3bac..1ab3f29 100644
13--- a/configure.ac
14+++ b/configure.ac
15@@ -151,7 +151,7 @@ if test "$with_kernel_modules" = "yes"; then
16 if test ! -d "$LINUXDIR/kernel/"; then
17 AC_MSG_ERROR([$LINUXDIR/kernel does not exist])
18 fi
19- LINUXINCLUDE="$LINUXDIR/build/include"
20+ LINUXINCLUDE="$LINUXDIR/include"
21 if test ! -d "$LINUXINCLUDE"; then
22 AC_MSG_ERROR([Can't find include dir under $LINUXDIR])
23 fi
24@@ -1034,7 +1034,7 @@ MODULES_DIR=""
25 buildHgfsmounter=no
26
27 if test "$os" = "linux"; then
28- MODULES_DIR="$LINUXDIR/kernel/"
29+ MODULES_DIR="/lib/modules/$KERNEL_RELEASE"
30
31 CPPFLAGS="$CPPFLAGS -D_FILE_OFFSET_BITS=64"
32 CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
33--
341.9.1
35
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
new file mode 100644
index 000000000..4dee03a23
--- /dev/null
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
@@ -0,0 +1,75 @@
1# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12DECRIPTION = "open-vm-tools"
13SECTION = "vmware-tools"
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5804fe91d3294da4ac47c02b454bbc8a"
16
17PR = "r5"
18
19SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
20 file://tools.conf \
21 file://vmtoolsd.service \
22 file://0001-Fix-kernel-detection.patch \
23 "
24
25SRCREV = "538ea037a1549b6fd4e57529f7448a3fd2aa47af"
26
27S = "${WORKDIR}/git/open-vm-tools"
28
29DEPENDS = "virtual/kernel glib-2.0 util-linux libdnet procps libmspack"
30RDEPENDS_${PN} = "util-linux libdnet kernel-module-vmhgfs"
31
32inherit module-base kernel-module-split autotools systemd
33
34# from module.bbclass...
35addtask make_scripts after do_patch before do_compile
36do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
37do_make_scripts[depends] = "virtual/kernel:do_shared_workdir"
38# add all splitted modules to PN RDEPENDS, PN can be empty now
39KERNEL_MODULES_META_PACKAGE = "${PN}"
40
41SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
42
43EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs --disable-tests \
44 --without-gtk2 --without-gtkmm --without-xerces --without-pam \
45 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
46 --with-linuxdir=${STAGING_KERNEL_DIR} --with-kernel-release=${KERNEL_VERSION} --without-root-privileges"
47
48EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'x11', '', '--without-x', d)}"
49
50EXTRA_OEMAKE = "KERNEL_RELEASE=${KERNEL_VERSION}"
51
52
53CFLAGS += '-Wno-error=deprecated-declarations'
54
55FILES_${PN} += "/usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \
56 /usr/lib/open-vm-tools/plugins/common/lib*.so \
57 ${sysconfdir}/vmware-tools/tools.conf"
58FILES_${PN}-locale += "/usr/share/open-vm-tools/messages"
59FILES_${PN}-dev += "/usr/lib/open-vm-tools/plugins/common/lib*.la"
60FILES_${PN}-dbg += "/usr/lib/open-vm-tools/plugins/common/.debug \
61 /usr/lib/open-vm-tools/plugins/vmsvc/.debug"
62
63CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
64
65do_install_append() {
66 ln -sf /usr/sbin/mount.vmhgfs ${D}/sbin/mount.vmhgfs
67 install -d ${D}${systemd_unitdir}/system ${D}${sysconfdir}/vmware-tools
68 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
69 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
70}
71
72do_configure_prepend() {
73 export CUSTOM_PROCPS_NAME=procps
74 export CUSTOM_PROCPS_LIBS=-L${STAGING_LIBDIR}/libprocps.so
75}