summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-09 23:01:26 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-09 23:01:26 -0700
commitd5ed5b9ccf539d9ff850ea2b884e964900fae8fb (patch)
tree26694e597306addadfa880e9d3441d2dcd980c50
parent77922f115a5dba3c16cce45c95e0fac318a3b8c6 (diff)
downloadmeta-openembedded-d5ed5b9ccf539d9ff850ea2b884e964900fae8fb.tar.gz
opencv: Fix build on big-endian systems
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch36
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.4.3.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch b/meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch
new file mode 100644
index 000000000..513597b8c
--- /dev/null
+++ b/meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch
@@ -0,0 +1,36 @@
1From 60857229aab13ccc426572a43ab891409bb76ea4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 9 Sep 2018 22:52:55 -0700
4Subject: [PATCH] Add missing multi-line separator
5
6Otherwise this fails to build ( found on mips )
7
8Fixes
9contrib/modules/surface_matching/src/hash_murmur86.hpp:97:15: error:
10expected constructor, destructor, or type conversion before '(' token
11 && defined(__GNUC__) && (__GNUC__>4 || (__GNUC__==4 &&
12__GNUC_MINOR__>=3))
13 ^
14
15Upstream-Status: Submitted [https://github.com/opencv/opencv_contrib/pull/1764]
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 modules/surface_matching/src/hash_murmur86.hpp | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/modules/surface_matching/src/hash_murmur86.hpp b/modules/surface_matching/src/hash_murmur86.hpp
22index 1edf6bf4..0477d37e 100644
23--- a/modules/surface_matching/src/hash_murmur86.hpp
24+++ b/modules/surface_matching/src/hash_murmur86.hpp
25@@ -93,7 +93,7 @@ void hashMurmurx86 ( const void * key, const int len, const uint seed, void * ou
26 /* Now find best way we can to READ_UINT32 */
27 #ifndef WORDS_BIGENDIAN
28 # define READ_UINT32(ptr) (*((uint32_t*)(ptr)))
29-#elif defined(WORDS_BIGENDIAN)
30+#elif defined(WORDS_BIGENDIAN) \
31 && defined(__GNUC__) && (__GNUC__>4 || (__GNUC__==4 && __GNUC_MINOR__>=3))
32 # define READ_UINT32(ptr) (__builtin_bswap32(*((uint32_t*)(ptr))))
33 #endif
34--
352.18.0
36
diff --git a/meta-oe/recipes-support/opencv/opencv_3.4.3.bb b/meta-oe/recipes-support/opencv/opencv_3.4.3.bb
index 5591481b7..403146e7c 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.4.3.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.4.3.bb
@@ -46,6 +46,7 @@ SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \
46 https://github.com/tiny-dnn/tiny-dnn/archive/v1.0.0a3.tar.gz;destsuffix=git/3rdparty/tinydnn/tiny-dnn-1.0.0a3;name=tinydnn;unpack=false \ 46 https://github.com/tiny-dnn/tiny-dnn/archive/v1.0.0a3.tar.gz;destsuffix=git/3rdparty/tinydnn/tiny-dnn-1.0.0a3;name=tinydnn;unpack=false \
47 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \ 47 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
48 file://uselocalxfeatures.patch;patchdir=../contrib/ \ 48 file://uselocalxfeatures.patch;patchdir=../contrib/ \
49 file://0001-Add-missing-multi-line-separator.patch;patchdir=../contrib/ \
49 file://0002-Make-opencv-ts-create-share-library-intead-of-static.patch \ 50 file://0002-Make-opencv-ts-create-share-library-intead-of-static.patch \
50 file://0003-To-fix-errors-as-following.patch \ 51 file://0003-To-fix-errors-as-following.patch \
51 file://fixpkgconfig.patch \ 52 file://fixpkgconfig.patch \