summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-11 20:41:40 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-14 07:15:36 -0700
commitd5b6841bf8c7623ae8d7b0031c2de711b04cdc08 (patch)
tree8d3e6ca4efe9199cf4e65e8cc509a8c71d27f592
parent539a6d36f166288fdd26fb7278547f05e7fe70e5 (diff)
downloadmeta-openembedded-d5b6841bf8c7623ae8d7b0031c2de711b04cdc08.tar.gz
python3-m2crypto: address build failure with openssl 3.x
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch28
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb5
2 files changed, 31 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch
new file mode 100644
index 000000000..c67e50803
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-address-openssl-3.x-build-issue.patch
@@ -0,0 +1,28 @@
1From 0d824e5c2ab13e761ffaeabdccf9513d5b8f280d Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex@linutronix.de>
3Date: Fri, 8 Oct 2021 11:18:35 +0200
4Subject: [PATCH] setup.py: address openssl 3.x build issue
5
6swig throws:
7| /home/alex/development/poky/build-metaoe/tmp/work/x86_64-linux/python3-m2crypto-native/0.38.0-r0/recipe-sysroot-native/usr/include/openssl/macros.h:155: Error: CPP #error ""OPENSSL_API_COMPAT expresses an impossible API compatibility level"". Use the -cpperraswarn option to continue swig processing.
8
9I'm not sure why; upstream should take a look.
10
11Upstream-Status: Inappropriate [workaround]
12Signed-off-by: Alexander Kanavin <alex@linutronix.de>
13---
14 setup.py | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/setup.py b/setup.py
18index 2c65404..74704bc 100644
19--- a/setup.py
20+++ b/setup.py
21@@ -192,6 +192,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
22
23 self.swig_opts.append('-includeall')
24 self.swig_opts.append('-modern')
25+ self.swig_opts.append('-cpperraswarn')
26 self.swig_opts.append('-builtin')
27
28 # These two lines are a workaround for
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb b/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb
index e1ee99bae..51a0dd676 100644
--- a/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb
+++ b/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb
@@ -7,8 +7,9 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
7FILESEXTRAPATHS:prepend := "${THISDIR}/python-m2crypto:" 7FILESEXTRAPATHS:prepend := "${THISDIR}/python-m2crypto:"
8 8
9SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \ 9SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
10 file://cross-compile-platform.patch \ 10 file://cross-compile-platform.patch \
11 file://avoid-host-contamination.patch \ 11 file://avoid-host-contamination.patch \
12 file://0001-setup.py-address-openssl-3.x-build-issue.patch \
12 " 13 "
13SRC_URI[sha256sum] = "99f2260a30901c949a8dc6d5f82cd5312ffb8abc92e76633baf231bbbcb2decb" 14SRC_URI[sha256sum] = "99f2260a30901c949a8dc6d5f82cd5312ffb8abc92e76633baf231bbbcb2decb"
14 15