diff options
author | Dmitry Baryshkov <dmitry.baryshkov@linaro.org> | 2025-02-11 06:31:25 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-02-12 09:16:08 -0800 |
commit | d54a6102d81d5d662cb806d8411228969d392709 (patch) | |
tree | cefca4727ffe6215c760c4aa3919d22a681ff018 | |
parent | 40682626c3b391781b2bd54f862bf903eaa985db (diff) | |
download | meta-openembedded-d54a6102d81d5d662cb806d8411228969d392709.tar.gz |
android-tools: build without gold
The android-tools recipe has been using gold linker to create
executables. Recently OE-Core has dropped support for the gold linker,
which is now causing build errors for the android-tools recipe. Update
the build-system patch in order to stop using gold for linking.
Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools/0002-android-tools-modifications-to-make-it-build-in-yoct.patch | 13 |
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools/0002-android-tools-modifications-to-make-it-build-in-yoct.patch b/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools/0002-android-tools-modifications-to-make-it-build-in-yoct.patch index 5ce375134c..a35428b5b4 100644 --- a/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools/0002-android-tools-modifications-to-make-it-build-in-yoct.patch +++ b/meta-oe/dynamic-layers/selinux/recipes-devtool/android-tools/android-tools/0002-android-tools-modifications-to-make-it-build-in-yoct.patch | |||
@@ -89,6 +89,14 @@ index 9769b68ab793..58c9a63bd225 100644 | |||
89 | -Iexternal/boringssl/include \ | 89 | -Iexternal/boringssl/include \ |
90 | -Isystem/core/adb \ | 90 | -Isystem/core/adb \ |
91 | -Isystem/core/base/include \ | 91 | -Isystem/core/base/include \ |
92 | @@ -28,7 +27,6 @@ CPPFLAGS += \ | ||
93 | LDFLAGS += \ | ||
94 | -Ldebian/out/system/core \ | ||
95 | -Wl,-rpath=/usr/lib/$(DEB_HOST_MULTIARCH)/android \ | ||
96 | - -fuse-ld=gold \ | ||
97 | -lbase \ | ||
98 | -lcutils \ | ||
99 | -lpthread \ | ||
92 | diff --git a/debian/system/core/append2simg.mk b/debian/system/core/append2simg.mk | 100 | diff --git a/debian/system/core/append2simg.mk b/debian/system/core/append2simg.mk |
93 | index 1599bdb8..598c751d 100644 | 101 | index 1599bdb8..598c751d 100644 |
94 | --- a/debian/system/core/append2simg.mk | 102 | --- a/debian/system/core/append2simg.mk |
@@ -114,15 +122,16 @@ index d5c9a285..a59ba1a4 100644 | |||
114 | -Iexternal/boringssl/include \ | 122 | -Iexternal/boringssl/include \ |
115 | -Iexternal/avb \ | 123 | -Iexternal/avb \ |
116 | -Isystem/core/adb \ | 124 | -Isystem/core/adb \ |
117 | @@ -49,7 +49,7 @@ CPPFLAGS += \ | 125 | @@ -49,8 +48,7 @@ CPPFLAGS += \ |
118 | 126 | ||
119 | LDFLAGS += \ | 127 | LDFLAGS += \ |
120 | -Ldebian/out/system/core \ | 128 | -Ldebian/out/system/core \ |
121 | - -Wl,-rpath=/usr/lib/$(DEB_HOST_MULTIARCH)/android \ | 129 | - -Wl,-rpath=/usr/lib/$(DEB_HOST_MULTIARCH)/android \ |
130 | - -fuse-ld=gold \ | ||
122 | + -Wl,-rpath='$$ORIGIN/../lib/android' \ | 131 | + -Wl,-rpath='$$ORIGIN/../lib/android' \ |
123 | -fuse-ld=gold \ | ||
124 | -lbase \ | 132 | -lbase \ |
125 | -lcutils \ | 133 | -lcutils \ |
134 | -lpthread \ | ||
126 | diff --git a/debian/system/core/img2simg.mk b/debian/system/core/img2simg.mk | 135 | diff --git a/debian/system/core/img2simg.mk b/debian/system/core/img2simg.mk |
127 | index 11adf014..8baf5ba5 100644 | 136 | index 11adf014..8baf5ba5 100644 |
128 | --- a/debian/system/core/img2simg.mk | 137 | --- a/debian/system/core/img2simg.mk |