diff options
author | Denis OSTERLAND-HEIM <denis.osterland@diehl.com> | 2025-04-03 15:28:44 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-04-04 19:18:47 -0700 |
commit | d51084073d2441ed3ce2d2352af8c3d1f10693db (patch) | |
tree | 71f856c609d4d0edf40725cfdcba91c94e657c60 | |
parent | 9e57cd65cc548894266579ad2a8597a573af21f5 (diff) | |
download | meta-openembedded-d51084073d2441ed3ce2d2352af8c3d1f10693db.tar.gz |
libftdi: cpp-wrapper fix cmake support
Backport fix for C++ wrapper cmake support.
Signed-off-by: Denis Osterland-Heim <denis.osterland@diehl.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/libftdi/files/CMakeLists-txt-fix-paths-when-FTDIPP-is-set.patch | 45 | ||||
-rw-r--r-- | meta-oe/recipes-support/libftdi/libftdi_1.5.bb | 5 |
2 files changed, 49 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libftdi/files/CMakeLists-txt-fix-paths-when-FTDIPP-is-set.patch b/meta-oe/recipes-support/libftdi/files/CMakeLists-txt-fix-paths-when-FTDIPP-is-set.patch new file mode 100644 index 0000000000..b2735f8059 --- /dev/null +++ b/meta-oe/recipes-support/libftdi/files/CMakeLists-txt-fix-paths-when-FTDIPP-is-set.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From cdb28383402d248dbc6062f4391b038375c52385 Mon Sep 17 00:00:00 2001 | ||
2 | From: Fabrice Fontaine <fontaine.fabrice@gmail.com> | ||
3 | Date: Fri, 17 Jul 2020 21:25:03 +0200 | ||
4 | Subject: [PATCH] CMakeLists.txt: fix paths when FTDIPP is set | ||
5 | |||
6 | Use the same project name (i.e. libftdi1 and not libftdipp1) when FTDIPP | ||
7 | is enabled as suggested by Aurelien Jarno in | ||
8 | http://developer.intra2net.com/mailarchive/html/libftdi/2020/msg00044.html | ||
9 | |||
10 | Without this change, the libftdi1.pc config file defines the include | ||
11 | path as /usr/local/include/libftdipp1 while the ftdi.h file is actually | ||
12 | installed in /usr/local/include/libftdi1 | ||
13 | |||
14 | This is an issue for example for libsigrok which will fail on: | ||
15 | |||
16 | In file included from src/hardware/asix-sigma/protocol.c:27: | ||
17 | src/hardware/asix-sigma/protocol.h:28:10: fatal error: ftdi.h: No such file or directory | ||
18 | 28 | #include <ftdi.h> | ||
19 | | ^~~~~~~~ | ||
20 | |||
21 | Fixes: | ||
22 | - http://autobuild.buildroot.org/results/1427f44e36752c337791597fab47a1889552a2fe | ||
23 | |||
24 | Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> | ||
25 | Upstream-Status: Backport [http://developer.intra2net.com/git/?p=libftdi;a=patch;h=cdb28383402d248dbc6062f4391b038375c52385] | ||
26 | --- | ||
27 | CMakeLists.txt | 2 +- | ||
28 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
29 | |||
30 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
31 | index 5aecafc..3b0b87c 100644 | ||
32 | --- a/CMakeLists.txt | ||
33 | +++ b/CMakeLists.txt | ||
34 | @@ -136,7 +136,7 @@ endif () | ||
35 | |||
36 | add_subdirectory(src) | ||
37 | if ( FTDIPP ) | ||
38 | - project(libftdipp1 C CXX) | ||
39 | + project(libftdi1 C CXX) | ||
40 | add_subdirectory(ftdipp) | ||
41 | endif () | ||
42 | if ( PYTHON_BINDINGS ) | ||
43 | -- | ||
44 | 1.7.1 | ||
45 | |||
diff --git a/meta-oe/recipes-support/libftdi/libftdi_1.5.bb b/meta-oe/recipes-support/libftdi/libftdi_1.5.bb index 0284ad7e22..1679f212b3 100644 --- a/meta-oe/recipes-support/libftdi/libftdi_1.5.bb +++ b/meta-oe/recipes-support/libftdi/libftdi_1.5.bb | |||
@@ -11,7 +11,10 @@ LIC_FILES_CHKSUM = "\ | |||
11 | 11 | ||
12 | DEPENDS = "libusb1 python3 swig-native" | 12 | DEPENDS = "libusb1 python3 swig-native" |
13 | 13 | ||
14 | SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2" | 14 | SRC_URI = "\ |
15 | http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2 \ | ||
16 | file://CMakeLists-txt-fix-paths-when-FTDIPP-is-set.patch \ | ||
17 | " | ||
15 | SRC_URI[sha256sum] = "7c7091e9c86196148bd41177b4590dccb1510bfe6cea5bf7407ff194482eb049" | 18 | SRC_URI[sha256sum] = "7c7091e9c86196148bd41177b4590dccb1510bfe6cea5bf7407ff194482eb049" |
16 | 19 | ||
17 | UPSTREAM_CHECK_URI = "http://www.intra2net.com/en/developer/libftdi/download.php" | 20 | UPSTREAM_CHECK_URI = "http://www.intra2net.com/en/developer/libftdi/download.php" |