summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlater, Joseph <joe.slater@windriver.com>2020-07-21 15:00:55 -0700
committerKhem Raj <raj.khem@gmail.com>2020-07-21 16:46:37 -0700
commitd4c6f65de79211310380704df63f0c9a18fb9d48 (patch)
tree1f7a4b1d4fc43d175dd4c07953879d5fb3fad33e
parent75ec95b17c048d99f7d8e64e42ad82b6074f39cd (diff)
downloadmeta-openembedded-d4c6f65de79211310380704df63f0c9a18fb9d48.tar.gz
toybox-inittab: unpack to S
toybox-inittab does not unpack source files into S, so the archiver cannot see them. We copy them to a sub-directory in order to keep the originals available if running do_configure() (again) without first running do_unpack(). Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
index 9af1e3f14..f82f8e9ce 100644
--- a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
+++ b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
@@ -2,10 +2,12 @@ SUMMARY = "Toybox Inittab Configuration"
2LICENSE = "BSD-0-Clause" 2LICENSE = "BSD-0-Clause"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-0-Clause;md5=81eeb0083e31f11ab1e33ded846d521c" 3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-0-Clause;md5=81eeb0083e31f11ab1e33ded846d521c"
4 4
5# Unpack to ${S}/orig
6#
5SRC_URI = "\ 7SRC_URI = "\
6 file://inittab \ 8 file://inittab;subdir=${BP}/orig \
7 file://rcK \ 9 file://rcK;subdir=${BP}/orig \
8 file://rcS \ 10 file://rcS;subdir=${BP}/orig \
9" 11"
10 12
11PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -15,6 +17,9 @@ RCONFLICTS_${PN} = "\
15 sysvinit-inittab \ 17 sysvinit-inittab \
16" 18"
17 19
20# Just being sure.
21B = "${S}"
22
18# most users may want to have getty enabled by default 23# most users may want to have getty enabled by default
19PACKAGECONFIG ??= "getty" 24PACKAGECONFIG ??= "getty"
20 25
@@ -26,9 +31,7 @@ do_patch[noexec] = "1"
26 31
27do_configure() { 32do_configure() {
28 # copy over files now to have a fresh start on each config 33 # copy over files now to have a fresh start on each config
29 for f in inittab rcK rcS; do 34 cp orig/* .
30 cp ${WORKDIR}/$f ${S}
31 done
32 35
33 for config in ${PACKAGECONFIG_CONFARGS}; do 36 for config in ${PACKAGECONFIG_CONFARGS}; do
34 if [[ ${config} == "enable_getty" ]]; then 37 if [[ ${config} == "enable_getty" ]]; then