diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-11-04 13:40:34 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-11-06 08:47:48 -0800 |
commit | d422b857eebb3ca16f8bfcf6f1f14f077d1ed119 (patch) | |
tree | ad283985942a1b0893a09c87c4b9af388d7100d9 | |
parent | 5f54314bb816a5b74d3af214e394eda856755496 (diff) | |
download | meta-openembedded-d422b857eebb3ca16f8bfcf6f1f14f077d1ed119.tar.gz |
python3-greenlet: upgrade 2.0.2 -> 3.0.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch | 247 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-greenlet_3.0.1.bb (renamed from meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb) | 4 |
2 files changed, 2 insertions, 249 deletions
diff --git a/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch b/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch deleted file mode 100644 index 2a6ddd4726..0000000000 --- a/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch +++ /dev/null | |||
@@ -1,247 +0,0 @@ | |||
1 | From 74d8c5ecdc677a7a412c7f782fe8488a5d987333 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 5 Feb 2023 19:05:45 -0800 | ||
4 | Subject: [PATCH] cleanup: Drop using 'register' storage class keyword everywhere | ||
5 | |||
6 | This has been dropped in c++17 and newer | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/python-greenlet/greenlet/pull/347] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/greenlet/platform/switch_alpha_unix.h | 4 ++-- | ||
12 | src/greenlet/platform/switch_arm32_gcc.h | 2 +- | ||
13 | src/greenlet/platform/switch_arm32_ios.h | 2 +- | ||
14 | src/greenlet/platform/switch_csky_gcc.h | 2 +- | ||
15 | src/greenlet/platform/switch_mips_unix.h | 4 ++-- | ||
16 | src/greenlet/platform/switch_ppc64_aix.h | 4 ++-- | ||
17 | src/greenlet/platform/switch_ppc64_linux.h | 4 ++-- | ||
18 | src/greenlet/platform/switch_ppc_aix.h | 4 ++-- | ||
19 | src/greenlet/platform/switch_ppc_linux.h | 4 ++-- | ||
20 | src/greenlet/platform/switch_ppc_macosx.h | 4 ++-- | ||
21 | src/greenlet/platform/switch_ppc_unix.h | 4 ++-- | ||
22 | src/greenlet/platform/switch_s390_unix.h | 4 ++-- | ||
23 | src/greenlet/platform/switch_sparc_sun_gcc.h | 4 ++-- | ||
24 | src/greenlet/platform/switch_x32_unix.h | 4 ++-- | ||
25 | src/greenlet/platform/switch_x86_unix.h | 2 +- | ||
26 | 15 files changed, 26 insertions(+), 26 deletions(-) | ||
27 | |||
28 | diff --git a/src/greenlet/platform/switch_alpha_unix.h b/src/greenlet/platform/switch_alpha_unix.h | ||
29 | index 216619f..7e07abf 100644 | ||
30 | --- a/src/greenlet/platform/switch_alpha_unix.h | ||
31 | +++ b/src/greenlet/platform/switch_alpha_unix.h | ||
32 | @@ -9,8 +9,8 @@ | ||
33 | static int | ||
34 | slp_switch(void) | ||
35 | { | ||
36 | - register int ret; | ||
37 | - register long *stackref, stsizediff; | ||
38 | + int ret; | ||
39 | + long *stackref, stsizediff; | ||
40 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
41 | __asm__ volatile ("mov $30, %0" : "=r" (stackref) : ); | ||
42 | { | ||
43 | diff --git a/src/greenlet/platform/switch_arm32_gcc.h b/src/greenlet/platform/switch_arm32_gcc.h | ||
44 | index 035d6b9..655003a 100644 | ||
45 | --- a/src/greenlet/platform/switch_arm32_gcc.h | ||
46 | +++ b/src/greenlet/platform/switch_arm32_gcc.h | ||
47 | @@ -56,7 +56,7 @@ __attribute__((optimize("no-omit-frame-pointer"))) | ||
48 | slp_switch(void) | ||
49 | { | ||
50 | void *fp; | ||
51 | - register int *stackref, stsizediff; | ||
52 | + int *stackref, stsizediff; | ||
53 | int result; | ||
54 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
55 | __asm__ volatile ("mov r0," REG_FP "\n\tstr r0,%0" : "=m" (fp) : : "r0"); | ||
56 | diff --git a/src/greenlet/platform/switch_arm32_ios.h b/src/greenlet/platform/switch_arm32_ios.h | ||
57 | index e993707..9e640e1 100644 | ||
58 | --- a/src/greenlet/platform/switch_arm32_ios.h | ||
59 | +++ b/src/greenlet/platform/switch_arm32_ios.h | ||
60 | @@ -38,7 +38,7 @@ __attribute__((optimize("no-omit-frame-pointer"))) | ||
61 | slp_switch(void) | ||
62 | { | ||
63 | void *fp; | ||
64 | - register int *stackref, stsizediff, result; | ||
65 | + int *stackref, stsizediff, result; | ||
66 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
67 | __asm__ volatile ("str " REG_FP ",%0" : "=m" (fp)); | ||
68 | __asm__ ("mov %0," REG_SP : "=r" (stackref)); | ||
69 | diff --git a/src/greenlet/platform/switch_csky_gcc.h b/src/greenlet/platform/switch_csky_gcc.h | ||
70 | index 7486b94..ac469d3 100644 | ||
71 | --- a/src/greenlet/platform/switch_csky_gcc.h | ||
72 | +++ b/src/greenlet/platform/switch_csky_gcc.h | ||
73 | @@ -23,7 +23,7 @@ __attribute__((optimize("no-omit-frame-pointer"))) | ||
74 | #endif | ||
75 | slp_switch(void) | ||
76 | { | ||
77 | - register int *stackref, stsizediff; | ||
78 | + int *stackref, stsizediff; | ||
79 | int result; | ||
80 | |||
81 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
82 | diff --git a/src/greenlet/platform/switch_mips_unix.h b/src/greenlet/platform/switch_mips_unix.h | ||
83 | index 1916b26..b9003e9 100644 | ||
84 | --- a/src/greenlet/platform/switch_mips_unix.h | ||
85 | +++ b/src/greenlet/platform/switch_mips_unix.h | ||
86 | @@ -19,8 +19,8 @@ | ||
87 | static int | ||
88 | slp_switch(void) | ||
89 | { | ||
90 | - register int err; | ||
91 | - register int *stackref, stsizediff; | ||
92 | + int err; | ||
93 | + int *stackref, stsizediff; | ||
94 | #ifdef __mips64 | ||
95 | uint64_t gpsave; | ||
96 | #endif | ||
97 | diff --git a/src/greenlet/platform/switch_ppc64_aix.h b/src/greenlet/platform/switch_ppc64_aix.h | ||
98 | index e07b8de..e7e0b87 100644 | ||
99 | --- a/src/greenlet/platform/switch_ppc64_aix.h | ||
100 | +++ b/src/greenlet/platform/switch_ppc64_aix.h | ||
101 | @@ -74,8 +74,8 @@ | ||
102 | static int | ||
103 | slp_switch(void) | ||
104 | { | ||
105 | - register int err; | ||
106 | - register long *stackref, stsizediff; | ||
107 | + int err; | ||
108 | + long *stackref, stsizediff; | ||
109 | void * toc; | ||
110 | void * r30; | ||
111 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
112 | diff --git a/src/greenlet/platform/switch_ppc64_linux.h b/src/greenlet/platform/switch_ppc64_linux.h | ||
113 | index 88e6847..3c324d0 100644 | ||
114 | --- a/src/greenlet/platform/switch_ppc64_linux.h | ||
115 | +++ b/src/greenlet/platform/switch_ppc64_linux.h | ||
116 | @@ -76,8 +76,8 @@ | ||
117 | static int | ||
118 | slp_switch(void) | ||
119 | { | ||
120 | - register int err; | ||
121 | - register long *stackref, stsizediff; | ||
122 | + int err; | ||
123 | + long *stackref, stsizediff; | ||
124 | void * toc; | ||
125 | void * r30; | ||
126 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
127 | diff --git a/src/greenlet/platform/switch_ppc_aix.h b/src/greenlet/platform/switch_ppc_aix.h | ||
128 | index c7d476f..6d93c13 100644 | ||
129 | --- a/src/greenlet/platform/switch_ppc_aix.h | ||
130 | +++ b/src/greenlet/platform/switch_ppc_aix.h | ||
131 | @@ -53,8 +53,8 @@ | ||
132 | static int | ||
133 | slp_switch(void) | ||
134 | { | ||
135 | - register int err; | ||
136 | - register int *stackref, stsizediff; | ||
137 | + int err; | ||
138 | + int *stackref, stsizediff; | ||
139 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
140 | __asm__ ("mr %0, 1" : "=r" (stackref) : ); | ||
141 | { | ||
142 | diff --git a/src/greenlet/platform/switch_ppc_linux.h b/src/greenlet/platform/switch_ppc_linux.h | ||
143 | index 0a71255..e83ad70 100644 | ||
144 | --- a/src/greenlet/platform/switch_ppc_linux.h | ||
145 | +++ b/src/greenlet/platform/switch_ppc_linux.h | ||
146 | @@ -49,8 +49,8 @@ | ||
147 | static int | ||
148 | slp_switch(void) | ||
149 | { | ||
150 | - register int err; | ||
151 | - register int *stackref, stsizediff; | ||
152 | + int err; | ||
153 | + int *stackref, stsizediff; | ||
154 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
155 | __asm__ ("mr %0, 1" : "=r" (stackref) : ); | ||
156 | { | ||
157 | diff --git a/src/greenlet/platform/switch_ppc_macosx.h b/src/greenlet/platform/switch_ppc_macosx.h | ||
158 | index 56e573f..d6e5a03 100644 | ||
159 | --- a/src/greenlet/platform/switch_ppc_macosx.h | ||
160 | +++ b/src/greenlet/platform/switch_ppc_macosx.h | ||
161 | @@ -46,8 +46,8 @@ | ||
162 | static int | ||
163 | slp_switch(void) | ||
164 | { | ||
165 | - register int err; | ||
166 | - register int *stackref, stsizediff; | ||
167 | + int err; | ||
168 | + int *stackref, stsizediff; | ||
169 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
170 | __asm__ ("; asm block 2\n\tmr %0, r1" : "=g" (stackref) : ); | ||
171 | { | ||
172 | diff --git a/src/greenlet/platform/switch_ppc_unix.h b/src/greenlet/platform/switch_ppc_unix.h | ||
173 | index 2b3d307..ca590a5 100644 | ||
174 | --- a/src/greenlet/platform/switch_ppc_unix.h | ||
175 | +++ b/src/greenlet/platform/switch_ppc_unix.h | ||
176 | @@ -47,8 +47,8 @@ | ||
177 | static int | ||
178 | slp_switch(void) | ||
179 | { | ||
180 | - register int err; | ||
181 | - register int *stackref, stsizediff; | ||
182 | + int err; | ||
183 | + int *stackref, stsizediff; | ||
184 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
185 | __asm__ ("mr %0, 1" : "=g" (stackref) : ); | ||
186 | { | ||
187 | diff --git a/src/greenlet/platform/switch_s390_unix.h b/src/greenlet/platform/switch_s390_unix.h | ||
188 | index 6641854..9199367 100644 | ||
189 | --- a/src/greenlet/platform/switch_s390_unix.h | ||
190 | +++ b/src/greenlet/platform/switch_s390_unix.h | ||
191 | @@ -36,8 +36,8 @@ | ||
192 | static int | ||
193 | slp_switch(void) | ||
194 | { | ||
195 | - register int ret; | ||
196 | - register long *stackref, stsizediff; | ||
197 | + int ret; | ||
198 | + long *stackref, stsizediff; | ||
199 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
200 | #ifdef __s390x__ | ||
201 | __asm__ volatile ("lgr %0, 15" : "=r" (stackref) : ); | ||
202 | diff --git a/src/greenlet/platform/switch_sparc_sun_gcc.h b/src/greenlet/platform/switch_sparc_sun_gcc.h | ||
203 | index 652b57f..96990c3 100644 | ||
204 | --- a/src/greenlet/platform/switch_sparc_sun_gcc.h | ||
205 | +++ b/src/greenlet/platform/switch_sparc_sun_gcc.h | ||
206 | @@ -51,8 +51,8 @@ | ||
207 | static int | ||
208 | slp_switch(void) | ||
209 | { | ||
210 | - register int err; | ||
211 | - register int *stackref, stsizediff; | ||
212 | + int err; | ||
213 | + int *stackref, stsizediff; | ||
214 | |||
215 | /* Put current stack pointer into stackref. | ||
216 | * Register spilling is done in save/restore. | ||
217 | diff --git a/src/greenlet/platform/switch_x32_unix.h b/src/greenlet/platform/switch_x32_unix.h | ||
218 | index cb14ec1..893369c 100644 | ||
219 | --- a/src/greenlet/platform/switch_x32_unix.h | ||
220 | +++ b/src/greenlet/platform/switch_x32_unix.h | ||
221 | @@ -22,8 +22,8 @@ slp_switch(void) | ||
222 | void* ebx; | ||
223 | unsigned int csr; | ||
224 | unsigned short cw; | ||
225 | - register int err; | ||
226 | - register int *stackref, stsizediff; | ||
227 | + int err; | ||
228 | + int *stackref, stsizediff; | ||
229 | __asm__ volatile ("" : : : REGS_TO_SAVE); | ||
230 | __asm__ volatile ("fstcw %0" : "=m" (cw)); | ||
231 | __asm__ volatile ("stmxcsr %0" : "=m" (csr)); | ||
232 | diff --git a/src/greenlet/platform/switch_x86_unix.h b/src/greenlet/platform/switch_x86_unix.h | ||
233 | index 3a95186..493fa6b 100644 | ||
234 | --- a/src/greenlet/platform/switch_x86_unix.h | ||
235 | +++ b/src/greenlet/platform/switch_x86_unix.h | ||
236 | @@ -51,7 +51,7 @@ slp_switch(void) | ||
237 | #endif | ||
238 | void *ebp, *ebx; | ||
239 | unsigned short cw; | ||
240 | - register int *stackref, stsizediff; | ||
241 | + int *stackref, stsizediff; | ||
242 | __asm__ volatile ("" : : : "esi", "edi"); | ||
243 | __asm__ volatile ("fstcw %0" : "=m" (cw)); | ||
244 | __asm__ volatile ("movl %%ebp, %0" : "=m" (ebp)); | ||
245 | -- | ||
246 | 2.39.1 | ||
247 | |||
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb b/meta-python/recipes-devtools/python/python3-greenlet_3.0.1.bb index a2e036a891..fbabf12a38 100644 --- a/meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb +++ b/meta-python/recipes-devtools/python/python3-greenlet_3.0.1.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "MIT & PSF-2.0" | |||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \ | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \ |
5 | file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a" | 5 | file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a" |
6 | 6 | ||
7 | SRC_URI += "file://0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch" | 7 | SRC_URI += "${PYPI_SRC_URI}" |
8 | SRC_URI[sha256sum] = "e7c8dc13af7db097bed64a051d2dd49e9f0af495c26995c00a9ee842690d34c0" | 8 | SRC_URI[sha256sum] = "816bd9488a94cba78d93e1abb58000e8266fa9cc2aa9ccdd6eb0696acb24005b" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 |