summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-15 21:19:59 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-15 21:01:20 -0700
commitd3a16ad4aec3f496484295bbdb1f3d661911e69b (patch)
treecea9caac7daf724c9db9d143ecaf9b1e31337cfd
parentfd208c871429fdd331ecc3bf3b59e975e680b7ff (diff)
downloadmeta-openembedded-d3a16ad4aec3f496484295bbdb1f3d661911e69b.tar.gz
Use PYTHON_SITEPACKAGES_DIR instead of hard-coded site-packages directory path
The following paths have been replaced with PYTHON_SITEPACKAGES_DIR: - "${libdir}/${PYTHON_DIR}/site-packages" - "${libdir}/python${PYTHON_BASEVERSION}/site-packages" - "${libdir}/python*/site-packages" - "${libdir}/python3.*/site-packages" Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.1.bb4
-rw-r--r--meta-networking/recipes-support/libldb/libldb_2.8.0.bb4
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb2
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb2
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.16.0.bb2
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb2
-rw-r--r--meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb4
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb2
-rw-r--r--meta-oe/recipes-extended/libimobiledevice/libplist_2.3.0.bb6
-rw-r--r--meta-oe/recipes-extended/libimobiledevice/libplist_git.bb6
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb4
-rw-r--r--meta-oe/recipes-graphics/graphviz/graphviz_8.1.0.bb2
-rw-r--r--meta-oe/recipes-security/audit/audit_4.0.1.bb4
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb10
-rw-r--r--meta-oe/recipes-support/libftdi/libftdi_1.5.bb2
-rw-r--r--meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_6.4.bb2
20 files changed, 39 insertions, 39 deletions
diff --git a/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.1.bb b/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.1.bb
index 3e5fc91da..63476d349 100644
--- a/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.1.bb
+++ b/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.1.bb
@@ -33,6 +33,6 @@ RDEPENDS:${PN}-python = " python3-core "
33RDEPENDS:${PN} = " python3-core " 33RDEPENDS:${PN} = " python3-core "
34 34
35FILES:${PN} += " \ 35FILES:${PN} += " \
36 ${libdir}/${PYTHON_DIR}/site-packages/iec61850.py \ 36 ${PYTHON_SITEPACKAGES_DIR}/iec61850.py \
37 ${libdir}/${PYTHON_DIR}/site-packages/_iec61850.so \ 37 ${PYTHON_SITEPACKAGES_DIR}/_iec61850.so \
38" 38"
diff --git a/meta-networking/recipes-support/libldb/libldb_2.8.0.bb b/meta-networking/recipes-support/libldb/libldb_2.8.0.bb
index 58d683eab..bdd87993d 100644
--- a/meta-networking/recipes-support/libldb/libldb_2.8.0.bb
+++ b/meta-networking/recipes-support/libldb/libldb_2.8.0.bb
@@ -63,10 +63,10 @@ FILES:${PN}-dbg += "${bindir}/.debug/* \
63 ${libdir}/ldb/.debug/* \ 63 ${libdir}/ldb/.debug/* \
64 ${libdir}/ldb/modules/ldb/.debug/*" 64 ${libdir}/ldb/modules/ldb/.debug/*"
65 65
66FILES:pyldb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \ 66FILES:pyldb = "${PYTHON_SITEPACKAGES_DIR}/* \
67 ${libdir}/libpyldb-util.*.so.* \ 67 ${libdir}/libpyldb-util.*.so.* \
68 " 68 "
69FILES:pyldb-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug \ 69FILES:pyldb-dbg = "${PYTHON_SITEPACKAGES_DIR}/.debug \
70 ${libdir}/.debug/libpyldb-util.*.so.*" 70 ${libdir}/.debug/libpyldb-util.*.so.*"
71FILES:pyldb-dev = "${libdir}/libpyldb-util.*.so" 71FILES:pyldb-dev = "${libdir}/libpyldb-util.*.so"
72 72
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb b/meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb
index 394c17628..b617f097c 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb
+++ b/meta-networking/recipes-support/libtalloc/libtalloc_2.4.2.bb
@@ -53,7 +53,7 @@ PACKAGES += "pytalloc pytalloc-dev"
53 53
54RPROVIDES:${PN}-dbg += "pytalloc-dbg" 54RPROVIDES:${PN}-dbg += "pytalloc-dbg"
55 55
56FILES:pytalloc = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \ 56FILES:pytalloc = "${PYTHON_SITEPACKAGES_DIR}/* \
57 ${libdir}/libpytalloc-util.so.2 \ 57 ${libdir}/libpytalloc-util.so.2 \
58 ${libdir}/libpytalloc-util.so.2.1.1 \ 58 ${libdir}/libpytalloc-util.so.2.1.1 \
59 " 59 "
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb b/meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb
index f23b157e8..bd3f9f63a 100644
--- a/meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb
+++ b/meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb
@@ -58,6 +58,6 @@ RPROVIDES:${PN}-dbg += "python3-tdb-dbg"
58 58
59FILES:${PN} = "${libdir}/*.so.*" 59FILES:${PN} = "${libdir}/*.so.*"
60FILES:tdb-tools = "${bindir}/*" 60FILES:tdb-tools = "${bindir}/*"
61FILES:python3-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*" 61FILES:python3-tdb = "${PYTHON_SITEPACKAGES_DIR}/*"
62RDEPENDS:python3-tdb = "python3" 62RDEPENDS:python3-tdb = "python3"
63INSANE_SKIP:${MLPREFIX}python3-tdb = "dev-so" 63INSANE_SKIP:${MLPREFIX}python3-tdb = "dev-so"
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.16.0.bb b/meta-networking/recipes-support/libtevent/libtevent_0.16.0.bb
index 67f36083b..ac80f3733 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.16.0.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.16.0.bb
@@ -57,6 +57,6 @@ PACKAGES += "python3-tevent"
57 57
58RPROVIDES:${PN}-dbg += "python3-tevent-dbg" 58RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
59 59
60FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*" 60FILES:python3-tevent = "${PYTHON_SITEPACKAGES_DIR}/*"
61 61
62INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so" 62INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
index 3d474305d..d348ef8be 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
@@ -101,7 +101,7 @@ FILES:${PN} += "${systemd_unitdir}/system/lircd.service"
101FILES:${PN} += "${systemd_unitdir}/system/lircd.socket" 101FILES:${PN} += "${systemd_unitdir}/system/lircd.socket"
102FILES:${PN} += "${libdir}/tmpfiles.d/lirc.conf" 102FILES:${PN} += "${libdir}/tmpfiles.d/lirc.conf"
103FILES:${PN}-dbg += "${libdir}/lirc/plugins/.debug" 103FILES:${PN}-dbg += "${libdir}/lirc/plugins/.debug"
104FILES:${PN}-python += "${bindir}/irdb-get ${bindir}/irtext2udp ${bindir}/lircd-setup ${bindir}/pronto2lirc ${libdir}/python*/site-packages" 104FILES:${PN}-python += "${bindir}/irdb-get ${bindir}/irtext2udp ${bindir}/lircd-setup ${bindir}/pronto2lirc ${PYTHON_SITEPACKAGES_DIR}"
105 105
106INITSCRIPT_PACKAGES = "lirc lirc-exec" 106INITSCRIPT_PACKAGES = "lirc lirc-exec"
107INITSCRIPT_NAME:lirc-exec = "lircexec" 107INITSCRIPT_NAME:lirc-exec = "lircexec"
diff --git a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb
index 15a796593..6b60d8918 100644
--- a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb
+++ b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb
@@ -17,7 +17,7 @@ SRC_URI = "git://github.com/rnovacek/konkretcmpi.git;branch=master;protocol=http
17SRCREV = "ad28225e6eceff88417a60c1ba8896c8e40f21a7" 17SRCREV = "ad28225e6eceff88417a60c1ba8896c8e40f21a7"
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20inherit cmake 20inherit cmake python3-dir
21 21
22EXTRA_OECMAKE = "-DWITH_PYTHON=ON \ 22EXTRA_OECMAKE = "-DWITH_PYTHON=ON \
23 ${@oe.utils.conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \ 23 ${@oe.utils.conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
@@ -34,6 +34,6 @@ PACKAGES =+ "${PN}-python"
34 34
35RPROVIDES:${PN}-dbg += "${PN}-python-dbg" 35RPROVIDES:${PN}-dbg += "${PN}-python-dbg"
36 36
37FILES:${PN}-python = "${libdir}/python*/site-packages/konkretmof.py* ${libdir}/python*/site-packages/_konkretmof.so" 37FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/konkretmof.py* ${PYTHON_SITEPACKAGES_DIR}/_konkretmof.so"
38 38
39BBCLASSEXTEND = "native" 39BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb
index dd1514628..1ad8036d7 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_3.1.1.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/storaged-project/libblockdev;branch=3.1.x-devel;prot
18SRCREV = "68aaff5556afe26be749c29a2b7cbd714dce3050" 18SRCREV = "68aaff5556afe26be749c29a2b7cbd714dce3050"
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21FILES:${PN} += "${libdir}/python3.*/site-packages" 21FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
22 22
23PACKAGECONFIG ??= "python3 lvm lvm-dbus dm parted fs escrow btrfs crypto mdraid mpath nvdimm tools" 23PACKAGECONFIG ??= "python3 lvm lvm-dbus dm parted fs escrow btrfs crypto mdraid mpath nvdimm tools"
24PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" 24PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_2.3.0.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_2.3.0.bb
index 69e80ac0c..81a3c26e0 100644
--- a/meta-oe/recipes-extended/libimobiledevice/libplist_2.3.0.bb
+++ b/meta-oe/recipes-extended/libimobiledevice/libplist_2.3.0.bb
@@ -26,8 +26,8 @@ do_configure:prepend() {
26} 26}
27 27
28do_install:append () { 28do_install:append () {
29 if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then 29 if [ -e ${D}${PYTHON_SITEPACKAGES_DIR}/plist/_plist.so ]; then
30 chrpath -d ${D}${libdir}/python*/site-packages/plist/_plist.so 30 chrpath -d ${D}${PYTHON_SITEPACKAGES_DIR}/plist/_plist.so
31 fi 31 fi
32} 32}
33 33
@@ -38,4 +38,4 @@ PACKAGES =+ "${PN}-utils \
38FILES:${PN} = "${libdir}/libplist-2.0${SOLIBS}" 38FILES:${PN} = "${libdir}/libplist-2.0${SOLIBS}"
39FILES:${PN}++ = "${libdir}/libplist++-2.0${SOLIBS}" 39FILES:${PN}++ = "${libdir}/libplist++-2.0${SOLIBS}"
40FILES:${PN}-utils = "${bindir}/*" 40FILES:${PN}-utils = "${bindir}/*"
41FILES:${PN}-python = "${libdir}/python*/site-packages/*" 41FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
index 26dd821f9..bfd4af053 100644
--- a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
+++ b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
@@ -28,8 +28,8 @@ do_configure:prepend() {
28} 28}
29 29
30do_install:append () { 30do_install:append () {
31 if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then 31 if [ -e ${D}${PYTHON_SITEPACKAGES_DIR}/plist/_plist.so ]; then
32 chrpath -d ${D}${libdir}/python*/site-packages/plist/_plist.so 32 chrpath -d ${D}${PYTHON_SITEPACKAGES_DIR}/plist/_plist.so
33 fi 33 fi
34} 34}
35 35
@@ -40,4 +40,4 @@ PACKAGES =+ "${PN}-utils \
40FILES:${PN} = "${libdir}/libplist-2.0${SOLIBS}" 40FILES:${PN} = "${libdir}/libplist-2.0${SOLIBS}"
41FILES:${PN}++ = "${libdir}/libplist++-2.0${SOLIBS}" 41FILES:${PN}++ = "${libdir}/libplist++-2.0${SOLIBS}"
42FILES:${PN}-utils = "${bindir}/*" 42FILES:${PN}-utils = "${bindir}/*"
43FILES:${PN}-python = "${libdir}/python*/site-packages/*" 43FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb
index f0c083c6d..cbe1af285 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.8.0.bb
@@ -124,8 +124,8 @@ RDEPENDS:${PN}-perl = "perl perl-module-lib perl-module-getopt-long perl-module-
124 124
125DESCRIPTION:${PN}-python = \ 125DESCRIPTION:${PN}-python = \
126"The ${PN}-python package includes RRDtool bindings for python." 126"The ${PN}-python package includes RRDtool bindings for python."
127FILES:${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*" 127FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
128RDEPENDS:${PN}-python = "python3" 128RDEPENDS:${PN}-python = "python3"
129 129
130FILES:${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/RRDs/.debug \ 130FILES:${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/RRDs/.debug \
131 ${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug" 131 ${PYTHON_SITEPACKAGES_DIR}/.debug"
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_8.1.0.bb b/meta-oe/recipes-graphics/graphviz/graphviz_8.1.0.bb
index 4d40ee4de..2700142e5 100644
--- a/meta-oe/recipes-graphics/graphviz/graphviz_8.1.0.bb
+++ b/meta-oe/recipes-graphics/graphviz/graphviz_8.1.0.bb
@@ -101,7 +101,7 @@ PACKAGE_WRITE_DEPS += "qemu-native"
101 101
102PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo" 102PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
103 103
104FILES:${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/" 104FILES:${PN}-python += "${PYTHON_SITEPACKAGES_DIR}/ ${libdir}/graphviz/python/"
105FILES:${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/" 105FILES:${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/"
106FILES:${PN}-demo += "${datadir}/graphviz/demo/" 106FILES:${PN}-demo += "${datadir}/graphviz/demo/"
107 107
diff --git a/meta-oe/recipes-security/audit/audit_4.0.1.bb b/meta-oe/recipes-security/audit/audit_4.0.1.bb
index 96ed6ff3d..a37ae3bb8 100644
--- a/meta-oe/recipes-security/audit/audit_4.0.1.bb
+++ b/meta-oe/recipes-security/audit/audit_4.0.1.bb
@@ -44,8 +44,8 @@ EXTRA_OECONF = " \
44 44
45EXTRA_OEMAKE = " \ 45EXTRA_OEMAKE = " \
46 PYTHON=python3 \ 46 PYTHON=python3 \
47 pythondir=${libdir}/python${PYTHON_BASEVERSION}/site-packages \ 47 pythondir=${PYTHON_SITEPACKAGES_DIR} \
48 pyexecdir=${libdir}/python${PYTHON_BASEVERSION}/site-packages \ 48 pyexecdir=${PYTHON_SITEPACKAGES_DIR} \
49 STDINC='${STAGING_INCDIR}' \ 49 STDINC='${STAGING_INCDIR}' \
50 " 50 "
51 51
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
index aa595ebe5..139649b97 100644
--- a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
@@ -48,12 +48,12 @@ RDEPENDS:${PN}-bin = " \
48 48
49FILES:${PN} += " \ 49FILES:${PN} += " \
50 ${datadir}/geisview \ 50 ${datadir}/geisview \
51 ${libdir}/${PYTHON_DIR}/site-packages/geis* \ 51 ${PYTHON_SITEPACKAGES_DIR}/geis* \
52 ${libdir}/${PYTHON_DIR}/site-packages/_*.so \ 52 ${PYTHON_SITEPACKAGES_DIR}/_*.so \
53" 53"
54 54
55FILES:${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug" 55FILES:${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
56 56
57FILES:${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la" 57FILES:${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/_*.la"
58 58
59FILES:${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a" 59FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_*.a"
diff --git a/meta-oe/recipes-support/libftdi/libftdi_1.5.bb b/meta-oe/recipes-support/libftdi/libftdi_1.5.bb
index 7f0cfa237..eae1c02f0 100644
--- a/meta-oe/recipes-support/libftdi/libftdi_1.5.bb
+++ b/meta-oe/recipes-support/libftdi/libftdi_1.5.bb
@@ -37,4 +37,4 @@ BBCLASSEXTEND = "native nativesdk"
37PACKAGES =+ "${PN}-python ftdi-eeprom" 37PACKAGES =+ "${PN}-python ftdi-eeprom"
38 38
39FILES:ftdi-eeprom = "${bindir}/ftdi_eeprom" 39FILES:ftdi-eeprom = "${bindir}/ftdi_eeprom"
40FILES:${PN}-python = "${libdir}/${PYTHON_DIR}/site-packages/" 40FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/"
diff --git a/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb b/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
index 31f6ae37f..23c216504 100644
--- a/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
+++ b/meta-python/recipes-connectivity/telepathy/telepathy-python3_0.15.19.bb
@@ -20,14 +20,14 @@ SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017"
20SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376" 20SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376"
21 21
22FILES:${PN} += "\ 22FILES:${PN} += "\
23 ${libdir}/python*/site-packages/telepathy/*.py \ 23 ${PYTHON_SITEPACKAGES_DIR}/telepathy/*.py \
24 ${libdir}/python*/site-packages/telepathy/*/*.py \ 24 ${PYTHON_SITEPACKAGES_DIR}/telepathy/*/*.py \
25" 25"
26 26
27do_install:append () { 27do_install:append () {
28 rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__ 28 rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/__pycache__
29 rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__ 29 rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/__pycache__
30 rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__ 30 rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/*/__pycache__
31 rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__ 31 rm -fr ${D}${PYTHON_SITEPACKAGES_DIR}/telepathy/*/__pycache__
32} 32}
33RDEPENDS:${PN} += "python3-dbus" 33RDEPENDS:${PN} += "python3-dbus"
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
index ac76ccc96..1f7a4a03f 100644
--- a/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
@@ -10,7 +10,7 @@ PYPI_PACKAGE = "python-dateutil"
10inherit pypi python_setuptools_build_meta 10inherit pypi python_setuptools_build_meta
11 11
12PACKAGES =+ "${PN}-zoneinfo" 12PACKAGES =+ "${PN}-zoneinfo"
13FILES:${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo" 13FILES:${PN}-zoneinfo = "${PYTHON_SITEPACKAGES_DIR}/dateutil/zoneinfo"
14 14
15DEPENDS += "python3-setuptools-scm-native" 15DEPENDS += "python3-setuptools-scm-native"
16 16
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
index 934e3e2bb..faa291ea6 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
@@ -36,12 +36,12 @@ RDEPENDS:${PN}-ptest += "\
36" 36"
37 37
38do_install:append() { 38do_install:append() {
39 for f in ${D}/${libdir}/${PYTHON_DIR}/site-packages/pydantic_core/_pydantic_core.*.so 39 for f in ${D}/${PYTHON_SITEPACKAGES_DIR}/pydantic_core/_pydantic_core.*.so
40 do 40 do
41 fname=`basename $f` 41 fname=`basename $f`
42 lname=`echo $fname | sed 's/musl/gnu/'` 42 lname=`echo $fname | sed 's/musl/gnu/'`
43 if [ "$fname" != "$lname" ]; then 43 if [ "$fname" != "$lname" ]; then
44 mv $f ${D}/${libdir}/${PYTHON_DIR}/site-packages/pydantic_core/$lname 44 mv $f ${D}/${PYTHON_SITEPACKAGES_DIR}/pydantic_core/$lname
45 fi 45 fi
46 done 46 done
47} 47}
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb b/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
index 540aa6200..2a6993c14 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
@@ -22,7 +22,7 @@ PACKAGES =+ "\
22" 22"
23 23
24FILES:${PN}-test += "\ 24FILES:${PN}-test += "\
25 ${libdir}/${PYTHON_DIR}/site-packages/*/tests \ 25 ${PYTHON_SITEPACKAGES_DIR}/*/tests \
26" 26"
27 27
28RDEPENDS:${PN} += "\ 28RDEPENDS:${PN} += "\
diff --git a/meta-python/recipes-devtools/python/python3-tornado_6.4.bb b/meta-python/recipes-devtools/python/python3-tornado_6.4.bb
index 08c8672eb..b01c1cec2 100644
--- a/meta-python/recipes-devtools/python/python3-tornado_6.4.bb
+++ b/meta-python/recipes-devtools/python/python3-tornado_6.4.bb
@@ -35,7 +35,7 @@ PACKAGES =+ "\
35" 35"
36 36
37FILES:${PN}-test = " \ 37FILES:${PN}-test = " \
38 ${libdir}/${PYTHON_DIR}/site-packages/*/test \ 38 ${PYTHON_SITEPACKAGES_DIR}/*/test \
39" 39"
40 40
41BBCLASSEXTEND += "native nativesdk" 41BBCLASSEXTEND += "native nativesdk"