diff options
author | Alex Kiernan <alex.kiernan@gmail.com> | 2024-10-30 09:32:54 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-10-30 08:24:30 -0700 |
commit | cedfa1be3aee047ddc6ac146626eb17eb2529342 (patch) | |
tree | 7d2758f17178ac28dddc4c300a781512208df108 | |
parent | 78a332939f8bd852c47a09a65d9d1837aa83ff97 (diff) | |
download | meta-openembedded-cedfa1be3aee047ddc6ac146626eb17eb2529342.tar.gz |
mdns: Upgrade 2200.140.11 -> 2559.1.1
Add local fixes for:
* definition for MAX()
* missing `limit` declarations
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch | 6 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch | 8 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0004-Add-definition-for-MAX.patch | 24 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0005-Fix-missing-limit-declarations.patch | 49 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns/0009-remove-unneeded-headers.patch | 5 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/mdns/mdns_2559.1.1.bb (renamed from meta-networking/recipes-protocols/mdns/mdns_2200.140.11.bb) | 7 |
6 files changed, 87 insertions, 12 deletions
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch b/meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch index abf82b1e0..d74c031ab 100644 --- a/meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch +++ b/meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 2db1f5bc941e4b4cd1721e361a47cfe288b07a76 Mon Sep 17 00:00:00 2001 | 1 | From 3138d70ce8f521d03120e7789e93ebe290ece101 Mon Sep 17 00:00:00 2001 |
2 | From: Alex Kiernan <alex.kiernan@gmail.com> | 2 | From: Alex Kiernan <alex.kiernan@gmail.com> |
3 | Date: Thu, 1 Feb 2024 14:07:03 +0000 | 3 | Date: Thu, 1 Feb 2024 14:07:03 +0000 |
4 | Subject: [PATCH] Fix SIGSEGV during DumpStateLog() | 4 | Subject: [PATCH] Fix SIGSEGV during DumpStateLog() |
@@ -13,10 +13,10 @@ Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | |||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | 13 | 1 file changed, 1 insertion(+), 1 deletion(-) |
14 | 14 | ||
15 | diff --git a/mDNSShared/mDNSDebug.c b/mDNSShared/mDNSDebug.c | 15 | diff --git a/mDNSShared/mDNSDebug.c b/mDNSShared/mDNSDebug.c |
16 | index 7a4ca19eff6d..d449dde320f6 100644 | 16 | index b531fcea2bb9..1e8d9b10afbc 100644 |
17 | --- a/mDNSShared/mDNSDebug.c | 17 | --- a/mDNSShared/mDNSDebug.c |
18 | +++ b/mDNSShared/mDNSDebug.c | 18 | +++ b/mDNSShared/mDNSDebug.c |
19 | @@ -71,7 +71,7 @@ mDNSlocal void LogMsgWithLevelv(os_log_t category, os_log_type_t level, const ch | 19 | @@ -72,7 +72,7 @@ mDNSlocal void LogMsgWithLevelv(os_log_t category, os_log_type_t level, const ch |
20 | mDNSlocal void LogMsgWithLevelv(const char *category, mDNSLogLevel_t level, const char *format, va_list args) | 20 | mDNSlocal void LogMsgWithLevelv(const char *category, mDNSLogLevel_t level, const char *format, va_list args) |
21 | { | 21 | { |
22 | // Do not print the logs if the log category is MDNS_LOG_CATEGORY_DISABLED. | 22 | // Do not print the logs if the log category is MDNS_LOG_CATEGORY_DISABLED. |
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch b/meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch index 7ec599601..a531884af 100644 --- a/meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch +++ b/meta-networking/recipes-protocols/mdns/mdns/0001-Handle-interface-without-ifa_addr.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From c67102307f25c5f4d238c736e90519e56a76ae79 Mon Sep 17 00:00:00 2001 | 1 | From 199b376e585d5362a1f51ea20e45dcc3bdb7d6aa Mon Sep 17 00:00:00 2001 |
2 | From: Stefan Agner <stefan@agner.ch> | 2 | From: Stefan Agner <stefan@agner.ch> |
3 | Date: Fri, 23 Jun 2023 10:10:00 +0200 | 3 | Date: Fri, 23 Jun 2023 10:10:00 +0200 |
4 | Subject: [PATCH] Handle interface without `ifa_addr` | 4 | Subject: [PATCH] Handle interface without `ifa_addr` |
@@ -15,10 +15,10 @@ Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | |||
15 | 1 file changed, 3 insertions(+), 1 deletion(-) | 15 | 1 file changed, 3 insertions(+), 1 deletion(-) |
16 | 16 | ||
17 | diff --git a/mDNSPosix/mDNSPosix.c b/mDNSPosix/mDNSPosix.c | 17 | diff --git a/mDNSPosix/mDNSPosix.c b/mDNSPosix/mDNSPosix.c |
18 | index 0c9dd2582660..c3ead26799e6 100644 | 18 | index 4c835a8c253c..e1e27b1de3b2 100644 |
19 | --- a/mDNSPosix/mDNSPosix.c | 19 | --- a/mDNSPosix/mDNSPosix.c |
20 | +++ b/mDNSPosix/mDNSPosix.c | 20 | +++ b/mDNSPosix/mDNSPosix.c |
21 | @@ -1895,6 +1895,7 @@ mDNSlocal void InterfaceChangeCallback(int fd, void *context) | 21 | @@ -1927,6 +1927,7 @@ mDNSlocal void InterfaceChangeCallback(int fd, void *context) |
22 | continue; | 22 | continue; |
23 | 23 | ||
24 | if ((ifa_loop4 == NULL) && | 24 | if ((ifa_loop4 == NULL) && |
@@ -26,7 +26,7 @@ index 0c9dd2582660..c3ead26799e6 100644 | |||
26 | ((*ifi)->ifa_addr->sa_family == AF_INET) && | 26 | ((*ifi)->ifa_addr->sa_family == AF_INET) && |
27 | ((*ifi)->ifa_flags & IFF_UP) && | 27 | ((*ifi)->ifa_flags & IFF_UP) && |
28 | ((*ifi)->ifa_flags & IFF_LOOPBACK)) | 28 | ((*ifi)->ifa_flags & IFF_LOOPBACK)) |
29 | @@ -1903,7 +1904,8 @@ mDNSlocal void InterfaceChangeCallback(int fd, void *context) | 29 | @@ -1935,7 +1936,8 @@ mDNSlocal void InterfaceChangeCallback(int fd, void *context) |
30 | continue; | 30 | continue; |
31 | } | 31 | } |
32 | 32 | ||
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0004-Add-definition-for-MAX.patch b/meta-networking/recipes-protocols/mdns/mdns/0004-Add-definition-for-MAX.patch new file mode 100644 index 000000000..82d7ceca3 --- /dev/null +++ b/meta-networking/recipes-protocols/mdns/mdns/0004-Add-definition-for-MAX.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | From f0adca77472c9c1df6db14f2b03e66d78a577649 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alex Kiernan <alex.kiernan@gmail.com> | ||
3 | Date: Sat, 26 Oct 2024 13:24:45 +0000 | ||
4 | Subject: [PATCH] Add definition for MAX() | ||
5 | |||
6 | Upstream-Status: Inactive-Upstream [Upstream does not take patches] | ||
7 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
8 | --- | ||
9 | mDNSShared/uds_daemon.c | 2 ++ | ||
10 | 1 file changed, 2 insertions(+) | ||
11 | |||
12 | diff --git a/mDNSShared/uds_daemon.c b/mDNSShared/uds_daemon.c | ||
13 | index e73bc1181b73..1d590a6a3580 100644 | ||
14 | --- a/mDNSShared/uds_daemon.c | ||
15 | +++ b/mDNSShared/uds_daemon.c | ||
16 | @@ -89,6 +89,8 @@ | ||
17 | |||
18 | #include "mdns_strict.h" | ||
19 | |||
20 | +#define MAX(A, B) (((A) > (B)) ? (A) : (B)) | ||
21 | + | ||
22 | // User IDs 0-500 are system-wide processes, not actual users in the usual sense | ||
23 | // User IDs for real user accounts start at 501 and count up from there | ||
24 | #define SystemUID(X) ((X) <= 500) | ||
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0005-Fix-missing-limit-declarations.patch b/meta-networking/recipes-protocols/mdns/mdns/0005-Fix-missing-limit-declarations.patch new file mode 100644 index 000000000..4d4a8cf9b --- /dev/null +++ b/meta-networking/recipes-protocols/mdns/mdns/0005-Fix-missing-limit-declarations.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From cf216a6872139e435d5712787359b03022b51d2b Mon Sep 17 00:00:00 2001 | ||
2 | From: Alex Kiernan <alexk@zuma.ai> | ||
3 | Date: Sat, 26 Oct 2024 13:26:09 +0000 | ||
4 | Subject: [PATCH] Fix missing `limit` declarations | ||
5 | |||
6 | `put_attribute_tlvs` needs a limit setting which is missing, add it in. | ||
7 | |||
8 | Upstream-Status: Inactive-Upstream [Upstream does not take patches] | ||
9 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | ||
10 | --- | ||
11 | mDNSShared/dnssd_clientstub.c | 4 ++++ | ||
12 | 1 file changed, 4 insertions(+) | ||
13 | |||
14 | diff --git a/mDNSShared/dnssd_clientstub.c b/mDNSShared/dnssd_clientstub.c | ||
15 | index fc93d162446a..a6cf45fa9856 100644 | ||
16 | --- a/mDNSShared/dnssd_clientstub.c | ||
17 | +++ b/mDNSShared/dnssd_clientstub.c | ||
18 | @@ -2022,6 +2022,7 @@ DNSServiceErrorType DNSServiceRegisterInternal | ||
19 | ipc_msg_hdr *hdr; | ||
20 | DNSServiceErrorType err; | ||
21 | union { uint16_t s; u_char b[2]; } port = { portInNetworkByteOrder }; | ||
22 | + const uint8_t *limit; | ||
23 | (void)attr; | ||
24 | |||
25 | if (!sdRef || !regtype) return kDNSServiceErr_BadParam; | ||
26 | @@ -2054,6 +2055,7 @@ DNSServiceErrorType DNSServiceRegisterInternal | ||
27 | if (!hdr) { DNSServiceRefDeallocate(*sdRef); *sdRef = NULL; return kDNSServiceErr_NoMemory; } | ||
28 | if (!callBack) hdr->ipc_flags |= IPC_FLAGS_NOREPLY; | ||
29 | |||
30 | + limit = ptr + len; | ||
31 | put_flags(flags, &ptr); | ||
32 | put_uint32(interfaceIndex, &ptr); | ||
33 | put_string(name, &ptr); | ||
34 | @@ -2334,6 +2336,7 @@ DNSServiceErrorType DNSServiceRegisterRecordInternal | ||
35 | ipc_msg_hdr *hdr = NULL; | ||
36 | DNSRecordRef rref = NULL; | ||
37 | DNSRecord **p; | ||
38 | + const uint8_t *limit; | ||
39 | (void)attr; | ||
40 | |||
41 | // Verify that only one of the following flags is set. | ||
42 | @@ -2389,6 +2392,7 @@ DNSServiceErrorType DNSServiceRegisterRecordInternal | ||
43 | hdr = create_hdr(reg_record_request, &len, &ptr, !(flags & kDNSServiceFlagsQueueRequest), sdRef); | ||
44 | if (!hdr) return kDNSServiceErr_NoMemory; | ||
45 | |||
46 | + limit = ptr + len; | ||
47 | put_flags(flags, &ptr); | ||
48 | put_uint32(interfaceIndex, &ptr); | ||
49 | put_string(fullname, &ptr); | ||
diff --git a/meta-networking/recipes-protocols/mdns/mdns/0009-remove-unneeded-headers.patch b/meta-networking/recipes-protocols/mdns/mdns/0009-remove-unneeded-headers.patch index 818017037..3784e3be8 100644 --- a/meta-networking/recipes-protocols/mdns/mdns/0009-remove-unneeded-headers.patch +++ b/meta-networking/recipes-protocols/mdns/mdns/0009-remove-unneeded-headers.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 05cb409ce213f35798c02faf2032d4846a84b48e Mon Sep 17 00:00:00 2001 | 1 | From d15ee692af42163846be7517372f3ee098cdaf18 Mon Sep 17 00:00:00 2001 |
2 | From: Beniamin Sandu <beniaminsandu@gmail.com> | 2 | From: Beniamin Sandu <beniaminsandu@gmail.com> |
3 | Date: Thu, 15 Jun 2023 17:02:58 +0000 | 3 | Date: Thu, 15 Jun 2023 17:02:58 +0000 |
4 | Subject: [PATCH] remove unneeded headers | 4 | Subject: [PATCH] remove unneeded headers |
@@ -7,8 +7,7 @@ From a quick look, these seem to not be needed and having them | |||
7 | breaks the build with mbedtls 3.x. Without them it builds fine | 7 | breaks the build with mbedtls 3.x. Without them it builds fine |
8 | on both 2.x and 3.x versions. | 8 | on both 2.x and 3.x versions. |
9 | 9 | ||
10 | Upstream-Status: Pending | 10 | Upstream-Status: Inactive-Upstream [Upstream does not take patches] |
11 | |||
12 | Signed-off-by: Beniamin Sandu <beniaminsandu@gmail.com> | 11 | Signed-off-by: Beniamin Sandu <beniaminsandu@gmail.com> |
13 | --- | 12 | --- |
14 | mDNSPosix/mbedtls.c | 2 -- | 13 | mDNSPosix/mbedtls.c | 2 -- |
diff --git a/meta-networking/recipes-protocols/mdns/mdns_2200.140.11.bb b/meta-networking/recipes-protocols/mdns/mdns_2559.1.1.bb index e6ea70719..212fd0eab 100644 --- a/meta-networking/recipes-protocols/mdns/mdns_2200.140.11.bb +++ b/meta-networking/recipes-protocols/mdns/mdns_2559.1.1.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=31c50371921e0fb731003bbc665f29bf" | |||
6 | 6 | ||
7 | DEPENDS:append:libc-musl = " musl-nscd" | 7 | DEPENDS:append:libc-musl = " musl-nscd" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https;branch=rel/mDNSResponder-2200 \ | 9 | SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https;branch=${BRANCH} \ |
10 | file://0001-dns-sd-Include-missing-headers.patch \ | 10 | file://0001-dns-sd-Include-missing-headers.patch \ |
11 | file://0002-make-Set-libdns_sd.so-soname-correctly.patch \ | 11 | file://0002-make-Set-libdns_sd.so-soname-correctly.patch \ |
12 | file://0004-make-Separate-TLS-targets-from-libraries.patch \ | 12 | file://0004-make-Separate-TLS-targets-from-libraries.patch \ |
@@ -24,8 +24,11 @@ SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https | |||
24 | file://mdns.service \ | 24 | file://mdns.service \ |
25 | file://0001-Handle-interface-without-ifa_addr.patch \ | 25 | file://0001-Handle-interface-without-ifa_addr.patch \ |
26 | file://0001-Fix-SIGSEGV-during-DumpStateLog.patch \ | 26 | file://0001-Fix-SIGSEGV-during-DumpStateLog.patch \ |
27 | file://0005-Fix-missing-limit-declarations.patch \ | ||
28 | file://0004-Add-definition-for-MAX.patch \ | ||
27 | " | 29 | " |
28 | SRCREV = "12e84b9089e577e0c0a9f48c4b922d7349fcc5a4" | 30 | BRANCH = "main" |
31 | SRCREV = "71e6611203d57c78b26fd505d98cb57a33d00880" | ||
29 | 32 | ||
30 | # We install a stub Makefile in the top directory so that the various checks | 33 | # We install a stub Makefile in the top directory so that the various checks |
31 | # in base.bbclass pass their tests for a Makefile, this ensures (that amongst | 34 | # in base.bbclass pass their tests for a Makefile, this ensures (that amongst |