summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-23 19:01:26 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-23 20:10:28 -0700
commitcb02f5b68d6bac74542ac34194da1b5a31eb3241 (patch)
tree9fc7f67bd02737956938d82d59e6c58b397bfead
parente1e5ba58c028030e699da3698a6f3cbf2c8d3e7f (diff)
downloadmeta-openembedded-cb02f5b68d6bac74542ac34194da1b5a31eb3241.tar.gz
openflow: Merge .inc into .bb
There is one recipe so merge the include file into recipe Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow.inc60
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow_git.bb62
2 files changed, 59 insertions, 63 deletions
diff --git a/meta-networking/recipes-protocols/openflow/openflow.inc b/meta-networking/recipes-protocols/openflow/openflow.inc
deleted file mode 100644
index 7b404f540..000000000
--- a/meta-networking/recipes-protocols/openflow/openflow.inc
+++ /dev/null
@@ -1,60 +0,0 @@
1SUMMARY = "OpenFlow communications protocol"
2DESCRIPTION = "\
3Open standard that enables researchers to run experimental protocols in \
4contained networks. OpenFlow is a communications interface between \
5control and forwarding planes of a software-defined networking architecture.\
6"
7HOMEPAGE = "http://www.openflow.org"
8
9SECTION = "net"
10LICENSE = "GPL-2.0-only"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=e870c934e2c3d6ccf085fd7cf0a1e2e2"
13
14SRC_URI = "git://github.com/mininet/openflow;protocol=https;branch=master"
15
16CVE_STATUS[CVE-2015-1611] = "not-applicable-config: Not referred to our implementation of openflow"
17CVE_STATUS[CVE-2015-1612] = "not-applicable-config: Not referred to our implementation of openflow"
18CVE_STATUS[CVE-2018-1078] = "cpe-incorrect: This CVE is not for this product but cve-check assumes it is \
19because two CPE collides when checking the NVD database"
20
21DEPENDS = "virtual/libc"
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[openssl] = "--enable-ssl,--disable-ssl, openssl openssl-native, libssl"
25
26EXTRA_OECONF += " \
27 KARCH=${TARGET_ARCH} \
28 ${@bb.utils.contains('PACKAGECONFIG', 'openssl', 'SSL_LIBS="-lssl -lcrypto"', '', d)} \
29 "
30
31S = "${WORKDIR}/git"
32
33inherit autotools-brokensep pkgconfig
34
35do_configure:prepend() {
36 ./boot.sh
37}
38
39do_install:append() {
40 # Remove /var/run as it is created on startup
41 rm -rf ${D}${localstatedir}/run
42
43 # /var/log/openflow needs to be created in runtime. Use rmdir to catch if
44 # upstream stops creating /var/log/openflow, or adds something else in
45 # /var/log.
46 rmdir ${D}${localstatedir}/log/${BPN} ${D}${localstatedir}/log
47 rmdir --ignore-fail-on-non-empty ${D}${localstatedir}
48
49 # Create /var/log/openflow in runtime.
50 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
51 install -d ${D}${nonarch_libdir}/tmpfiles.d
52 echo "d ${localstatedir}/log/${BPN} - - - -" > ${D}${nonarch_libdir}/tmpfiles.d/${BPN}.conf
53 fi
54 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)}" ]; then
55 install -d ${D}${sysconfdir}/default/volatiles
56 echo "d root root 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN}
57 fi
58}
59
60FILES:${PN} += "${nonarch_libdir}/tmpfiles.d"
diff --git a/meta-networking/recipes-protocols/openflow/openflow_git.bb b/meta-networking/recipes-protocols/openflow/openflow_git.bb
index c86c811cc..eadfc2546 100644
--- a/meta-networking/recipes-protocols/openflow/openflow_git.bb
+++ b/meta-networking/recipes-protocols/openflow/openflow_git.bb
@@ -1,11 +1,67 @@
1include ${BPN}.inc 1SUMMARY = "OpenFlow communications protocol"
2DESCRIPTION = "\
3Open standard that enables researchers to run experimental protocols in \
4contained networks. OpenFlow is a communications interface between \
5control and forwarding planes of a software-defined networking architecture.\
6"
7HOMEPAGE = "http://www.openflow.org"
8
9SECTION = "net"
10LICENSE = "GPL-2.0-only"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=e870c934e2c3d6ccf085fd7cf0a1e2e2"
2 13
3SRCREV = "82ad07d997b0b2ee70e1b2c7e82fcc6d0ccf23ea" 14SRCREV = "82ad07d997b0b2ee70e1b2c7e82fcc6d0ccf23ea"
15
4PV = "1.0+git" 16PV = "1.0+git"
5 17
6SRC_URI += "file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \ 18SRC_URI = "git://github.com/mininet/openflow;protocol=https;branch=master \
19 file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \
7 file://0002-lib-netdev-Adjust-header-include-sequence.patch \ 20 file://0002-lib-netdev-Adjust-header-include-sequence.patch \
8 file://0001-generate-not-static-get_dh-functions.patch \ 21 file://0001-generate-not-static-get_dh-functions.patch \
9 file://0001-socket-util-Include-sys-stat.h-for-fchmod.patch \ 22 file://0001-socket-util-Include-sys-stat.h-for-fchmod.patch \
10 file://0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch \ 23 file://0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch \
11 " 24"
25CVE_STATUS[CVE-2015-1611] = "not-applicable-config: Not referred to our implementation of openflow"
26CVE_STATUS[CVE-2015-1612] = "not-applicable-config: Not referred to our implementation of openflow"
27CVE_STATUS[CVE-2018-1078] = "cpe-incorrect: This CVE is not for this product but cve-check assumes it is \
28because two CPE collides when checking the NVD database"
29
30PACKAGECONFIG ??= ""
31PACKAGECONFIG[openssl] = "--enable-ssl,--disable-ssl, openssl openssl-native, libssl"
32
33EXTRA_OECONF += " \
34 KARCH=${TARGET_ARCH} \
35 ${@bb.utils.contains('PACKAGECONFIG', 'openssl', 'SSL_LIBS="-lssl -lcrypto"', '', d)} \
36 "
37
38S = "${WORKDIR}/git"
39
40inherit autotools-brokensep pkgconfig
41
42do_configure:prepend() {
43 ./boot.sh
44}
45
46do_install:append() {
47 # Remove /var/run as it is created on startup
48 rm -rf ${D}${localstatedir}/run
49
50 # /var/log/openflow needs to be created in runtime. Use rmdir to catch if
51 # upstream stops creating /var/log/openflow, or adds something else in
52 # /var/log.
53 rmdir ${D}${localstatedir}/log/${BPN} ${D}${localstatedir}/log
54 rmdir --ignore-fail-on-non-empty ${D}${localstatedir}
55
56 # Create /var/log/openflow in runtime.
57 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
58 install -d ${D}${nonarch_libdir}/tmpfiles.d
59 echo "d ${localstatedir}/log/${BPN} - - - -" > ${D}${nonarch_libdir}/tmpfiles.d/${BPN}.conf
60 fi
61 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)}" ]; then
62 install -d ${D}${sysconfdir}/default/volatiles
63 echo "d root root 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN}
64 fi
65}
66
67FILES:${PN} += "${nonarch_libdir}/tmpfiles.d"