diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-11-29 18:41:51 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-11-30 09:46:47 -0800 |
commit | c8e7f93867671a23f2b6d4a7559ea024a0dfc784 (patch) | |
tree | dad758a51ba52687ae3bb019b4c24d7c29b9f6a3 | |
parent | 5a1d5db2b66aa4c9fc27a029fc07c2f20bf3ffb6 (diff) | |
download | meta-openembedded-c8e7f93867671a23f2b6d4a7559ea024a0dfc784.tar.gz |
aufs-util: Fix build with large file support enabled systems
Fixes
| /mnt/b/yoe/master/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/aufs-util/4.9+gitAUTOINC+8f35db59ef-r0/recipe-sysroot-native/usr/bin/arm-yoe-linux-gnueabi/arm-yoe-linux-gnueabi-ld: rdu64.o: in function `readdir64':
| <unknown>:122: multiple definition of `readdir64'; rdu.o:<unknown>:122: first defined here
| /mnt/b/yoe/master/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/aufs-util/4.9+gitAUTOINC+8f35db59ef-r0/recipe-sysroot-native/usr/bin/arm-yoe-linux-gnueabi/arm-yoe-linux-gnueabi-ld: rdu64.o: in function `readdir64_r':
| <unknown>:139: multiple definition of `readdir64_r'; rdu.o:<unknown>:139: first defined here
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Do-not-build-LFS-version-of-readdir.patch | 32 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb | 1 |
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Do-not-build-LFS-version-of-readdir.patch b/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Do-not-build-LFS-version-of-readdir.patch new file mode 100644 index 0000000000..c983733dcb --- /dev/null +++ b/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Do-not-build-LFS-version-of-readdir.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 12ba95281d0bbea3576350d635b4dee0f953b94a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 29 Nov 2022 18:38:07 -0800 | ||
4 | Subject: [PATCH] libau: Do not build LFS version of readdir | ||
5 | |||
6 | rdu64 is providing largefile supported version of readdir and readdir_r | ||
7 | however, we enable largefile support unconditionally in OE therefore its | ||
8 | not needed since readdir() and readdir_r() are already LFS capable | ||
9 | |||
10 | Upstream-Status: Inappropriate [OE-Specific] | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | libau/Makefile | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/libau/Makefile b/libau/Makefile | ||
18 | index 9ada831..1fd1ccc 100644 | ||
19 | --- a/libau/Makefile | ||
20 | +++ b/libau/Makefile | ||
21 | @@ -30,7 +30,7 @@ STRIP ?= strip | ||
22 | all: ${LibSo} | ||
23 | |||
24 | ifeq (${Glibc},yes) | ||
25 | -LibSoObj += rdu64.o | ||
26 | +#LibSoObj += rdu64.o | ||
27 | |||
28 | # this is unnecessary on 64bit system? | ||
29 | rdu64.c: rdu.c | ||
30 | -- | ||
31 | 2.38.1 | ||
32 | |||
diff --git a/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb b/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb index f565be3f7e..fbf7753b02 100644 --- a/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb +++ b/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb | |||
@@ -12,6 +12,7 @@ SRC_URI = "git://git.code.sf.net/p/aufs/aufs-util;protocol=git;branch=aufs4.9 \ | |||
12 | https://raw.githubusercontent.com/sfjro/aufs4-linux/aufs4.9/include/uapi/linux/aufs_type.h;name=aufs_type \ | 12 | https://raw.githubusercontent.com/sfjro/aufs4-linux/aufs4.9/include/uapi/linux/aufs_type.h;name=aufs_type \ |
13 | file://aufs-util-don-t-strip-executables.patch \ | 13 | file://aufs-util-don-t-strip-executables.patch \ |
14 | file://aufs-util-add-tool-concept-to-Makefile-for-cross-com.patch \ | 14 | file://aufs-util-add-tool-concept-to-Makefile-for-cross-com.patch \ |
15 | file://0001-libau-Do-not-build-LFS-version-of-readdir.patch \ | ||
15 | " | 16 | " |
16 | SRC_URI[aufs_type.md5sum] = "b37129ef0703de72a852db7e48bdedc6" | 17 | SRC_URI[aufs_type.md5sum] = "b37129ef0703de72a852db7e48bdedc6" |
17 | SRC_URI[aufs_type.sha256sum] = "7ff6566adb9c7a3b6862cdc85a690ab546f1d0bc81ddd595fd663c0a69031683" | 18 | SRC_URI[aufs_type.sha256sum] = "7ff6566adb9c7a3b6862cdc85a690ab546f1d0bc81ddd595fd663c0a69031683" |