summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Randle <bill.randle@gmail.com>2017-12-07 21:49:08 -0800
committerArmin Kuster <akuster808@gmail.com>2017-12-22 19:43:54 -0800
commitc8419ea70e5d20932d51696c13349ca9c151d6e6 (patch)
treebad5718587e4d7633208546697d94a6227a2b0c1
parentc970883032ffe2343576b50a9ff71bc25d4b43ea (diff)
downloadmeta-openembedded-c8419ea70e5d20932d51696c13349ca9c151d6e6.tar.gz
python[3]-flask-babel: new recipes
Signed-off-by: Bill Randle <bill.randle@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-flask-babel.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-flask-babel_0.11.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-babel_0.11.2.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-babel.inc b/meta-python/recipes-devtools/python/python-flask-babel.inc
new file mode 100644
index 000000000..b60ee17d1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-babel.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "i18n and l10n support for Flask based on babel and pytz"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=51917f3e8e858f5ae295a7d0e2eb3cc9"
4
5SRC_URI[md5sum] = "07803453743f139309021572a799c6b3"
6SRC_URI[sha256sum] = "c0d75710bd4b0fe866f9f2347de6e19208712f9cec006436b4c1c15d4cb0c939"
7
8PYPI_PACKAGE = "Flask-Babel"
9
10inherit pypi
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-speaklater \
14 ${PYTHON_PN}-babel \
15 ${PYTHON_PN}-flask \
16 "
diff --git a/meta-python/recipes-devtools/python/python-flask-babel_0.11.2.bb b/meta-python/recipes-devtools/python/python-flask-babel_0.11.2.bb
new file mode 100644
index 000000000..38e78c73f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-babel_0.11.2.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools
2require python-flask-babel.inc
diff --git a/meta-python/recipes-devtools/python/python3-flask-babel_0.11.2.bb b/meta-python/recipes-devtools/python/python3-flask-babel_0.11.2.bb
new file mode 100644
index 000000000..104e7c28f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-babel_0.11.2.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-flask-babel.inc