summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRui Costa <rui.ms.costa@ctw.bmwgroup.com>2024-04-15 12:33:34 +0100
committerKhem Raj <raj.khem@gmail.com>2024-04-16 11:00:32 -0700
commitc4107ba77e70451c4033ccee658c19a1da44df4f (patch)
tree3b99749302bb08cd5ac3266df9dcf56d3e206b05
parentad340c8fe23e7043d6fcc815dbf6462a6244352d (diff)
downloadmeta-openembedded-c4107ba77e70451c4033ccee658c19a1da44df4f.tar.gz
avro: extend avro-c++ to native and nativesdk
- fix HOMEPAGE for both avro recipes - fix cmake install paths in patch
-rw-r--r--meta-oe/recipes-support/avro/avro-c++/0001-Remove-cpp-unittest-compilation.patch6
-rw-r--r--meta-oe/recipes-support/avro/avro-c++/0002-Add-package-configuration-files.patch45
-rw-r--r--meta-oe/recipes-support/avro/avro-c++/0003-Update-CXX-standard-to-CXX14.patch10
-rw-r--r--meta-oe/recipes-support/avro/avro-c++_1.11.3.bb4
-rw-r--r--meta-oe/recipes-support/avro/avro-c_1.11.3.bb2
5 files changed, 35 insertions, 32 deletions
diff --git a/meta-oe/recipes-support/avro/avro-c++/0001-Remove-cpp-unittest-compilation.patch b/meta-oe/recipes-support/avro/avro-c++/0001-Remove-cpp-unittest-compilation.patch
index f407fa6ec..bcfafdda5 100644
--- a/meta-oe/recipes-support/avro/avro-c++/0001-Remove-cpp-unittest-compilation.patch
+++ b/meta-oe/recipes-support/avro/avro-c++/0001-Remove-cpp-unittest-compilation.patch
@@ -1,9 +1,10 @@
1From 6be1c45e1f7ee78499bdca76c25ec23a61317134 Mon Sep 17 00:00:00 2001 1From 6be1c45e1f7ee78499bdca76c25ec23a61317134 Mon Sep 17 00:00:00 2001
2From: Rui Costa <rui.ms.costa@ctw.bmwgroup.com> 2From: Rui Costa <rui.ms.costa@ctw.bmwgroup.com>
3Date: Wed, 20 Mar 2024 14:58:27 +0000 3Date: Wed, 20 Mar 2024 14:58:27 +0000
4Subject: [PATCH 1/2] Remove cpp unittest compilation 4Subject: [PATCH] Remove cpp unittest compilation
5 5
6Upstream-Status: Inappropriate [oe-specific] 6Upstream-Status: Inappropriate [oe-specific]
7
7--- 8---
8 lang/c++/CMakeLists.txt | 61 ----------------------------------------- 9 lang/c++/CMakeLists.txt | 61 -----------------------------------------
9 1 file changed, 61 deletions(-) 10 1 file changed, 61 deletions(-)
@@ -83,6 +84,3 @@ index 4a3793152..d94ba42d3 100644
83 include (InstallRequiredSystemLibraries) 84 include (InstallRequiredSystemLibraries)
84 85
85 set (CPACK_PACKAGE_FILE_NAME "avrocpp-${AVRO_VERSION_MAJOR}") 86 set (CPACK_PACKAGE_FILE_NAME "avrocpp-${AVRO_VERSION_MAJOR}")
86--
872.44.0
88
diff --git a/meta-oe/recipes-support/avro/avro-c++/0002-Add-package-configuration-files.patch b/meta-oe/recipes-support/avro/avro-c++/0002-Add-package-configuration-files.patch
index ecb125186..437a3fa13 100644
--- a/meta-oe/recipes-support/avro/avro-c++/0002-Add-package-configuration-files.patch
+++ b/meta-oe/recipes-support/avro/avro-c++/0002-Add-package-configuration-files.patch
@@ -1,39 +1,47 @@
1From 56feaa90d070a5011f380d3ae47c01643b9fafe0 Mon Sep 17 00:00:00 2001 1From 86aa3f2333a9b8e6f1c631e6d5cb7296b6e8380b Mon Sep 17 00:00:00 2001
2From: Rui Costa <rui.ms.costa@ctw.bmwgroup.com> 2From: Rui Costa <rui.ms.costa@ctw.bmwgroup.com>
3Date: Fri, 22 Mar 2024 13:27:38 +0000 3Date: Fri, 22 Mar 2024 13:27:38 +0000
4Subject: [PATCH 2/2] Add package configuration files 4Subject: [PATCH] Add package configuration files
5 5
6Upstream-Status: Pending 6Upstream-Status: Pending
7
7--- 8---
8 lang/c++/CMakeLists.txt | 35 +++++++++++++++++++++++++++--- 9 lang/c++/CMakeLists.txt | 45 ++++++++++++++++++++++++------
9 lang/c++/cmake/AvroCppConfig.cmake | 5 +++++ 10 lang/c++/cmake/AvroCppConfig.cmake | 5 ++++
10 2 files changed, 37 insertions(+), 3 deletions(-) 11 2 files changed, 42 insertions(+), 8 deletions(-)
11 create mode 100644 lang/c++/cmake/AvroCppConfig.cmake 12 create mode 100644 lang/c++/cmake/AvroCppConfig.cmake
12 13
13diff --git a/CMakeLists.txt b/CMakeLists.txt 14diff --git a/CMakeLists.txt b/CMakeLists.txt
14index d94ba42d3..2e5a394cb 100644 15index d94ba42d3..4748b111d 100644
15--- a/CMakeLists.txt 16--- a/CMakeLists.txt
16+++ b/CMakeLists.txt 17+++ b/CMakeLists.txt
17@@ -140,12 +140,16 @@ set (CPACK_PACKAGE_FILE_NAME "avrocpp-${AVRO_VERSION_MAJOR}") 18@@ -140,14 +140,18 @@ set (CPACK_PACKAGE_FILE_NAME "avrocpp-${AVRO_VERSION_MAJOR}")
18 19
19 include (CPack) 20 include (CPack)
20 21
21-install (TARGETS avrocpp avrocpp_s 22-install (TARGETS avrocpp avrocpp_s
23- LIBRARY DESTINATION lib
24- ARCHIVE DESTINATION lib
25- RUNTIME DESTINATION lib)
26-
27-install (TARGETS avrogencpp RUNTIME DESTINATION bin)
28-
29-install (DIRECTORY api/ DESTINATION include/avro
22+install (TARGETS avrocpp 30+install (TARGETS avrocpp
23+ EXPORT AvroCppTargets 31+ EXPORT AvroCppTargets
24 LIBRARY DESTINATION lib 32+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
25 ARCHIVE DESTINATION lib 33+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
26- RUNTIME DESTINATION lib) 34+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}
27+ RUNTIME DESTINATION lib
28+ INCLUDES DESTINATION include) 35+ INCLUDES DESTINATION include)
29 36+
30-install (TARGETS avrogencpp RUNTIME DESTINATION bin)
31+install (TARGETS avrogencpp 37+install (TARGETS avrogencpp
32+ EXPORT AvroCppTargets 38+ EXPORT AvroCppTargets
33+ RUNTIME DESTINATION bin) 39+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
34 40+
35 install (DIRECTORY api/ DESTINATION include/avro 41+install (DIRECTORY api/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/avro
36 FILES_MATCHING PATTERN *.hh) 42 FILES_MATCHING PATTERN *.hh)
43
44 if (NOT CMAKE_BUILD_TYPE)
37@@ -155,3 +159,28 @@ if (NOT CMAKE_BUILD_TYPE) 45@@ -155,3 +159,28 @@ if (NOT CMAKE_BUILD_TYPE)
38 "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel." 46 "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel."
39 FORCE) 47 FORCE)
@@ -52,7 +60,7 @@ index d94ba42d3..2e5a394cb 100644
52+ COPYONLY 60+ COPYONLY
53+) 61+)
54+ 62+
55+set(ConfigPackageLocation lib/cmake/avrocpp) 63+set(ConfigPackageLocation ${CMAKE_INSTALL_LIBDIR}/cmake/avrocpp)
56+install(EXPORT AvroCppTargets 64+install(EXPORT AvroCppTargets
57+ FILE AvroCppTargets.cmake 65+ FILE AvroCppTargets.cmake
58+ NAMESPACE AvroCpp:: 66+ NAMESPACE AvroCpp::
@@ -74,6 +82,3 @@ index 000000000..deb8aaa31
74+ COMPONENTS filesystem iostreams program_options regex system) 82+ COMPONENTS filesystem iostreams program_options regex system)
75+ 83+
76+include("${CMAKE_CURRENT_LIST_DIR}/AvroCppTargets.cmake") 84+include("${CMAKE_CURRENT_LIST_DIR}/AvroCppTargets.cmake")
77--
782.44.0
79
diff --git a/meta-oe/recipes-support/avro/avro-c++/0003-Update-CXX-standard-to-CXX14.patch b/meta-oe/recipes-support/avro/avro-c++/0003-Update-CXX-standard-to-CXX14.patch
index 449b0dfd6..3e65cb7a7 100644
--- a/meta-oe/recipes-support/avro/avro-c++/0003-Update-CXX-standard-to-CXX14.patch
+++ b/meta-oe/recipes-support/avro/avro-c++/0003-Update-CXX-standard-to-CXX14.patch
@@ -1,15 +1,16 @@
1From 640c51c61536913b3d43714bebe228b32f043144 Mon Sep 17 00:00:00 2001 1From 66c08ade24e4472b5af5dca48097ed9a2ec035ec Mon Sep 17 00:00:00 2001
2From: Rui Costa <rui.ms.costa@ctw.bmwgroup.com> 2From: Rui Costa <rui.ms.costa@ctw.bmwgroup.com>
3Date: Fri, 5 Apr 2024 11:33:51 +0000 3Date: Fri, 5 Apr 2024 11:33:51 +0000
4Subject: [PATCH 3/3] Update CXX standard to CXX14 4Subject: [PATCH] Update CXX standard to CXX14
5 5
6Upstream-Status: Inappropriate [oe-specific] 6Upstream-Status: Inappropriate [oe-specific]
7
7--- 8---
8 lang/c++/CMakeLists.txt | 2 +- 9 lang/c++/CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-) 10 1 file changed, 1 insertion(+), 1 deletion(-)
10 11
11diff --git a/CMakeLists.txt b/CMakeLists.txt 12diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 2e5a394cb..f29a532ef 100644 13index 4748b111d..1e45c13d5 100644
13--- a/CMakeLists.txt 14--- a/CMakeLists.txt
14+++ b/CMakeLists.txt 15+++ b/CMakeLists.txt
15@@ -21,7 +21,7 @@ cmake_minimum_required (VERSION 3.1) 16@@ -21,7 +21,7 @@ cmake_minimum_required (VERSION 3.1)
@@ -21,6 +22,3 @@ index 2e5a394cb..f29a532ef 100644
21 endif() 22 endif()
22 23
23 set(CMAKE_CXX_STANDARD_REQUIRED ON) 24 set(CMAKE_CXX_STANDARD_REQUIRED ON)
24--
252.44.0
26
diff --git a/meta-oe/recipes-support/avro/avro-c++_1.11.3.bb b/meta-oe/recipes-support/avro/avro-c++_1.11.3.bb
index 1e4787eb4..6ec25bdd2 100644
--- a/meta-oe/recipes-support/avro/avro-c++_1.11.3.bb
+++ b/meta-oe/recipes-support/avro/avro-c++_1.11.3.bb
@@ -1,5 +1,5 @@
1SUMMARY = "Apache Avro data serialization system." 1SUMMARY = "Apache Avro data serialization system."
2HOMEPAGE = "http://apr.apache.org/" 2HOMEPAGE = "https://avro.apache.org/"
3SECTION = "libs" 3SECTION = "libs"
4 4
5LICENSE = "Apache-2.0" 5LICENSE = "Apache-2.0"
@@ -18,3 +18,5 @@ SRC_URI = "git://github.com/apache/avro;branch=${BRANCH};protocol=https \
18S = "${WORKDIR}/git/lang/c++" 18S = "${WORKDIR}/git/lang/c++"
19 19
20inherit cmake pkgconfig 20inherit cmake pkgconfig
21
22BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-support/avro/avro-c_1.11.3.bb b/meta-oe/recipes-support/avro/avro-c_1.11.3.bb
index 14a3cbe46..bb7f53e45 100644
--- a/meta-oe/recipes-support/avro/avro-c_1.11.3.bb
+++ b/meta-oe/recipes-support/avro/avro-c_1.11.3.bb
@@ -1,5 +1,5 @@
1SUMMARY = "Apache Avro data serialization system." 1SUMMARY = "Apache Avro data serialization system."
2HOMEPAGE = "http://apr.apache.org/" 2HOMEPAGE = "https://avro.apache.org/"
3SECTION = "libs" 3SECTION = "libs"
4 4
5LICENSE = "Apache-2.0" 5LICENSE = "Apache-2.0"