summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-08 15:14:04 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:43:42 -0700
commitc1123ba2327571f036b9a6b3622af53c5c732236 (patch)
treef8ede32779488c0e275dabaea11a1b0b81e9012e
parent257a2f7afb51d9dfd0193c3ee41bc0e6d3211f89 (diff)
downloadmeta-openembedded-c1123ba2327571f036b9a6b3622af53c5c732236.tar.gz
python3-lxml: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-lxml.inc50
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_4.5.0.bb53
2 files changed, 51 insertions, 52 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml.inc b/meta-python/recipes-devtools/python/python-lxml.inc
deleted file mode 100644
index 05b5eae46..000000000
--- a/meta-python/recipes-devtools/python/python-lxml.inc
+++ /dev/null
@@ -1,50 +0,0 @@
1SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
3libxslt libraries. It provides safe and convenient access to these \
4libraries using the ElementTree API. It extends the ElementTree API \
5significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
6C14N and much more."
7HOMEPAGE = "http://codespeak.net/lxml"
8SECTION = "devel/python"
9LICENSE = "BSD & GPLv2 & MIT & PSF"
10LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
11 file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
12 file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
13 file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
14 file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
15 file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
16 file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
17 "
18
19DEPENDS += "libxml2 libxslt"
20
21SRC_URI[md5sum] = "f088e452ed45b030b6f84269f1e84d11"
22SRC_URI[sha256sum] = "8620ce80f50d023d414183bf90cc2576c2837b88e00bea3f33ad2630133bbb60"
23
24DISTUTILS_BUILD_ARGS += " \
25 --with-xslt-config='pkg-config libxslt' \
26 --with-xml2-config='pkg-config libxml-2.0' \
27"
28
29DISTUTILS_INSTALL_ARGS += " \
30 --with-xslt-config='pkg-config libxslt' \
31 --with-xml2-config='pkg-config libxml-2.0' \
32"
33
34inherit pypi
35
36# {standard input}: Assembler messages:
37# {standard input}:1488805: Error: branch out of range
38DEBUG_OPTIMIZATION_remove_mips = " -Og"
39DEBUG_OPTIMIZATION_append_mips = " -O"
40BUILD_OPTIMIZATION_remove_mips = " -Og"
41BUILD_OPTIMIZATION_append_mips = " -O"
42
43DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
44DEBUG_OPTIMIZATION_append_mipsel = " -O"
45BUILD_OPTIMIZATION_remove_mipsel = " -Og"
46BUILD_OPTIMIZATION_append_mipsel = " -O"
47
48BBCLASSEXTEND = "native nativesdk"
49
50RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.5.0.bb b/meta-python/recipes-devtools/python/python3-lxml_4.5.0.bb
index b95d7bae7..e3cfa46d1 100644
--- a/meta-python/recipes-devtools/python/python3-lxml_4.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-lxml_4.5.0.bb
@@ -1,3 +1,52 @@
1inherit setuptools3 1SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2require python-lxml.inc 2DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
3libxslt libraries. It provides safe and convenient access to these \
4libraries using the ElementTree API. It extends the ElementTree API \
5significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
6C14N and much more."
7HOMEPAGE = "http://codespeak.net/lxml"
8SECTION = "devel/python"
9LICENSE = "BSD & GPLv2 & MIT & PSF"
10LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
11 file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
12 file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
13 file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
14 file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
15 file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
16 file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
17 "
18
19DEPENDS += "libxml2 libxslt"
20
21SRC_URI[md5sum] = "f088e452ed45b030b6f84269f1e84d11"
22SRC_URI[sha256sum] = "8620ce80f50d023d414183bf90cc2576c2837b88e00bea3f33ad2630133bbb60"
23
24DISTUTILS_BUILD_ARGS += " \
25 --with-xslt-config='pkg-config libxslt' \
26 --with-xml2-config='pkg-config libxml-2.0' \
27"
28
29DISTUTILS_INSTALL_ARGS += " \
30 --with-xslt-config='pkg-config libxslt' \
31 --with-xml2-config='pkg-config libxml-2.0' \
32"
33
34inherit pypi setuptools3
35
36# {standard input}: Assembler messages:
37# {standard input}:1488805: Error: branch out of range
38DEBUG_OPTIMIZATION_remove_mips = " -Og"
39DEBUG_OPTIMIZATION_append_mips = " -O"
40BUILD_OPTIMIZATION_remove_mips = " -Og"
41BUILD_OPTIMIZATION_append_mips = " -O"
42
43DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
44DEBUG_OPTIMIZATION_append_mipsel = " -O"
45BUILD_OPTIMIZATION_remove_mipsel = " -Og"
46BUILD_OPTIMIZATION_append_mipsel = " -O"
47
48BBCLASSEXTEND = "native nativesdk"
49
50RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
51
3CLEANBROKEN = "1" 52CLEANBROKEN = "1"