summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-17 20:30:27 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-17 16:39:42 -0800
commitbf5ce7551dd745379447395dd9265eeb9fd6a102 (patch)
tree790444ba7f84dc4c31e212f486f3833d5f416d50
parent569cffbd06357bc1307dd9032838c5ca6c4d234e (diff)
downloadmeta-openembedded-bf5ce7551dd745379447395dd9265eeb9fd6a102.tar.gz
python3-propcache: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-propcache/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-propcache_0.2.1.bb12
2 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-propcache/run-ptest b/meta-python/recipes-devtools/python/python3-propcache/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-propcache/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-propcache_0.2.1.bb b/meta-python/recipes-devtools/python/python3-propcache_0.2.1.bb
index 0ea24e8bc3..d15ead9205 100644
--- a/meta-python/recipes-devtools/python/python3-propcache_0.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-propcache_0.2.1.bb
@@ -5,26 +5,16 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5 5
6SRC_URI[sha256sum] = "3f77ce728b19cb537714499928fe800c3dda29e8d9428778fc7c186da4c09a64" 6SRC_URI[sha256sum] = "3f77ce728b19cb537714499928fe800c3dda29e8d9428778fc7c186da4c09a64"
7 7
8inherit pypi python_setuptools_build_meta ptest cython 8inherit pypi python_setuptools_build_meta ptest-python-pytest cython
9
10SRC_URI += " \
11 file://run-ptest \
12"
13 9
14DEPENDS += " \ 10DEPENDS += " \
15 python3-expandvars-native \ 11 python3-expandvars-native \
16" 12"
17 13
18RDEPENDS:${PN}-ptest += " \ 14RDEPENDS:${PN}-ptest += " \
19 python3-pytest \
20 python3-pytest-codspeed \ 15 python3-pytest-codspeed \
21 python3-pytest-xdist \ 16 python3-pytest-xdist \
22 python3-rich \ 17 python3-rich \
23 python3-statistics \ 18 python3-statistics \
24 python3-unittest-automake-output \
25" 19"
26 20
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}