summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2015-08-25 13:19:55 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:11:11 +0200
commitbe019b379479f4df346b34a940ec46aaa3534d22 (patch)
tree9b1ef5828d69c26a1a48ba91ad956f6aca85d6ea
parent0f2b4f7281865ead770335195c5f913eb7523057 (diff)
downloadmeta-openembedded-be019b379479f4df346b34a940ec46aaa3534d22.tar.gz
cim-schema-exper: add new recipe for openlmi
- Cim-schema-exper(Experimental-MOFs) is dependence of openlmi. - Cim-schema_2.40.0.bb is renamed to cim-schema-final_2.40.0.bb. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb28
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb (renamed from meta-networking/recipes-support/cim-schema/cim-schema_2.40.0.bb)2
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema/files/LICENSE34
3 files changed, 64 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
new file mode 100644
index 000000000..62e50df1d
--- /dev/null
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
@@ -0,0 +1,28 @@
1require cim-schema.inc
2
3LICENSE = "DMTF"
4
5RCONFLICTS_${PN} = "cim-schema-final"
6
7SRC_URI = "http://dmtf.org/sites/default/files/cim/cim_schema_v2390/cim_schema_${PV}Experimental-MOFs.zip;subdir=${BPN}-${PV} \
8 file://LICENSE \
9 "
10SRC_URI[md5sum] = "b82b31c609c6bcc69521829409f58ccc"
11SRC_URI[sha256sum] = "ed2096ef1ea25d189a02bbc6603fed7a48297f2987f254265763a6eecb7fc870"
12LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=eecc6f71a56ff3caf17f15bf7aeac7b4"
13
14do_install() {
15 install -d -m 0755 ${D}${datadir}/mof/cimv${PV}/
16 install -d -m 0755 ${D}${datadir}/doc/cim-schema-${PV}
17 install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV}
18
19 cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/
20 for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do
21 sed -i -e 's/\r//g' $i
22 done
23 ln -s cimv${PV} ${D}${datadir}/mof/cim-current
24 ln -s cim_schema_${PV}.mof ${D}${datadir}/mof/cim-current/CIM_Schema.mof
25}
26
27FILES_${PN} = "${datadir}/mof/* ${datadir}/doc/*"
28FILES_${PN}-doc = ""
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema_2.40.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
index ff6c29dc5..1694f3182 100644
--- a/meta-networking/recipes-support/cim-schema/cim-schema_2.40.0.bb
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
@@ -2,6 +2,8 @@ require cim-schema.inc
2 2
3LICENSE = "DMTF" 3LICENSE = "DMTF"
4 4
5RCONFLICTS_${PN} = "cim-schema-exper"
6
5SRC_URI = "http://dmtf.org/sites/default/files/cim/cim_schema_v2400/cim_schema_${PV}Final-MOFs.zip \ 7SRC_URI = "http://dmtf.org/sites/default/files/cim/cim_schema_v2400/cim_schema_${PV}Final-MOFs.zip \
6 file://LICENSE \ 8 file://LICENSE \
7 " 9 "
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema/files/LICENSE b/meta-networking/recipes-support/cim-schema/cim-schema/files/LICENSE
new file mode 100644
index 000000000..54a28120e
--- /dev/null
+++ b/meta-networking/recipes-support/cim-schema/cim-schema/files/LICENSE
@@ -0,0 +1,34 @@
1// Copyright 1998-2008 Distributed Management Task Force, Inc. (DMTF).
2// All rights reserved.
3// DMTF is a not-for-profit association of industry members dedicated
4// to promoting enterprise and systems management and interoperability.
5// DMTF specifications and documents may be reproduced by
6// members and non-members, provided that correct attribution is given.
7// As DMTF specifications may be revised from time to time,
8// the particular version and release date should always be noted.
9//
10// Implementation of certain elements of this standard or proposed
11// standard may be subject to third party patent rights, including
12// provisional patent rights (herein "patent rights"). DMTF makes
13// no representations to users of the standard as to the existence
14// of such rights, and is not responsible to recognize, disclose, or
15// identify any or all such third party patent right, owners or
16// claimants, nor for any incomplete or inaccurate identification or
17// disclosure of such rights, owners or claimants. DMTF shall have no
18// liability to any party, in any manner or circumstance, under any
19// legal theory whatsoever, for failure to recognize, disclose, or
20// identify any such third party patent rights, or for such party's
21// reliance on the standard or incorporation thereof in its product,
22// protocols or testing procedures. DMTF shall have no liability to
23// any party implementing such standard, whether such implementation
24// is foreseeable or not, nor to any patent owner or claimant, and shall
25// have no liability or responsibility for costs or losses incurred if
26// a standard is withdrawn or modified after publication, and shall be
27// indemnified and held harmless by any party implementing the
28// standard from any and all claims of infringement by a patent owner
29// for such implementations.
30//
31// For information about patents held by third-parties which have
32// notified the DMTF that, in their opinion, such patent may relate to
33// or impact implementations of DMTF standards, visit
34// http://www.dmtf.org/about/policies/disclosures.php.