summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Silva <eduardo@monkey.io>2014-10-03 07:51:57 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-06 01:07:52 +0200
commitbde313a10573f7894143dd381b8aa5432711d481 (patch)
tree444b4af18fb3cfab6b3fdae29db5d63e3ab113ce
parent0186f9817848332a43016669e848d2696dacc7da (diff)
downloadmeta-openembedded-bde313a10573f7894143dd381b8aa5432711d481.tar.gz
PolarSSL: new recipe for polarssl v1.3.8
PolarSSL is a lightweight crypto and SSL/TLS library with a strong focus on embedded systems. Signed-off-by: Eduardo Silva <eduardo@monkey.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb b/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb
new file mode 100644
index 000000000..d05f4163a
--- /dev/null
+++ b/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Lightweight crypto and SSL/TLS library"
2DESCRIPTION = "PolarSSL is a fork of the abandonned project XySSL. It \
3is a lean crypto library providing SSL and TLS support \
4in your programs."
5
6HOMEPAGE = "https://polarssl.org"
7BUGTRACKER = "https://github.com/polarssl/polarssl/issues"
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
11
12SECTION = "net"
13
14SRC_URI = "https://polarssl.org/download/polarssl-${PV}-gpl.tgz"
15
16SRC_URI[md5sum] = "d1a2b4f21727e888f143414d2e3144e6"
17SRC_URI[sha256sum] = "318171db41335cacbb5b0047c94f1faf91442ab70a223b5223436703c9406ff1"
18
19RDEPENDS_${PN} += "libcrypto"
20EXTRA_OECMAKE = "-DUSE_SHARED_POLARSSL_LIBRARY=on"
21
22inherit cmake