diff options
author | zangrc <zangrc.fnst@fujitsu.com> | 2021-10-30 01:30:51 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-01 05:41:29 -0700 |
commit | bc8f0c2456434b9b0d878ac3232be09dc8466e21 (patch) | |
tree | 401f27a653c1b2d8d689766a84093e319f6a8153 | |
parent | b1ccba562459c50f1b2d357b93425c9b6bcc8227 (diff) | |
download | meta-openembedded-bc8f0c2456434b9b0d878ac3232be09dc8466e21.tar.gz |
python3-smpplib: upgrade 2.1.0 -> 2.2.0
License-Update: README.md is modified as follows
- client = smpplib.client.Client('example.com', SOMEPORTNUMBER)
+ client = smpplib.client.Client('example.com', SOMEPORTNUMBER, allow_unknown_opt_params=True)
Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb | 24 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb | 30 |
2 files changed, 30 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb b/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb deleted file mode 100644 index 56d8f9eea..000000000 --- a/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | SUMMARY = "SMPP library for python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "GPLv3.0" | ||
4 | LIC_FILES_CHKSUM = "file://README.md;md5=56a03d0ce7e492d4b9487b8aae957efe" | ||
5 | |||
6 | PYPI_PACKAGE = "smpplib" | ||
7 | SRC_URI[sha256sum] = "df4139a279b35fbb42a58f2a254a9c6daf362b04a7f94e208dc120e0b8a3fd4b" | ||
8 | |||
9 | inherit pypi setuptools3 ptest | ||
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | RDEPENDS:${PN}-ptest += " \ | ||
16 | ${PYTHON_PN}-pytest \ | ||
17 | ${PYTHON_PN}-unittest \ | ||
18 | " | ||
19 | |||
20 | do_install_ptest() { | ||
21 | install -d ${D}${PTEST_PATH}/tests | ||
22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
23 | sed -i 's/mock/unittest.mock/g' ${D}${PTEST_PATH}/tests/* | ||
24 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb b/meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb new file mode 100644 index 000000000..00a493914 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "SMPP library for python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "GPLv3.0" | ||
4 | LIC_FILES_CHKSUM = "file://README.md;md5=8b4e2ac8cf248f7b991784f88b630852" | ||
5 | |||
6 | PYPI_PACKAGE = "smpplib" | ||
7 | SRC_URI[sha256sum] = "3d513178a35573f66faac4ef2127c4bd73307ddb463d145b17b013cf709d9ddd" | ||
8 | |||
9 | inherit pypi setuptools3 ptest | ||
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | RDEPENDS:${PN} += " \ | ||
16 | ${PYTHON_PN}-logging \ | ||
17 | ${PYTHON_PN}-six \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS:${PN}-ptest += " \ | ||
21 | ${PYTHON_PN}-pytest \ | ||
22 | ${PYTHON_PN}-unittest \ | ||
23 | ${PYTHON_PN}-profile \ | ||
24 | ${PYTHON_PN}-mock \ | ||
25 | " | ||
26 | |||
27 | do_install_ptest() { | ||
28 | install -d ${D}${PTEST_PATH}/tests | ||
29 | cp -rf ${S}/smpplib/tests/* ${D}${PTEST_PATH}/tests/ | ||
30 | } | ||