summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-30 17:20:53 -0700
committerKhem Raj <raj.khem@gmail.com>2023-03-31 10:42:43 -0700
commitbabd1cbf85f2ddba8380dd74950ce027d097d9da (patch)
treeb2a7ff3911dcabf09b4bdf98fbf4ed4e9f716d95
parent1807ecfe4b4d40df0873210f36276188431383ab (diff)
downloadmeta-openembedded-babd1cbf85f2ddba8380dd74950ce027d097d9da.tar.gz
cyrus-sasl: Fix autoconf patch to work with new autoconf 2.72
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch9
-rw-r--r--meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/avoid-to-call-AC_TRY_RUN.patch73
2 files changed, 32 insertions, 50 deletions
diff --git a/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch
index a6df213fe..3b7054a79 100644
--- a/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch
+++ b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/0001-Fix-time.h-check.patch
@@ -28,11 +28,9 @@ Signed-off-by: Sam James <sam@gentoo.org>
28 plugins/cram.c | 4 ++++ 28 plugins/cram.c | 4 ++++
29 2 files changed, 5 insertions(+), 1 deletion(-) 29 2 files changed, 5 insertions(+), 1 deletion(-)
30 30
31diff --git a/configure.ac b/configure.ac
32index e1bf53b6..ad781830 100644
33--- a/configure.ac 31--- a/configure.ac
34+++ b/configure.ac 32+++ b/configure.ac
35@@ -1290,7 +1290,7 @@ AC_CHECK_HEADERS_ONCE([sys/time.h]) 33@@ -1231,7 +1231,7 @@ AC_CHECK_HEADERS_ONCE([sys/time.h])
36 34
37 AC_HEADER_DIRENT 35 AC_HEADER_DIRENT
38 AC_HEADER_SYS_WAIT 36 AC_HEADER_SYS_WAIT
@@ -41,8 +39,6 @@ index e1bf53b6..ad781830 100644
41 39
42 IPv6_CHECK_SS_FAMILY() 40 IPv6_CHECK_SS_FAMILY()
43 IPv6_CHECK_SA_LEN() 41 IPv6_CHECK_SA_LEN()
44diff --git a/plugins/cram.c b/plugins/cram.c
45index d02e9baa..695aaa91 100644
46--- a/plugins/cram.c 42--- a/plugins/cram.c
47+++ b/plugins/cram.c 43+++ b/plugins/cram.c
48@@ -53,6 +53,10 @@ 44@@ -53,6 +53,10 @@
@@ -56,6 +52,3 @@ index d02e9baa..695aaa91 100644
56 #include <sasl.h> 52 #include <sasl.h>
57 #include <saslplug.h> 53 #include <saslplug.h>
58 #include <saslutil.h> 54 #include <saslutil.h>
59--
602.37.3
61
diff --git a/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/avoid-to-call-AC_TRY_RUN.patch b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/avoid-to-call-AC_TRY_RUN.patch
index 1e6f99603..308d88204 100644
--- a/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/avoid-to-call-AC_TRY_RUN.patch
+++ b/meta-oe/recipes-networking/cyrus-sasl/cyrus-sasl/avoid-to-call-AC_TRY_RUN.patch
@@ -1,50 +1,39 @@
1From 288430d3c2d3f36a4c9d40c4fffa85288f44549a Mon Sep 17 00:00:00 2001 1Remove AC_TRY_RUN
2From: "Roy.Li" <rongqing.li@windriver.com>
3Date: Tue, 25 Jun 2013 09:22:59 +0800
4Subject: [PATCH] Avoid to call AC_TRY_RUN
5 2
6Upstream-Status: Inappropriate [configuration] 3It can not be run during cross compile
7 4
8Avoid to call AC_TRY_RUN to check if GSSAPI libraries support SPNEGO 5Upstream-Status: Inappropriate [Cross-compile specific]
9on cross-compile environment by definition AC_ARG_ENABLE enable-spnego 6Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
11Signed-off-by: Roy.Li <rongqing.li@windriver.com>
12---
13 m4/sasl2.m4 | 14 +++++++++++++-
14 1 file changed, 13 insertions(+), 1 deletion(-)
15
16diff --git a/m4/sasl2.m4 b/m4/sasl2.m4
17index 80371ef..ff70083 100644
18--- a/m4/sasl2.m4 7--- a/m4/sasl2.m4
19+++ b/m4/sasl2.m4 8+++ b/m4/sasl2.m4
20@@ -316,6 +316,18 @@ if test "$gssapi" != no; then 9@@ -316,28 +316,8 @@ if test "$gssapi" != no; then
21 AC_CACHE_CHECK([for SPNEGO support in GSSAPI libraries],[ac_cv_gssapi_supports_spnego],[ 10 AC_CACHE_CHECK([for SPNEGO support in GSSAPI libraries],[ac_cv_gssapi_supports_spnego],[
22 cmu_save_LIBS="$LIBS" 11 cmu_save_LIBS="$LIBS"
23 LIBS="$LIBS $GSSAPIBASE_LIBS" 12 LIBS="$LIBS $GSSAPIBASE_LIBS"
24+ AC_ARG_ENABLE([spnego], 13- AC_TRY_RUN([
25+ [AC_HELP_STRING([--enable-spnego=<DIR>], 14-#ifdef HAVE_GSSAPI_H
26+ [enable SPNEGO support in GSSAPI libraries [no]])], 15-#include <gssapi.h>
27+ [spnego=$enableval], 16-#else
28+ [spnego=no]) 17-#include <gssapi/gssapi.h>
29+ 18-#endif
30+ if test "$spnego" = no; then
31+ echo "no"
32+ elif test "$spnego" = yes; then
33+ AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
34+ else
35+ AC_MSG_CHECKING([for SPNEGO support in GSSAPI libraries])
36 AC_TRY_RUN([
37 #ifdef HAVE_GSSAPI_H
38 #include <gssapi.h>
39@@ -343,7 +355,7 @@ int main(void)
40 AS_IF([test "$ac_cv_gssapi_supports_spnego" = yes],[
41 AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
42 ])
43- 19-
44+ fi 20-int main(void)
45 else 21-{
46 AC_MSG_RESULT([disabled]) 22- gss_OID_desc spnego_oid = { 6, (void *) "\x2b\x06\x01\x05\x05\x02" };
47 fi 23- gss_OID_set mech_set;
48-- 24- OM_uint32 min_stat;
492.25.1 25- int have_spnego = 0;
50 26-
27- if (gss_indicate_mechs(&min_stat, &mech_set) == GSS_S_COMPLETE) {
28- gss_test_oid_set_member(&min_stat, &spnego_oid, mech_set, &have_spnego);
29- gss_release_oid_set(&min_stat, &mech_set);
30- }
31-
32- return (!have_spnego); // 0 = success, 1 = failure
33-}
34-],[ac_cv_gssapi_supports_spnego=yes],[ac_cv_gssapi_supports_spnego=no])
35+ AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
36+ AC_MSG_RESULT(yes)
37 LIBS="$cmu_save_LIBS"
38 ])
39 AS_IF([test "$ac_cv_gssapi_supports_spnego" = yes],[