summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-01 18:16:31 -0800
committerKhem Raj <raj.khem@gmail.com>2021-03-01 21:10:29 -0800
commitb93ec079f96cd3001ccb62d393059ffb2ff0f6ed (patch)
tree5d953f96a81cd415870c30744900cee2b97632d3
parente0c11d2ca4d25962919cebcaeeae9af8f3de6f57 (diff)
downloadmeta-openembedded-b93ec079f96cd3001ccb62d393059ffb2ff0f6ed.tar.gz
glog: Upgrade to 0.4.0
Drop upstreamed patch Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch (renamed from meta-oe/recipes-support/glog/glog/0002-Find-Libunwind-during-configure.patch)40
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch71
-rw-r--r--meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch65
-rw-r--r--meta-oe/recipes-support/glog/glog_0.4.0.bb (renamed from meta-oe/recipes-support/glog/glog_0.3.5.bb)6
4 files changed, 21 insertions, 161 deletions
diff --git a/meta-oe/recipes-support/glog/glog/0002-Find-Libunwind-during-configure.patch b/meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch
index 15cf67fd2..577007a62 100644
--- a/meta-oe/recipes-support/glog/glog/0002-Find-Libunwind-during-configure.patch
+++ b/meta-oe/recipes-support/glog/glog/0001-Find-Libunwind-during-configure.patch
@@ -1,6 +1,5 @@
1diff -uNr a/cmake/FindLibunwind.cmake b/cmake/FindLibunwind.cmake 1--- /dev/null
2--- a/cmake/FindLibunwind.cmake 1970-01-01 01:00:00.000000000 +0100 2+++ b/cmake/FindLibunwind.cmake
3+++ b/cmake/FindLibunwind.cmake 2018-11-20 15:53:48.799078114 +0100
4@@ -0,0 +1,54 @@ 3@@ -0,0 +1,54 @@
5+# - Try to find libunwind 4+# - Try to find libunwind
6+# Once done this will define 5+# Once done this will define
@@ -56,10 +55,9 @@ diff -uNr a/cmake/FindLibunwind.cmake b/cmake/FindLibunwind.cmake
56+else() 55+else()
57+ message("Can't find libunwind library") 56+ message("Can't find libunwind library")
58+endif() 57+endif()
59diff -uNr a/CMakeLists.txt b/CMakeLists.txt 58--- a/CMakeLists.txt
60--- a/CMakeLists.txt 2018-11-20 15:49:07.576278417 +0100 59+++ b/CMakeLists.txt
61+++ b/CMakeLists.txt 2018-11-20 15:49:32.106819928 +0100 60@@ -64,7 +64,6 @@ check_include_file (dlfcn.h HAVE_DLFCN_H
62@@ -58,7 +58,6 @@
63 check_include_file (execinfo.h HAVE_EXECINFO_H) 61 check_include_file (execinfo.h HAVE_EXECINFO_H)
64 check_include_file (glob.h HAVE_GLOB_H) 62 check_include_file (glob.h HAVE_GLOB_H)
65 check_include_file (inttypes.h HAVE_INTTYPES_H) 63 check_include_file (inttypes.h HAVE_INTTYPES_H)
@@ -67,27 +65,28 @@ diff -uNr a/CMakeLists.txt b/CMakeLists.txt
67 check_include_file (memory.h HAVE_MEMORY_H) 65 check_include_file (memory.h HAVE_MEMORY_H)
68 check_include_file (pwd.h HAVE_PWD_H) 66 check_include_file (pwd.h HAVE_PWD_H)
69 check_include_file (stdint.h HAVE_STDINT_H) 67 check_include_file (stdint.h HAVE_STDINT_H)
70@@ -74,7 +73,6 @@ 68@@ -80,7 +79,6 @@ check_include_file (syscall.h HAVE_SYSCA
71 check_include_file (syslog.h HAVE_SYSLOG_H) 69 check_include_file (syslog.h HAVE_SYSLOG_H)
72 check_include_file (ucontext.h HAVE_UCONTEXT_H) 70 check_include_file (ucontext.h HAVE_UCONTEXT_H)
73 check_include_file (unistd.h HAVE_UNISTD_H) 71 check_include_file (unistd.h HAVE_UNISTD_H)
74-check_include_file (unwind.h HAVE_UNWIND_H) 72-check_include_file (unwind.h HAVE_UNWIND_H)
73 check_include_file (pwd.h HAVE_PWD_H)
75 74
76 check_include_file_cxx ("ext/hash_map" HAVE_EXT_HASH_MAP) 75 check_include_file_cxx ("ext/hash_map" HAVE_EXT_HASH_MAP)
77 check_include_file_cxx ("ext/hash_set" HAVE_EXT_HASH_SET) 76@@ -116,11 +114,9 @@ check_cxx_compiler_flag (-Wunnamed-type-
78@@ -109,10 +107,7 @@
79 # snprintf as an inline function 77 # snprintf as an inline function
80 check_symbol_exists (snprintf stdio.h HAVE_SNPRINTF) 78 check_symbol_exists (snprintf stdio.h HAVE_SNPRINTF)
81 79
82-check_library_exists (unwind get_static_proc_name "" HAVE_LIB_UNWIND) 80-check_library_exists (unwind get_static_proc_name "" HAVE_LIB_UNWIND)
83- 81 check_library_exists (dbghelp UnDecorateSymbolName "" HAVE_DBGHELP)
82
84-find_library (UNWIND_LIBRARY NAMES unwind DOC "unwind library") 83-find_library (UNWIND_LIBRARY NAMES unwind DOC "unwind library")
85-mark_as_advanced (UNWIND_LIBRARY) 84-mark_as_advanced (UNWIND_LIBRARY)
86+find_package(Libunwind) 85+find_package(Libunwind)
87 86
88 check_c_source_compiles (" 87 check_c_source_compiles ("
89 #include <stdlib.h> 88 #include <stdlib.h>
90@@ -376,9 +371,9 @@ 89@@ -471,9 +467,9 @@ add_library(glog::glog ALIAS glog)
91 90
92 set_target_properties (glog PROPERTIES POSITION_INDEPENDENT_CODE ON) 91 set_target_properties (glog PROPERTIES POSITION_INDEPENDENT_CODE ON)
93 92
@@ -98,20 +97,19 @@ diff -uNr a/CMakeLists.txt b/CMakeLists.txt
98+ target_link_libraries (glog PUBLIC unwind) 97+ target_link_libraries (glog PUBLIC unwind)
99+endif (Libunwind_FOUND) 98+endif (Libunwind_FOUND)
100 99
101 if (HAVE_PTHREAD) 100 if (HAVE_DBGHELP)
102 target_link_libraries (glog PUBLIC ${CMAKE_THREAD_LIBS_INIT}) 101 target_link_libraries (glog PUBLIC dbghelp)
103@@ -571,6 +566,7 @@ 102@@ -678,6 +674,7 @@ export (PACKAGE glog)
104 install (FILES 103 install (FILES
105 ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake 104 ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
106 ${CMAKE_CURRENT_BINARY_DIR}/glog-config-version.cmake 105 ${CMAKE_CURRENT_BINARY_DIR}/glog-config-version.cmake
107+ ${CMAKE_CURRENT_SOURCE_DIR}/cmake/FindLibunwind.cmake 106+ ${CMAKE_CURRENT_SOURCE_DIR}/cmake/FindLibunwind.cmake
108 DESTINATION lib/cmake/glog) 107 DESTINATION ${_glog_CMake_INSTALLDIR})
109 108
110 install (EXPORT glog-targets NAMESPACE glog:: DESTINATION lib/cmake/glog) 109 install (EXPORT glog-targets NAMESPACE glog:: DESTINATION
111diff -uNr a/glog-config.cmake.in b/glog-config.cmake.in 110--- a/glog-config.cmake.in
112--- a/glog-config.cmake.in 2018-11-20 15:49:07.576278417 +0100 111+++ b/glog-config.cmake.in
113+++ b/glog-config.cmake.in 2018-11-20 15:52:32.330418489 +0100 112@@ -8,4 +8,6 @@ include (CMakeFindDependencyMacro)
114@@ -4,4 +4,6 @@
115 113
116 @gflags_DEPENDENCY@ 114 @gflags_DEPENDENCY@
117 115
diff --git a/meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch b/meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch
deleted file mode 100644
index f41a6c972..000000000
--- a/meta-oe/recipes-support/glog/glog/0001-Rework-CMake-glog-VERSION-management.patch
+++ /dev/null
@@ -1,71 +0,0 @@
1From 4ea11e0d7c0575316a6ccc07a931164ca29c3d2f Mon Sep 17 00:00:00 2001
2From: Corentin Le Molgat <corentinl@google.com>
3Date: Mon, 29 Jan 2018 14:59:08 +0100
4Subject: [PATCH] Rework CMake glog VERSION management.
5
6- Use of Project version properties instead of custom variables
7- fix missmatch between VERSION (build version) and SOVERSION (API version)
8src: https://cmake.org/cmake/help/latest/prop_tgt/VERSION.html#prop_tgt:VERSION
9
10Upstream-Status: Backport [https://github.com/google/glog/commit/6b6e38a7d53fe01f42ce34384cf4ba4c50e8cb65]
11Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12---
13 CMakeLists.txt | 23 ++++++++---------------
14 1 file changed, 8 insertions(+), 15 deletions(-)
15
16diff --git a/CMakeLists.txt b/CMakeLists.txt
17index 7415eab..fb4e408 100644
18--- a/CMakeLists.txt
19+++ b/CMakeLists.txt
20@@ -8,23 +8,16 @@ if (POLICY CMP0063)
21 cmake_policy (SET CMP0063 NEW)
22 endif (POLICY CMP0063)
23
24-project (google-glog)
25+project(glog VERSION 0.3.5 LANGUAGES C CXX)
26
27 enable_testing ()
28
29-set (GLOG_MAJOR_VERSION 0)
30-set (GLOG_MINOR_VERSION 3)
31-set (GLOG_PATCH_VERSION 5)
32-
33-set (GLOG_VERSION
34- ${GLOG_MAJOR_VERSION}.${GLOG_MINOR_VERSION}.${GLOG_PATCH_VERSION})
35-
36 set (CPACK_PACKAGE_NAME glog)
37 set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "")
38-set (CPACK_PACKAGE_VERSION_MAJOR ${GLOG_MAJOR_VERSION})
39-set (CPACK_PACKAGE_VERSION_MINOR ${GLOG_MINOR_VERSION})
40-set (CPACK_PACKAGE_VERSION_PATCH ${GLOG_PATCH_VERSION})
41-set (CPACK_PACKAGE_VERSION ${GLOG_VERSION})
42+set (CPACK_PACKAGE_VERSION_MAJOR ${PROJECT_VERSION_MAJOR})
43+set (CPACK_PACKAGE_VERSION_MINOR ${PROJECT_VERSION_MINOR})
44+set (CPACK_PACKAGE_VERSION_PATCH ${PROJECT_VERSION_PATCH})
45+set (CPACK_PACKAGE_VERSION ${PROJECT_VERSION})
46
47 option (WITH_GFLAGS "Use gflags" ON)
48 option (WITH_THREADS "Enable multithreading support" ON)
49@@ -406,8 +399,8 @@ if (gflags_FOUND)
50 endif (NOT BUILD_SHARED_LIBS)
51 endif (gflags_FOUND)
52
53-set_target_properties (glog PROPERTIES VERSION ${GLOG_MAJOR_VERSION})
54-set_target_properties (glog PROPERTIES SOVERSION ${GLOG_VERSION})
55+set_target_properties (glog PROPERTIES VERSION ${PROJECT_VERSION})
56+set_target_properties (glog PROPERTIES SOVERSION ${PROJECT_VERSION_MAJOR})
57
58 if (WIN32)
59 target_compile_definitions (glog PUBLIC GLOG_NO_ABBREVIATED_SEVERITIES)
60@@ -570,7 +563,7 @@ configure_package_config_file (glog-config.cmake.in
61 NO_CHECK_REQUIRED_COMPONENTS_MACRO)
62
63 write_basic_package_version_file (glog-config-version.cmake VERSION
64- ${GLOG_VERSION} COMPATIBILITY SameMajorVersion)
65+ ${PROJECT_VERSION} COMPATIBILITY SameMajorVersion)
66
67 export (TARGETS glog NAMESPACE glog:: FILE glog-targets.cmake)
68 export (PACKAGE glog)
69--
702.17.1
71
diff --git a/meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch b/meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch
deleted file mode 100644
index 641f70cb2..000000000
--- a/meta-oe/recipes-support/glog/glog/0003-installation-path-fix.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1diff -uNr a/CMakeLists.txt b/CMakeLists.txt
2--- a/CMakeLists.txt 2018-12-05 12:55:59.630792054 +0100
3+++ b/CMakeLists.txt 2018-12-05 13:00:22.922269200 +0100
4@@ -403,10 +403,15 @@
5
6 set_target_properties (glog PROPERTIES PUBLIC_HEADER "${GLOG_PUBLIC_H}")
7
8+set (_glog_CMake_BINDIR ${CMAKE_INSTALL_BINDIR})
9+set (_glog_CMake_INCLUDE_DIR ${CMAKE_INSTALL_INCLUDEDIR})
10+set (_glog_CMake_LIBDIR ${CMAKE_INSTALL_LIBDIR})
11+set (_glog_CMake_INSTALLDIR ${_glog_CMake_LIBDIR}/cmake/glog)
12+
13 target_include_directories (glog BEFORE PUBLIC
14 "$<BUILD_INTERFACE:${CMAKE_CURRENT_BINARY_DIR}>"
15 "$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/src>"
16- "$<INSTALL_INTERFACE:include>"
17+ "$<INSTALL_INTERFACE:${_glog_CMake_INCLUDE_DIR}>"
18 PRIVATE ${CMAKE_CURRENT_BINARY_DIR}
19 PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}/src)
20
21@@ -543,10 +548,10 @@
22
23 install (TARGETS glog
24 EXPORT glog-targets
25- RUNTIME DESTINATION bin
26- PUBLIC_HEADER DESTINATION include/glog
27- LIBRARY DESTINATION lib
28- ARCHIVE DESTINATION lib)
29+ RUNTIME DESTINATION ${_glog_CMake_BINDIR}
30+ PUBLIC_HEADER DESTINATION ${_glog_CMake_INCLUDE_DIR}/glog
31+ LIBRARY DESTINATION ${_glog_CMake_LIBDIR}
32+ ARCHIVE DESTINATION ${_glog_CMake_LIBDIR})
33
34 if (gflags_FOUND)
35 set (gflags_DEPENDENCY "find_dependency (gflags ${gflags_VERSION})")
36@@ -554,7 +559,7 @@
37
38 configure_package_config_file (glog-config.cmake.in
39 ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
40- INSTALL_DESTINATION lib/cmake/glog
41+ INSTALL_DESTINATION ${_glog_CMake_INSTALLDIR}
42 NO_CHECK_REQUIRED_COMPONENTS_MACRO)
43
44 write_basic_package_version_file (glog-config-version.cmake VERSION
45@@ -567,6 +572,7 @@
46 ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
47 ${CMAKE_CURRENT_BINARY_DIR}/glog-config-version.cmake
48 ${CMAKE_CURRENT_SOURCE_DIR}/cmake/FindLibunwind.cmake
49- DESTINATION lib/cmake/glog)
50+ DESTINATION ${_glog_CMake_INSTALLDIR})
51
52-install (EXPORT glog-targets NAMESPACE glog:: DESTINATION lib/cmake/glog)
53+install (EXPORT glog-targets NAMESPACE glog:: DESTINATION
54+ ${_glog_CMake_INSTALLDIR})
55diff -uNr a/glog-config.cmake.in b/glog-config.cmake.in
56--- a/glog-config.cmake.in 2018-12-05 12:55:59.630792054 +0100
57+++ b/glog-config.cmake.in 2018-12-05 13:05:19.547196843 +0100
58@@ -4,6 +4,7 @@
59
60 @gflags_DEPENDENCY@
61
62+list (APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}")
63 find_dependency (Libunwind)
64
65 include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake")
diff --git a/meta-oe/recipes-support/glog/glog_0.3.5.bb b/meta-oe/recipes-support/glog/glog_0.4.0.bb
index 56bf51554..8dc84e412 100644
--- a/meta-oe/recipes-support/glog/glog_0.3.5.bb
+++ b/meta-oe/recipes-support/glog/glog_0.4.0.bb
@@ -8,12 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 git://github.com/google/glog.git;nobranch=1 \ 10 git://github.com/google/glog.git;nobranch=1 \
11 file://0001-Rework-CMake-glog-VERSION-management.patch \ 11 file://0001-Find-Libunwind-during-configure.patch \
12 file://0002-Find-Libunwind-during-configure.patch \
13 file://0003-installation-path-fix.patch \
14" 12"
15 13
16SRCREV = "a6a166db069520dbbd653c97c2e5b12e08a8bb26" 14SRCREV = "96a2f23dca4cc7180821ca5f32e526314395d26a"
17 15
18S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
19 17