diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-11-12 10:59:47 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-16 08:25:15 -0800 |
commit | b6e76246ddea9e87459131a47907d0a29c8b1335 (patch) | |
tree | ab6a0e0a2386cf8166f0fb57c7e47064514b2beb | |
parent | ffacbb167bd7717592c87ec81760a25b51ca1b71 (diff) | |
download | meta-openembedded-b6e76246ddea9e87459131a47907d0a29c8b1335.tar.gz |
python3-yappi: Upgrade 1.3.2 -> 1.3.3
Upgrade to release 1.3.3:
- Fix 3.10 support
- Fix wrong sorting key when tavg is selected
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi/python310.patch | 51 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb (renamed from meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb) | 3 |
2 files changed, 1 insertions, 53 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yappi/python310.patch b/meta-python/recipes-devtools/python/python3-yappi/python310.patch deleted file mode 100644 index 6dd58ae96..000000000 --- a/meta-python/recipes-devtools/python/python3-yappi/python310.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | From d40bc0e8230dd35e05222f5761e3d7f7a75fd46e Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Shadchin <shadchin@yandex-team.ru> | ||
3 | Date: Tue, 1 Jun 2021 02:31:12 +0300 | ||
4 | Subject: [PATCH] Adapt to Python 3.10 beta 1 | ||
5 | |||
6 | Upstream-Status: Backport | ||
7 | Signed-off-by: Alexander Kanavin <alex@linutronix.de> | ||
8 | --- | ||
9 | yappi/_yappi.c | 12 ++++++++++++ | ||
10 | 1 file changed, 12 insertions(+) | ||
11 | |||
12 | diff --git a/yappi/_yappi.c b/yappi/_yappi.c | ||
13 | index 1721280..343130d 100644 | ||
14 | --- a/yappi/_yappi.c | ||
15 | +++ b/yappi/_yappi.c | ||
16 | @@ -1258,7 +1258,11 @@ _resume_greenlet_ctx(_ctx *ctx) | ||
17 | static _ctx * | ||
18 | _bootstrap_thread(PyThreadState *ts) | ||
19 | { | ||
20 | +#if PY_VERSION_HEX < 0x030a00b1 | ||
21 | ts->use_tracing = 1; | ||
22 | +#else | ||
23 | + ts->cframe->use_tracing = 1; | ||
24 | +#endif | ||
25 | ts->c_profilefunc = _yapp_callback; | ||
26 | return NULL; | ||
27 | } | ||
28 | @@ -1289,7 +1293,11 @@ _profile_thread(PyThreadState *ts) | ||
29 | ctx = (_ctx *)it->val; | ||
30 | } | ||
31 | |||
32 | +#if PY_VERSION_HEX < 0x030a00b1 | ||
33 | ts->use_tracing = 1; | ||
34 | +#else | ||
35 | + ts->cframe->use_tracing = 1; | ||
36 | +#endif | ||
37 | ts->c_profilefunc = _yapp_callback; | ||
38 | ctx->id = ctx_id; | ||
39 | ctx->tid = ts->thread_id; | ||
40 | @@ -1306,7 +1314,11 @@ _profile_thread(PyThreadState *ts) | ||
41 | static _ctx* | ||
42 | _unprofile_thread(PyThreadState *ts) | ||
43 | { | ||
44 | +#if PY_VERSION_HEX < 0x030a00b1 | ||
45 | ts->use_tracing = 0; | ||
46 | +#else | ||
47 | + ts->cframe->use_tracing = 0; | ||
48 | +#endif | ||
49 | ts->c_profilefunc = NULL; | ||
50 | |||
51 | return NULL; //dummy return for enum_threads() func. prototype | ||
diff --git a/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb b/meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb index 7cfc84e75..45a5f058a 100644 --- a/meta-python/recipes-devtools/python/python3-yappi_1.3.2.bb +++ b/meta-python/recipes-devtools/python/python3-yappi_1.3.3.bb | |||
@@ -4,12 +4,11 @@ HOMEPAGE = "https://github.com/sumerc/yappi" | |||
4 | LICENSE = "MIT" | 4 | LICENSE = "MIT" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee" |
6 | 6 | ||
7 | SRC_URI[sha256sum] = "a51d3e6e5563cc74b5bb82ed6e7bd44a9c1a7eae3d97e4d52e9465edb3a8da8d" | 7 | SRC_URI[sha256sum] = "855890cd9a90d833dd2df632d648de8ccd0a4c3131f1edc8abd004db0625b5e8" |
8 | 8 | ||
9 | SRC_URI += " \ | 9 | SRC_URI += " \ |
10 | file://run-ptest \ | 10 | file://run-ptest \ |
11 | file://0001-Fix-imports-for-ptests.patch \ | 11 | file://0001-Fix-imports-for-ptests.patch \ |
12 | file://python310.patch \ | ||
13 | " | 12 | " |
14 | 13 | ||
15 | inherit pypi setuptools3 ptest | 14 | inherit pypi setuptools3 ptest |