summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2024-01-01 15:49:54 +0800
committerKhem Raj <raj.khem@gmail.com>2024-01-08 19:54:39 -0800
commitb2ba89eb89126360830b365f958f24f0a3528661 (patch)
tree319b7d5ee5f91eaac218d1d81067cbbc5c2a0ec7
parentf38b0faa6b9dbbc288f7e41f7d033d0c29ac98bd (diff)
downloadmeta-openembedded-b2ba89eb89126360830b365f958f24f0a3528661.tar.gz
libtdb: upgrade 1.4.8 -> 1.4.9
* Remove PACKAGECONFIG[libaio] as libaio is no longer required by libtdb. * Add ptest. * Refresh patches. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch48
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb/0002-Fix-pyext_PATTERN-for-cross-compilation.patch6
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb/run-ptest17
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb_1.4.9.bb (renamed from meta-networking/recipes-support/libtdb/libtdb_1.4.8.bb)19
4 files changed, 53 insertions, 37 deletions
diff --git a/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch b/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch
index 93a85e854..477b1cec7 100644
--- a/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch
+++ b/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch
@@ -1,4 +1,4 @@
1From d3b1d23e01e323b9610843ab6bef096512f6c244 Mon Sep 17 00:00:00 2001 1From 613cfb43622f0138edfcf3ad7a8fecc568e17db4 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com> 2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 19 Jun 2019 17:53:34 +0800 3Date: Wed, 19 Jun 2019 17:53:34 +0800
4Subject: [PATCH] tdb: Add configure options for packages 4Subject: [PATCH] tdb: Add configure options for packages
@@ -6,7 +6,6 @@ Subject: [PATCH] tdb: Add configure options for packages
6Add configure options for the following packages: 6Add configure options for the following packages:
7 - acl 7 - acl
8 - attr 8 - attr
9 - libaio
10 - libbsd 9 - libbsd
11 - libcap 10 - libcap
12 - valgrind 11 - valgrind
@@ -18,16 +17,20 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
18Update to 1.4.0 17Update to 1.4.0
19 18
20Signed-off-by: Changqing Li <changqing.li@windriver.com> 19Signed-off-by: Changqing Li <changqing.li@windriver.com>
20
21Rebase to 1.4.9
22Remove libaio option
23Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
21--- 24---
22 lib/replace/wscript | 92 ++++++++++++++++++++++++++++++++++----------- 25 lib/replace/wscript | 79 +++++++++++++++++++++++++++++++++------------
23 wscript | 6 +++ 26 wscript | 6 ++++
24 2 files changed, 77 insertions(+), 21 deletions(-) 27 2 files changed, 65 insertions(+), 20 deletions(-)
25 28
26diff --git a/lib/replace/wscript b/lib/replace/wscript 29diff --git a/lib/replace/wscript b/lib/replace/wscript
27index 827d74f..70cde6f 100644 30index 199e636..cb13b62 100644
28--- a/lib/replace/wscript 31--- a/lib/replace/wscript
29+++ b/lib/replace/wscript 32+++ b/lib/replace/wscript
30@@ -25,6 +25,41 @@ def options(opt): 33@@ -25,6 +25,34 @@ def options(opt):
31 opt.PRIVATE_EXTENSION_DEFAULT('') 34 opt.PRIVATE_EXTENSION_DEFAULT('')
32 opt.RECURSE('buildtools/wafsamba') 35 opt.RECURSE('buildtools/wafsamba')
33 36
@@ -45,13 +48,6 @@ index 827d74f..70cde6f 100644
45+ help=("Disable use of attr"), 48+ help=("Disable use of attr"),
46+ action="store_false", dest='enable_attr', default=False) 49+ action="store_false", dest='enable_attr', default=False)
47+ 50+
48+ opt.add_option('--with-libaio',
49+ help=("Enable use of libaio"),
50+ action="store_true", dest='enable_libaio')
51+ opt.add_option('--without-libaio',
52+ help=("Disable use of libaio"),
53+ action="store_false", dest='enable_libaio', default=False)
54+
55+ opt.add_option('--with-libbsd', 51+ opt.add_option('--with-libbsd',
56+ help=("Enable use of libbsd"), 52+ help=("Enable use of libbsd"),
57+ action="store_true", dest='enable_libbsd') 53+ action="store_true", dest='enable_libbsd')
@@ -69,51 +65,45 @@ index 827d74f..70cde6f 100644
69 @Utils.run_once 65 @Utils.run_once
70 def configure(conf): 66 def configure(conf):
71 conf.RECURSE('buildtools/wafsamba') 67 conf.RECURSE('buildtools/wafsamba')
72@@ -35,12 +70,25 @@ def configure(conf): 68@@ -38,12 +66,21 @@ def configure(conf):
73 conf.DEFINE('HAVE_LIBREPLACE', 1) 69 conf.DEFINE('HAVE_LIBREPLACE', 1)
74 conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1) 70 conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1)
75 71
76- conf.CHECK_HEADERS('linux/types.h crypt.h locale.h acl/libacl.h compat.h') 72- conf.CHECK_HEADERS('linux/types.h crypt.h locale.h acl/libacl.h compat.h')
77- conf.CHECK_HEADERS('acl/libacl.h attr/xattr.h compat.h ctype.h dustat.h') 73- conf.CHECK_HEADERS('acl/libacl.h attr/xattr.h compat.h ctype.h dustat.h')
78+ conf.CHECK_HEADERS('linux/types.h crypt.h locale.h compat.h') 74+ conf.CHECK_HEADERS('linux/types.h crypt.h locale.h compat.h')
79+ conf.CHECK_HEADERS('attr/xattr.h compat.h ctype.h dustat.h') 75+ conf.CHECK_HEADERS('compat.h ctype.h dustat.h')
80 conf.CHECK_HEADERS('fcntl.h fnmatch.h glob.h history.h krb5.h langinfo.h') 76 conf.CHECK_HEADERS('fcntl.h fnmatch.h glob.h history.h krb5.h langinfo.h')
81 conf.CHECK_HEADERS('locale.h ndir.h pwd.h') 77 conf.CHECK_HEADERS('locale.h ndir.h pwd.h')
82- conf.CHECK_HEADERS('shadow.h sys/acl.h') 78- conf.CHECK_HEADERS('shadow.h sys/acl.h')
83- conf.CHECK_HEADERS('sys/attributes.h attr/attributes.h sys/capability.h sys/dir.h sys/epoll.h') 79- conf.CHECK_HEADERS('sys/attributes.h attr/attributes.h sys/capability.h sys/dir.h sys/epoll.h')
84+ conf.CHECK_HEADERS('shadow.h') 80+ conf.CHECK_HEADERS('shadow.h')
85+ conf.CHECK_HEADERS('sys/attributes.h sys/dir.h sys/epoll.h') 81+ conf.CHECK_HEADERS('sys/attributes.h sys/dir.h sys/epoll.h')
86+
87+ if Options.options.enable_acl: 82+ if Options.options.enable_acl:
88+ conf.CHECK_HEADERS('acl/libacl.h sys/acl.h') 83+ conf.CHECK_HEADERS('acl/libacl.h sys/acl.h')
89+ 84+
90+ if Options.options.enable_attr: 85+ if Options.options.enable_attr:
91+ conf.CHECK_HEADERS('attr/attributes.h attr/xattr.h') 86+ conf.CHECK_HEADERS('attr/attributes.h attr/xattr.h')
92+ 87+
93+ if Options.options.enable_libaio:
94+ conf.CHECK_HEADERS('libaio.h')
95+
96+ if Options.options.enable_libcap: 88+ if Options.options.enable_libcap:
97+ conf.CHECK_HEADERS('sys/capability.h') 89+ conf.CHECK_HEADERS('sys/capability.h')
98+ 90+
99 conf.CHECK_HEADERS('port.h')
100 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h') 91 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h')
101 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h') 92 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h')
102@@ -110,9 +158,10 @@ def configure(conf): 93 conf.CHECK_HEADERS('sys/resource.h sys/security.h sys/shm.h sys/statfs.h sys/statvfs.h sys/termio.h')
94@@ -113,8 +150,9 @@ def configure(conf):
103 conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h') 95 conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h')
104 conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h') 96 conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h')
105 97
106- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h') 98- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h')
107- conf.CHECK_HEADERS('valgrind/memcheck.h valgrind/helgrind.h') 99- conf.CHECK_HEADERS('valgrind/memcheck.h valgrind/helgrind.h valgrind/callgrind.h')
108- conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
109+ if Options.options.enable_valgrind: 100+ if Options.options.enable_valgrind:
110+ conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h') 101+ conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h')
111+ conf.CHECK_HEADERS('valgrind/memcheck.h valgrind/helgrind.h') 102+ conf.CHECK_HEADERS('valgrind/memcheck.h valgrind/helgrind.h valgrind/callgrind.h')
112+ 103 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
113 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') 104 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
114 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') 105 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
115 conf.CHECK_HEADERS('syscall.h sys/syscall.h inttypes.h') 106@@ -443,20 +481,21 @@ def configure(conf):
116@@ -431,20 +480,21 @@ def configure(conf):
117 107
118 strlcpy_in_bsd = False 108 strlcpy_in_bsd = False
119 109
@@ -150,7 +140,7 @@ index 827d74f..70cde6f 100644
150 conf.CHECK_CODE(''' 140 conf.CHECK_CODE('''
151 struct ucred cred; 141 struct ucred cred;
152diff --git a/wscript b/wscript 142diff --git a/wscript b/wscript
153index 71ada31..10b16a7 100644 143index 5e6a928..5443b43 100644
154--- a/wscript 144--- a/wscript
155+++ b/wscript 145+++ b/wscript
156@@ -69,6 +69,12 @@ def options(opt): 146@@ -69,6 +69,12 @@ def options(opt):
diff --git a/meta-networking/recipes-support/libtdb/libtdb/0002-Fix-pyext_PATTERN-for-cross-compilation.patch b/meta-networking/recipes-support/libtdb/libtdb/0002-Fix-pyext_PATTERN-for-cross-compilation.patch
index 6bd118b53..00ec8a477 100644
--- a/meta-networking/recipes-support/libtdb/libtdb/0002-Fix-pyext_PATTERN-for-cross-compilation.patch
+++ b/meta-networking/recipes-support/libtdb/libtdb/0002-Fix-pyext_PATTERN-for-cross-compilation.patch
@@ -1,4 +1,4 @@
1From 10b4546edb194ede7a5e8bb5e4c9f5fdc67984eb Mon Sep 17 00:00:00 2001 1From de39c696a62894fd9c6626d3e2931e42e3407be5 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com> 2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Wed, 24 Nov 2021 13:33:35 +0800 3Date: Wed, 24 Nov 2021 13:33:35 +0800
4Subject: [PATCH] Fix pyext_PATTERN for cross compilation 4Subject: [PATCH] Fix pyext_PATTERN for cross compilation
@@ -25,10 +25,10 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
25 1 file changed, 1 insertion(+), 1 deletion(-) 25 1 file changed, 1 insertion(+), 1 deletion(-)
26 26
27diff --git a/third_party/waf/waflib/Tools/python.py b/third_party/waf/waflib/Tools/python.py 27diff --git a/third_party/waf/waflib/Tools/python.py b/third_party/waf/waflib/Tools/python.py
28index a23bd01..af202e0 100644 28index b2dd1a9..2bd3545 100644
29--- a/third_party/waf/waflib/Tools/python.py 29--- a/third_party/waf/waflib/Tools/python.py
30+++ b/third_party/waf/waflib/Tools/python.py 30+++ b/third_party/waf/waflib/Tools/python.py
31@@ -328,7 +328,7 @@ def check_python_headers(conf, features='pyembed pyext'): 31@@ -339,7 +339,7 @@ def check_python_headers(conf, features='pyembed pyext'):
32 x = 'MACOSX_DEPLOYMENT_TARGET' 32 x = 'MACOSX_DEPLOYMENT_TARGET'
33 if dct[x]: 33 if dct[x]:
34 env[x] = conf.environ[x] = str(dct[x]) 34 env[x] = conf.environ[x] = str(dct[x])
diff --git a/meta-networking/recipes-support/libtdb/libtdb/run-ptest b/meta-networking/recipes-support/libtdb/libtdb/run-ptest
new file mode 100644
index 000000000..7bc56f77c
--- /dev/null
+++ b/meta-networking/recipes-support/libtdb/libtdb/run-ptest
@@ -0,0 +1,17 @@
1#!/bin/sh
2
3ptestdir=$(dirname "$(readlink -f "$0")")
4cd "$ptestdir"/tests || exit
5
6tests=$(find * -type f -name 'tdb1-*')
7
8for f in replace_testsuite $tests
9do
10 if test -x ./"$f"; then
11 if ./"$f" > ./"$f".out 2> ./"$f".err; then
12 echo "PASS: $f"
13 else
14 echo "FAIL: $f"
15 fi
16 fi
17done
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.4.8.bb b/meta-networking/recipes-support/libtdb/libtdb_1.4.9.bb
index 5dc87bd91..248b72967 100644
--- a/meta-networking/recipes-support/libtdb/libtdb_1.4.8.bb
+++ b/meta-networking/recipes-support/libtdb/libtdb_1.4.9.bb
@@ -11,9 +11,10 @@ export PYTHONHASHSEED="1"
11SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \ 11SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
12 file://0001-tdb-Add-configure-options-for-packages.patch \ 12 file://0001-tdb-Add-configure-options-for-packages.patch \
13 file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \ 13 file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
14 file://run-ptest \
14" 15"
15 16
16SRC_URI[sha256sum] = "8434c9c857d13ce3fa8466f75601f25c3693676b36919f159e0ad6121baf5ce8" 17SRC_URI[sha256sum] = "0ac226073e3a2db8648da7af744cb95f50766a52feeb001d558b2b321b74a765"
17 18
18PACKAGECONFIG ??= "\ 19PACKAGECONFIG ??= "\
19 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \ 20 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
@@ -22,17 +23,16 @@ PACKAGECONFIG ??= "\
22 23
23PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl" 24PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
24PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr" 25PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
25PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
26PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd" 26PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
27PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap" 27PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
28PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind" 28PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
29 29
30S = "${WORKDIR}/tdb-${PV}" 30S = "${WORKDIR}/tdb-${PV}"
31 31
32inherit waf-samba 32inherit waf-samba pkgconfig ptest
33 33
34#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen 34# Cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
35#to cross Popen 35# to cross Popen
36export WAF_NO_PREFORK="yes" 36export WAF_NO_PREFORK="yes"
37 37
38EXTRA_OECONF += "--disable-rpath \ 38EXTRA_OECONF += "--disable-rpath \
@@ -42,6 +42,15 @@ EXTRA_OECONF += "--disable-rpath \
42 --with-libiconv=${STAGING_DIR_HOST}${prefix}\ 42 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
43 " 43 "
44 44
45do_install_ptest() {
46 install -d ${D}${PTEST_PATH}/tests
47 install -m 0755 ${B}/bin/tdb1-* ${D}${PTEST_PATH}/tests/
48 install -m 0755 ${B}/bin/replace_testsuite ${D}${PTEST_PATH}/tests/
49 install -d ${D}${PTEST_PATH}/tests/test
50 install -m 0644 ${B}/test/*.tdb ${D}${PTEST_PATH}/tests/test/
51 install -m 0644 ${B}/test/*.corrupt ${D}${PTEST_PATH}/tests/test/
52}
53
45PACKAGES += "tdb-tools python3-tdb" 54PACKAGES += "tdb-tools python3-tdb"
46 55
47RPROVIDES:${PN}-dbg += "python3-tdb-dbg" 56RPROVIDES:${PN}-dbg += "python3-tdb-dbg"