summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-14 11:52:45 +0000
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commitb298118df9cc1b633df82f06c485d489429428f7 (patch)
tree81d44627c1357a94b02ef023006b354cfad9d164
parente0a506536545e0a97a645093c75f9570d5aa94d4 (diff)
downloadmeta-openembedded-b298118df9cc1b633df82f06c485d489429428f7.tar.gz
iotop: move to the C port of iotop
The Python iotop implentation hasn't had a release since 2013[1], and there is a C port which is actively maintained and will have a lower impact on the system being monitored. [1] https://repo.or.cz/iotop.git/tag/10c60fedf5051421f4e62b89e2e51e7cc669ce34 Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_0.6.bb29
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_1.20.bb17
2 files changed, 17 insertions, 29 deletions
diff --git a/meta-oe/recipes-extended/iotop/iotop_0.6.bb b/meta-oe/recipes-extended/iotop/iotop_0.6.bb
deleted file mode 100644
index 97958dd4a..000000000
--- a/meta-oe/recipes-extended/iotop/iotop_0.6.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Simple top-like I/O monitor"
2DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
3 It watches I/O usage information output by the Linux kernel and displays \
4 a table of current I/O usage by processes on the system."
5HOMEPAGE = "http://guichaz.free.fr/iotop/"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
9
10PV .= "+git${SRCPV}"
11
12SRCREV = "1bfb3bc70febb1ffb95146b6dcd65257228099a3"
13SRC_URI = "git://repo.or.cz/iotop.git;branch=master"
14
15S = "${WORKDIR}/git"
16
17UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
18UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
19
20inherit distutils3
21
22do_install:append() {
23 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
24 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
25}
26
27RDEPENDS:${PN} = "python3-curses \
28 python3-codecs python3-ctypes python3-pprint \
29 python3-shell python3-core"
diff --git a/meta-oe/recipes-extended/iotop/iotop_1.20.bb b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
new file mode 100644
index 000000000..17c567095
--- /dev/null
+++ b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
@@ -0,0 +1,17 @@
1SUMMARY = "A top utility for I/O"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=48e7be78bd2671d08c9c3bad71f1cfaa"
4
5DEPENDS = "ncurses"
6
7SRC_URI = "https://github.com/Tomas-M/iotop/releases/download/v1.20/iotop-1.20.tar.xz"
8SRC_URI[sha256sum] = "e0227dd4b71ce3ffe50225b85cf9abb38a99c1d2dff69e3f1db7d059d7490d51"
9UPSTREAM_CHECK_URI = "https://github.com/Tomas-M/iotop/releases"
10
11inherit pkgconfig
12
13EXTRA_OEMAKE = "V=1 STRIP=true"
14
15do_install() {
16 oe_runmake install DESTDIR=${D}
17}