summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-10 10:13:24 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-10 10:13:24 +0200
commitb038ad87179391284e0829b6f92b463ba961f1e1 (patch)
tree141f3835739c38e82766923e518c43b070b21d8e
parent69fd0f67c4de99d01b643e32858565d40eaab803 (diff)
downloadmeta-openembedded-b038ad87179391284e0829b6f92b463ba961f1e1.tar.gz
nautilus: add 2.32.2
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch7
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff28
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb39
3 files changed, 74 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch b/meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch
new file mode 100644
index 000000000..0062cfb11
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch
@@ -0,0 +1,7 @@
1Index: nautilus-2.24.2/add-include-prefix
2===================================================================
3--- nautilus-2.24.2.orig/add-include-prefix 2008-10-06 17:22:21.000000000 +0000
4+++ nautilus-2.24.2/add-include-prefix 2009-04-09 16:00:05.000000000 +0000
5@@ -1 +1 @@
6-sed -e 's/^/ /' -e 's/ */ /g' -e 's/ / -I /g' -e 's/ -I $//'
7+sed -e 's:^: :' -e 's: *: :g' -e 's: : -I '"$SYSROOT"':g' -e 's: -I '"$SYSROOT"'$::'
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff b/meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff
new file mode 100644
index 000000000..ccd2934b3
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff
@@ -0,0 +1,28 @@
1--- /tmp/configure.in 2009-04-13 11:26:43.000000000 +0200
2+++ nautilus-2.26.1/configure.in 2009-04-13 11:28:37.000000000 +0200
3@@ -375,25 +375,6 @@
4
5 dnl ===========================================================================
6
7-dnl strftime checks
8-
9-AC_TRY_RUN([#include <time.h>
10- int main ()
11- {
12- char buf[100];
13- struct tm tm = {0};
14- tm.tm_year = 99;
15- if (strftime(buf, 100, "%EY", &tm) == 4 &&
16- strcmp (buf, "1999")==0)
17- return 0;
18- return 1;
19- }
20- ],
21- AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
22- )
23-
24-dnl ===========================================================================
25-
26 #
27 # Checks for Xft/XRender
28 #
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb
new file mode 100644
index 000000000..4cd3c690e
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb
@@ -0,0 +1,39 @@
1# nautilus OE build file
2# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
3# Released under the MIT license (see packages/COPYING)
4
5LICENSE="GPLv2 && LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7c0048536e43642a1f3a724c2909872b \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9DEPENDS = "libunique gvfs librsvg libexif esound gnome-desktop orbit2-native"
10# optional: tracker
11
12inherit gnome
13
14SRC_URI[archive.md5sum] = "51565aa10d1625dff56e381228346911"
15SRC_URI[archive.sha256sum] = "2d4ff28c7a7aa5d40eb2468149954a564c257a305183773057584d22d15347a2"
16
17SRC_URI += "file://idl-sysroot.patch \
18 file://no-try-run-strftime.diff \
19"
20
21
22EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
23export SYSROOT = "${STAGING_DIR_HOST}"
24
25do_configure() {
26 sed -i -e /docs/d Makefile.am
27 autotools_do_configure
28 # We need native orbit-idl with target idl files. No way to say it in a clean way:
29 find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
30}
31
32PACKAGES += " libnautilus"
33
34RDEPENDS_${PN} = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
35FILES_${PN} += "${datadir}/icons /usr/libexec/ "
36FILES_libnautilus = "/usr/lib/*.so*"
37FILES_${PN}-dbg += "/usr/libexec/.debug"
38
39